Results 1 to 4 of 4

Thread: Need some help with dconf CLI nomenclature

  1. #1
    Join Date
    Apr 2008
    Beans
    10,770

    Need some help with dconf CLI nomenclature

    I'm trying to work on a Trusty update to my Precise Classic thread:

    http://ubuntuforums.org/showthread.php?t=1966370

    Using dconf Editor I found what I was looking for in "org.gnome.desktop.wm.keybindings panel-run-dialog":

    Screenshot from 2014-04-18 14:21:52.jpg

    Oddly it was set to disabled even though the default is Alt+F2.

    Anyway I was able to fix it just by clicking on Set to Default, but I'd like to be able to change that setting via CLI, eg;

    NOTE: these do NOT work - therefore no code tags

    gsettings set org.gnome.desktop.wm.keybindings panel-run-dialog ['<Alt>F2']

    gsettings set org.gnome.desktop.wm.keybindings panel-run-dialog ['disabled']

    I've also been playing with variants like:

    dconf reset -f /org/gnome/desktop/wm/keybindings panel-run-dialog

    But to no avail

    I'm having a very tough time figuring out some stuff - like restoring all defaults - since the flashback sessions started using 'unity-settings-daemon' and 'unity-control-center' instead of the GNOME versions of those same packages.

    Any thoughts?
    Last edited by kansasnoob; April 18th, 2014 at 08:46 PM. Reason: tweaked title

  2. #2
    Join Date
    Jun 2007
    Beans
    13,059

    Re: Need some help with dconf CLI nomenclature

    You need to quote the 'as', ie.
    Code:
    gsettings set org.gnome.desktop.wm.keybindings panel-run-dialog "['<Alt>F2']"

  3. #3
    Join Date
    Apr 2008
    Beans
    10,770

    Re: Need some help with dconf CLI nomenclature

    Quote Originally Posted by mc4man View Post
    You need to quote the 'as', ie.
    Code:
    gsettings set org.gnome.desktop.wm.keybindings panel-run-dialog "['<Alt>F2']"
    Thank you.

  4. #4
    Join Date
    Apr 2008
    Beans
    10,770

    Re: Need some help with dconf CLI nomenclature

    This seems to be working OK:

    Code:
    gsettings set org.gnome.desktop.wm.keybindings panel-run-dialog "['<Alt>F2']"
    Still studying variants:

    gsettings reset org.gnome.desktop.wm.keybindings panel-run-dialog

    dconf reset -f /org/gnome/desktop/wm/keybindings panel-run-dialog

    The man pages for gsettings are at the very least confusing

    But I have this working now:

    run_app.jpg

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •