Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Can't get old Windows drive access

  1. #1
    Join Date
    Mar 2008
    Beans
    319

    Can't get old Windows drive access

    I went and deleted my Windows section, and used GPartEd to format the partition Ext4.

    Now it says the permissions are all Root, and I don't have access to this empty drive.

    I hope this is an easy fix...
    Every time I hear the word "Progress" my fur bristles!

  2. #2
    Join Date
    Jan 2012
    Location
    London, UK
    Beans
    603
    Distro
    Ubuntu Development Release

    Re: Can't get old Windows drive access

    Usually it's just the /etc/fstab file.
    try opening with gedit and positng the contents?

    Jj
    Love Ubuntu? If you feel like donating to future development, and suggest how that donation is used by the community, it's all here!

  3. #3
    Join Date
    Mar 2008
    Beans
    319

    Re: Can't get old Windows drive access

    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # / was on /dev/sda5 during installation
    UUID=017601ed-1684-49ee-9d88-48a4d132cebf / ext4 errors=remount-ro 0 1
    # swap was on /dev/sda6 during installation
    UUID=85104470-f87c-426b-ba8e-5e918f27a01e none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    Every time I hear the word "Progress" my fur bristles!

  4. #4
    Join Date
    Jan 2012
    Location
    London, UK
    Beans
    603
    Distro
    Ubuntu Development Release

    Re: Can't get old Windows drive access

    Hi there!

    was wirth a shot, not auto mounting at set up.

    To see who owns the partition:
    Code:
    ls -l /dev/sdax
    you want your user name to be in the output before root. If it says root root or other users root, thats the problem.

    To take ownership, use chown:
    Code:
    sudo chown username /dev/sdax
    note that /dev/sdax could also be where the partition is mounted ie /media/bobs.hdd

    To change ownership and add to group:
    Code:
    sudo chown user:user /dev/sdax
    note that :user can be whichever group you want to add it too


    If you want it to be automatically mounted at boot, an example fstab entry would be:
    Code:
    #my ext4 partition on /dev/sdax
    UUID=0000-1111-2222-3333     /media/where.to.mount    ext4    rw,user,auto    0    0
    Your partition's UUID can be found with
    Code:
    blkid

    hope it helps!

    sorry for late reply, real world got in the way!

    Jj
    Love Ubuntu? If you feel like donating to future development, and suggest how that donation is used by the community, it's all here!

  5. #5
    Join Date
    Dec 2009
    Beans
    5,422

    Re: Can't get old Windows drive access

    [1] You don't want to change ownership or permissions on anything in /dev - that's a system directory and it's meant to be owned by root.

    [2] You want to change ownership on the mounted partition.

    You didn't post what version of Ubuntu you are using so the partition can be mounted in one of 3 locations. To take ownership of the partition:

    Code:
    sudo chown your-user-name /media/something
    OR
    Code:
    sudo chown your-user-name /media/your-user-name/something
    OR
    Code:
    sudo chown your-user-name /media/1000/something
    You can also do this graphically with a sudo instance of nautilus:
    Code:
    gksu nautilus /media
    Then just right click the mounted partition and change ownership to you.

    [3] If you are going to automount it in fstab and you want to use the previosly posted suggestion you are going to have to add another option since the "user" option ( which has no meaning in this context ) disables exec:
    UUID=0000-1111-2222-3333 /media/where.to.mount ext4 rw,user,auto,exec 0 0
    Or you can just make the line look like this:
    Code:
    UUID=0000-1111-2222-3333     /media/where.to.mount    ext4 defaults    0    0
    defaults = rw, exec, auto, nouser.
    Last edited by Morbius1; April 13th, 2014 at 01:10 PM.

  6. #6
    Join Date
    Mar 2008
    Beans
    319

    Re: Can't get old Windows drive access


    If you want it to be automatically mounted at boot, an example fstab entry would be:
    Code:
    #my ext4 partition on /dev/sdax
    UUID=0000-1111-2222-3333     /media/where.to.mount    ext4    rw,user,auto    0    0
    This part I didn't understand. However:

    zaivala@zaivala-desktop:~$ ls -l /dev/sda1
    brw-rw---- 1 root disk 8, 1 Apr 13 09:41 /dev/sda1
    zaivala@zaivala-desktop:~$ sudo chown zaivala /dev/sda1
    [sudo] password for zaivala:
    zaivala@zaivala-desktop:~$ ls -l /dev/sda1
    brw-rw---- 1 zaivala disk 8, 1 Apr 13 09:41 /dev/sda1
    zaivala@zaivala-desktop:~$ sudo chown zaivala:zaivala /dev/sda1
    zaivala@zaivala-desktop:~$ #my ext4 partition on /dev/sda1
    zaivala@zaivala-desktop:~$ blkid
    /dev/sda1: UUID="1683ec7a-7bfd-4b8c-bccc-20bbeb2a5775" TYPE="ext4"
    zaivala@zaivala-desktop:~$


    Did I win?

    Moss
    Every time I hear the word "Progress" my fur bristles!

  7. #7
    Join Date
    Mar 2008
    Beans
    319

    Re: Can't get old Windows drive access

    SOMETHING worked. The drive no longer looks as though it is ready to unmount.

    Now the question is, is this a "sticky" change? Will it still be like this if I reboot?

    Edited to add:
    Daggone it. I tried moving files to the drive... Got told I don't have permissions to create a folder in that directory. Now what?

    zaivala@zaivala-desktop:~$ ls -l /dev/sda1
    brw-rw---- 1 zaivala zaivala 8, 1 Apr 13 09:41 /dev/sda1
    zaivala@zaivala-desktop:~$
    Last edited by zaivala; April 13th, 2014 at 03:46 PM.
    Every time I hear the word "Progress" my fur bristles!

  8. #8
    Join Date
    Mar 2008
    Beans
    319

    Re: Can't get old Windows drive access

    To Morbius1:

    OK, that had too many generics in it for me to understand what to plug in where.

    I'm running 64-bit Ubuntu 13.10 on a Dell Optiplex 740. The drive in question is sda1 (originally the Windoze XP partition, now Microsoft-free).
    Last edited by zaivala; April 13th, 2014 at 04:18 PM. Reason: identify who I was responding to
    Every time I hear the word "Progress" my fur bristles!

  9. #9
    Join Date
    Dec 2009
    Beans
    5,422

    Re: Can't get old Windows drive access

    Post the output of the following command please:
    Code:
    ls -al /media/zaivala

  10. #10
    Join Date
    Mar 2008
    Beans
    319

    Re: Can't get old Windows drive access

    I managed to get the files moved, but it raised a lot more questions.

    The permissions have not changed. I moved my music and videos to folders on the sda1 drive, and now do not have access to my videos and music. Can't change permissions. Here's the latest report from Terminal:

    zaivala@zaivala-desktop:~$ sudo gksu nautilus /media
    [sudo] password for zaivala:

    (nautilus:15878): Gtk-WARNING **: Failed to register client: GDBus.Errorrg.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

    (nautilus:15878): IBUS-WARNING **: The owner of /home/zaivala/.config/ibus/bus is not root!
    Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
    Please ask your system administrator to enable user sharing.

    zaivala@zaivala-desktop:~$ sudo gksu nautilus /media

    (nautilus:15905): Gtk-WARNING **: Failed to register client: GDBus.Errorrg.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

    (nautilus:15905): IBUS-WARNING **: The owner of /home/zaivala/.config/ibus/bus is not root!
    Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
    Please ask your system administrator to enable user sharing.

    wrestool: /vmlinuz: file contains no resources

    (nautilus:15905): Gtk-CRITICAL **: gtk_application_uninhibit: assertion 'cookie > 0' failed

    (nautilus:15905): Gtk-CRITICAL **: gtk_application_uninhibit: assertion 'cookie > 0' failed

    (nautilus:15905): Gtk-CRITICAL **: gtk_application_uninhibit: assertion 'cookie > 0' failed
    zaivala@zaivala-desktop:~$
    Last edited by zaivala; April 13th, 2014 at 06:54 PM.
    Every time I hear the word "Progress" my fur bristles!

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •