Results 1 to 7 of 7

Thread: VLC installation issues in Ubuntu 14.04

  1. #1
    Join Date
    Jun 2008
    Location
    USA
    Beans
    103
    Distro
    Ubuntu 9.10 Karmic Koala

    VLC installation issues in Ubuntu 14.04

    Trying to install VLC in 14.04 and I get this.

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     vlc : Depends: vlc-nox (= 2.1.2-2build2) but it is not going to be installed
           Recommends: vlc-plugin-notify (= 2.1.2-2build2) but it is not going to be installed
           Recommends: vlc-plugin-pulse (= 2.1.2-2build2) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    andrew@andrew-K52F:~$
    Please advise what I need to do to get this right. I get the same error (similar) with ffmpeg. I'll do a separate ffmpeg thread for that. Really need this. Great software and I need it to work in my 14.04. thanks.

  2. #2
    Join Date
    Aug 2013
    Beans
    2,277

    Re: VLC installation issues in Ubuntu 14.04

    Well 14.04 is a beta, so if you really need things to work don't install it. Checkout the Ubuntu+1 threads (beta testers) may be you will get some insights for your problem.

  3. #3
    Join Date
    Nov 2009
    Beans
    3,225

    Re: VLC installation issues in Ubuntu 14.04

    Go into synaptic package manager and look for - edit - fix broken packages .........

    edit - fix broken packages ( top of the screen )

    You may have to uninstall vlc ......... or it could be that you just need to update the package manager listings as below.



    sudo apt-get update
    sudo apt-get install aptitude
    sudo aptitude update
    sudo aptitude install vlc


    Then post back what its giving as options ....... often answering no
    will bring up another set of alternatives using aptitude ........

    but post back the resulting listing before accepting it ..........

  4. #4
    Join Date
    May 2014
    Beans
    1

    Re: VLC installation issues in Ubuntu 14.04

    It worked for me using:

    sudo apt-get update
    sudo apt-get install aptitude
    sudo aptitude update
    sudo aptitude install vlc

    Thank you

  5. #5
    Join Date
    Aug 2013
    Beans
    2,277

    Re: VLC installation issues in Ubuntu 14.04

    Quote Originally Posted by alessandro-gobbi View Post
    It worked for me using:

    sudo apt-get update
    sudo apt-get install aptitude
    sudo aptitude update
    sudo aptitude install vlc

    Thank you
    Why aptitude? Anyway look at the date of OP, now that 14.04 is released the repos are sorted out so not surprising that it works.

  6. #6
    Join Date
    Dec 2010
    Beans
    7

    Re: VLC installation issues in Ubuntu 14.04

    doesn't work for me at all. latest ubuntu 14.04 lts update really screwed things up -- broke dependencies, deleted vlc... See http://askubuntu.com/questions/48844...er-last-update

    would appreciate it if anyone could advise how I can dig myself out of this hole that cannonical dug for me.

    -harryg

  7. #7
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: VLC installation issues in Ubuntu 14.04

    Please first post the outputs of :
    Code:
    cat -n /etc/apt/sources.list
    ls /etc/apt/sources.list.d
    tail -v -n +1 /etc/apt/sources.list.d/*
    and the whole outputs to :
    Code:
    sudo apt-get update
    sudo apt-get upgrade
    Last two should bring up the same results as you already posted on AU, but we would need a fresh output. Please use code tags to post the outputs : http://ubuntuforums.org/misc.php?do=bbcode#code
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •