Results 1 to 5 of 5

Thread: ATI RADEON on AGP does not work.

  1. #1
    Join Date
    Apr 2014
    Beans
    12

    ATI RADEON on AGP does not work.

    Hi,

    To begin with, I am new Ubuntu user. I moved from the Win XP and felt in love with the Linux family straight away.
    But I faced hardware problem with graphics card and I will be very gratefull if you help me to solve it.

    My ubunutu version: 12.04.04 LTS (all updates installed during installation +those installed after the installation process).
    Please, don't try to encourage me to move to the newest version. I know it does exist, but I don't want it, cause not everything is properly translated and fully stable.

    My graphics card: ATI RADEON HD4670 AGP (8X).
    My processor: Intel Pentium 4 2.8 Ghz Hyper-Threating (I read that disabling hype-threating may help, but it doesn't).

    PROBLEM:
    My graphics card after system installation appears to be "Unknown", "Interface: Standard".
    I tried to enable the 3D acceleration by installing the driver from the AMD site. No go (Card not supported).
    So I tried to install fglrx (propierity).

    After installation of the fglrx and fglrx-amdcccle i tried to configure the xorg.conf automatically:
    Code:
    $ sudo aticonfig --initial
    it says: no supported adapters found.

    I checked the bus ID
    Code:
    $ lspci | grep VGA
    and tried to create the xorg.conf manually
    Code:
    $ sudo gedit /etc/X11/xorg.conf
    Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
    EndSection
    
    Section "Module"
    EndSection
    
    Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option        "VendorName" "ATI Proprietary Driver"
        Option        "ModelName" "Generic Autodetecting Monitor"
        Option        "DPMS" "true"
    EndSection
    
    Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        Option      "AGPMode" "4"
        BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection
    but the system does not boot this way (says that it must run in low settings but doesn't allow me anywhere but into console. So i removed the driver from the console (apt-get remove, rm xorg.conf), and now it boots.

    I have no idea how to enable 3D acceleration in this card.
    Would you be so kind and help me with this?
    Last edited by DidierDrigbi; April 7th, 2014 at 12:03 AM.

  2. #2
    Join Date
    Jun 2007
    Beans
    12,188

    Re: ATI RADEON on AGP does not work.

    It's probably already enabled (or at least it was until you tried to install the proprietary driver). You got hit with the n00b bug:
    https://bugs.launchpad.net/ubuntu/+bug/946620
    What would happen if your hard disk died right now?

  3. #3
    Join Date
    Apr 2014
    Beans
    12

    Re: ATI RADEON on AGP does not work.

    This was helpful, thank you. I re-installed the whole system to clean all the mess and on a clean installation, I installed mesa-utils. Now, it recognises my card as Gallium 0.4 on AMD RV730. Is that correct, does it mean i have 3D acceleration? Becasue I there is no xorg.conf file.
    Last edited by DidierDrigbi; April 6th, 2014 at 11:37 PM.

  4. #4
    Join Date
    Jun 2007
    Beans
    12,188

    Re: ATI RADEON on AGP does not work.

    Yes, "Gallium 0.4 on AMD RV730" is correct. xorg.conf is usually not needed nowadays.

    Please mark thread solved.
    What would happen if your hard disk died right now?

  5. #5
    Join Date
    Apr 2014
    Beans
    12

    Re: ATI RADEON on AGP does not work.

    Thank you very much, your help was brilliant and, what is very important, you responded quickly.
    Thanks once more, thread marked.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •