Results 1 to 7 of 7

Thread: HDMI/TV output sound not working when connected to my computer.

  1. #1
    Join Date
    Sep 2009
    Beans
    65

    Question HDMI/TV output sound not working when connected to my computer.

    Hi everybody. First post here. I use Ubuntu 12.04 LTS (with Cairo desktop layout) on my 2 year old HP Pavilion. My sound works great in my computer but when I want to switch to use it on my TV in order to watch some movies the sound doesn't follow. It works great with the picture, I can use it like a new form of monitor sort of, but the sound doesn't follow. I've checked with the Sound Settings and the HDMI output is not muted. It is not muted either in ALSA but I have a hard time to understand which is which though. So, after looking at other questions (here and other sites) and trying their respective answers, I am still unable to get the hdmi audio out working.


    Please I need help!
    Last edited by SwingKid; April 6th, 2014 at 08:06 PM.

  2. #2
    Join Date
    Sep 2009
    Beans
    65

    Re: HDMI/TV output sound not working when connected to my computer.

    More info: In Sound Settings it says "RV710/730 HDMI Audio [Radeon HD 4000 series] Digital Stereo [HDMI]

  3. #3
    Join Date
    Apr 2014
    Beans
    2

    Re: HDMI/TV output sound not working when connected to my computer.

    What's your display driver? Open source or proprietary?

    It's said open source version of ATI driver disables HDMI audio by default. Check the first comment in the below article.

    http://voices.canonical.com/david.he...-ubuntu-12-04/

  4. #4
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    9,629
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: HDMI/TV output sound not working when connected to my computer.

    Audio works fine over HDMI using the proprietary ATI driver for my Radeon 6770M graphics card. You can install it by using the "Additional Drivers" application in Ubuntu.

    I've found pavucontrol to be the most effective application for selecting the correct sound source.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  5. #5
    Join Date
    Sep 2009
    Beans
    65

    Re: HDMI/TV output sound not working when connected to my computer.

    "What's your display driver? Open source or proprietary?"
    I don't know. :/ How would I be able to find out? Is it an ATI driver that I have and how do I know that?

  6. #6
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    9,629
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: HDMI/TV output sound not working when connected to my computer.

    Open a terminal and type in this command:
    Code:
    lspci | grep VGA
    You'll see entries like these:
    Code:
    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT]
    This is a "hybrid" laptop with both Intel and ATI graphics.

    If you have an ATI adapter, then run the Additional Drivers application in Ubuntu. It will check to see if the proprietary driver is available for your adapter and offer to download and install the driver if you choose.
    Last edited by SeijiSensei; April 8th, 2014 at 12:23 AM.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  7. #7
    Join Date
    Jun 2013
    Beans
    88

    Re: HDMI/TV output sound not working when connected to my computer.

    HDMI audio output is disabled by default. To enable it you need to pass theradeon.audio=1 option to the kernel at boot.
    To do so:

    1. Edit /etc/default/grub and add radeon.audio=1 to the GRUB_CMDLINE_LINUX line, it should look like:GRUB_CMDLINE_LINUX="... radeon.audio=1 rhgb quiet"
    2. Update grub's config: $ sudo grub2-mkconfig -o /boot/grub2/grub.cfg
    3. Reboot.

    I hope this helps.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •