Results 1 to 6 of 6

Thread: TP-Link TL-WN725N nano wireless adapter not being recognized as a wireless device

  1. #1
    Join Date
    Dec 2013
    Beans
    5

    Question TP-Link TL-WN725N nano wireless adapter not being recognized as a wireless device

    The default wireless card that came with my laptop is crap, so I bought a TP-LInk Nano USB Adapter with the model no TL-WN725N. Ubuntu doesn't recognize this device as a wireless one and I can't seem to find any drivers for or a package that has drivers. Might someone be able to point me to that package with the drivers? Thanks

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,143
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: TP-Link TL-WN725N nano wireless adapter not being recognized as a wireless device

    There are at least two different versions of this device. Let's see which you have. Please open a terminal and run and post:
    Code:
    lsusb
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Dec 2013
    Beans
    5

    Re: TP-Link TL-WN725N nano wireless adapter not being recognized as a wireless device

    Quote Originally Posted by chili555 View Post
    There are at least two different versions of this device. Let's see which you have. Please open a terminal and run and post:
    Code:
    lsusb
    Thanks.
    Code:
    lsusb
    returns this

    Code:
    Bus 001 Device 005: ID 0bda:8179 Realtek Semiconductor Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Yes my device is plugged in and there is nothing else in the usb slots

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,143
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: TP-Link TL-WN725N nano wireless adapter not being recognized as a wireless device

    The solution depends on your Ubuntu version:
    Code:
    lsb_release -d
    uname -r
    This may work, depending on the results from above: http://ubuntuforums.org/showthread.p...4#post12781744
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Dec 2013
    Beans
    5

    Re: TP-Link TL-WN725N nano wireless adapter not being recognized as a wireless device

    Quote Originally Posted by chili555 View Post
    The solution depends on your Ubuntu version:
    Code:
    lsb_release -d
    uname -r
    This may work, depending on the results from above: http://ubuntuforums.org/showthread.p...4#post12781744
    Code:
    lsb_release -d
    Description:    Ubuntu 12.04.4 LTS
    uname -r
    3.8.0-38-generic
    Hm, no unfortunately that did not work for me.

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,143
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: TP-Link TL-WN725N nano wireless adapter not being recognized as a wireless device

    Quote Originally Posted by aman207 View Post
    Hm, no unfortunately that did not work for me.
    Not much to go on there. Did the driver not install because of an error? Was there an error when you modprobbed the driver? Did the driver load but you couldn't connect? Did you connect but the connection drops? Was there a kernel panic? Did your computer burst into flames?

    We might be able to help if we could hear some details and see the exact error.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •