Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30

Thread: Maximise does not full screen properly in any application

  1. #21
    Join Date
    Mar 2014
    Beans
    16

    Re: Maximise does not full screen properly in any application

    Quote Originally Posted by bapoumba View Post
    I'll look again tonight, last night I searched for the exact file to modify to make it permanent. But the file is different for different releases, especially after moving away from the ancien xorg.conf. I'll double check.

    Edit : please have a look here : https://wiki.archlinux.org/index.php/Xorg
    The /etc/X11/xorg.conf.d/10-monitor.conf file is what I had in mind, provided the file location is correct.
    https://wiki.archlinux.org/index.php...nitor_settings
    Apparently the file directory is incorrect. In response to your earlier comment the system version is Lubuntu 13.10 Saucy Salamander (but I'm figuring you figured it out, so I'm just confirming).

  2. #22
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: Maximise does not full screen properly in any application

    Quote Originally Posted by uzk20707 View Post
    Apparently the file directory is incorrect. In response to your earlier comment the system version is Lubuntu 13.10 Saucy Salamander (but I'm figuring you figured it out, so I'm just confirming).
    So if you do not have a /etc/X11/xorg.conf.d/, please have a look at /usr/share/X11/xorg.conf.d/, this is where I have all the other config files :
    Code:
    ls /usr/share/X11/xorg.conf.d/
    10-evdev.conf         11-evdev-trackpoint.conf  50-wacom.conf
    10-quirks.conf        50-synaptics.conf         51-synaptics-quirks.conf
    11-evdev-quirks.conf  50-vmmouse.conf
    This is where you need to create the 10-monitor.conf file.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  3. #23
    Join Date
    Mar 2014
    Beans
    16

    Re: Maximise does not full screen properly in any application

    Quote Originally Posted by bapoumba View Post
    So if you do not have a /etc/X11/xorg.conf.d/, please have a look at /usr/share/X11/xorg.conf.d/, this is where I have all the other config files :
    Code:
    ls /usr/share/X11/xorg.conf.d/
    10-evdev.conf         11-evdev-trackpoint.conf  50-wacom.conf
    10-quirks.conf        50-synaptics.conf         51-synaptics-quirks.conf
    11-evdev-quirks.conf  50-vmmouse.conf
    This is where you need to create the 10-monitor.conf file.
    I don't understand. What am I doing with the 10-monitor.conf file?

  4. #24
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: Maximise does not full screen properly in any application

    Quote Originally Posted by uzk20707 View Post
    I don't understand. What am I doing with the 10-monitor.conf file?
    From the last link in my previous post, if you want to perm change the resolution, you need to create the file. There is an example in the Arch wiki link that you can use, provided you set it up according to you own bigger monitor:
    Code:
    Section "Monitor"
        Identifier             "Monitor0"
    EndSection
    
    Section "Device"
        Identifier             "Device0"
        Driver                 "vesa" #Choose the driver used for this monitor
    EndSection
    
    Section "Screen"
        Identifier             "Screen0"  #Collapse Monitor and Device section to Screen section
        Device                 "Device0"
        Monitor                "Monitor0"
        DefaultDepth           16 #Choose the depth (16||24)
        SubSection             "Display"
            Depth              16
            Modes              "1024x768_75.00" #Choose the resolution
        EndSubSection
    EndSection
    I was not certain where to create the file. If you do not have /etc/X11/xorg.conf.d/, have a look at /usr/share/X11/xorg.conf.d/ where I have the related stuff on 14.04.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  5. #25
    Join Date
    Mar 2014
    Beans
    16

    Re: Maximise does not full screen properly in any application

    Quote Originally Posted by bapoumba View Post
    From the last link in my previous post, if you want to perm change the resolution, you need to create the file. There is an example in the Arch wiki link that you can use, provided you set it up according to you own bigger monitor:
    Code:
    Section "Monitor"
        Identifier             "Monitor0"
    EndSection
    
    Section "Device"
        Identifier             "Device0"
        Driver                 "vesa" #Choose the driver used for this monitor
    EndSection
    
    Section "Screen"
        Identifier             "Screen0"  #Collapse Monitor and Device section to Screen section
        Device                 "Device0"
        Monitor                "Monitor0"
        DefaultDepth           16 #Choose the depth (16||24)
        SubSection             "Display"
            Depth              16
            Modes              "1024x768_75.00" #Choose the resolution
        EndSubSection
    EndSection
    I was not certain where to create the file. If you do not have /etc/X11/xorg.conf.d/, have a look at /usr/share/X11/xorg.conf.d/ where I have the related stuff on 14.04.
    Attempting to construct the file there results in:

    Error opening file '/usr/share/X11/xorg.conf.d/10-monitor.conf': Permission denied

  6. #26
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: Maximise does not full screen properly in any application

    When do you get the error? Creating the file or having it run when you boot up? (I suspect the first one).
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  7. #27
    Join Date
    Mar 2014
    Beans
    16

    Re: Maximise does not full screen properly in any application

    Quote Originally Posted by bapoumba View Post
    When do you get the error? Creating the file or having it run when you boot up? (I suspect the first one).
    Creating the file.

  8. #28
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: Maximise does not full screen properly in any application

    OK, the file has to be created on the root filesystem where you need root privileges to write. You could do it opening leafpad as root, but I do not like it much that way. I'd prefer using nano which is a small command line editor. Open a terminal and run:

    Code:
    sudo nano /usr/share/X11/xorg.conf.d/10-monitor.conf
    It will create the file. Include your settings. ctrl-o (letter o) to save, ctrl-x to exit nano. You may have to reboot, not sure a simple logout/log back in gets the conf files to be read again.

    Please have a look at /usr/share/X11/xorg.conf.d/ and confirm you have other similar files in there. They may be different from mine, which are default and have not been modified, but they start with a rank number and end up with .conf

    http://linux.die.net/man/1/nano
    Last edited by bapoumba; April 9th, 2014 at 01:56 PM.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  9. #29
    Join Date
    Mar 2014
    Beans
    16

    Re: Maximise does not full screen properly in any application

    Okay, I'm confused about how to gather the information required in order to fill in the file to save the settings. Also, I don't know how to configure it to automatically disable the laptop screen every time it starts up (suffers from the same problem). This is extremely complex.

  10. #30
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: Maximise does not full screen properly in any application

    I have moved your thread to Multimedia & Video. Hopefully someone will be able to guide you through. I'd need to do some testing because I'm not that at ease with video stuff, but I'm running out of free time. Quite sorry..
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •