Results 1 to 4 of 4

Thread: squidGuard has stopped

  1. #1
    Join Date
    Mar 2014
    Beans
    2

    Question squidGuard has stopped

    Hi Guys

    I am using ubuntu 10.04 LTS server. Running squid with squidGuard for the first time. Both squid and SquidGuard are running after configuration.

    However, I have a problem updating my squidguard db files. When I run Either squidGuard -C ALL or squidGuard /etc/squid/squidGuard.conf -C all , squidGuard will stop running. Does anyone know why? I have pasted a copy of my configuration and log file

    I have adjusted my file permissions just like https://help.ubuntu.com/community/SquidGuard

    My log file /var/log/squid/squidguard.log

    Code:
    2014-03-29 20:49:12 [873] init domainlist /var/lib/squidguard/db/blacklist/domains
    2014-03-29 20:49:12 [873] loading dbfile /var/lib/squidguard/db/blacklist/domains.db
    2014-03-29 20:49:12 [873] squidGuard 1.2.0 started (1396097352.420)
    2014-03-29 20:49:12 [873] db update done
    2014-03-29 20:49:12 [873] squidGuard stopped (1396097352.420)
    My SquidGuard Configuartion

    Code:
    dbhome /var/lib/squidguard/db
    logdir /var/log/squid
    
    dest bad {
            domainlist blacklist/domains
    }
    
    acl {
            default {
                    pass !bad all
                    redirect http://www.google.com
            }
    }
    Last edited by lee16; March 30th, 2014 at 09:40 AM.

  2. #2
    Join Date
    Jun 2006
    Location
    Houston, TX
    Beans
    1,155
    Distro
    Ubuntu 6.06

    Re: squidGuard has stopped

    This is probably not your problem, but...

    10.04 is very out of date, and as a consequence it gets less mind share. (As is the version of Squid available in 10.04) I would start by moving to 12.04, or perhaps 14.04. The newer versions may resolve the problem, but if not, you will have many more people active, and able to help you.

  3. #3
    Join Date
    Mar 2014
    Beans
    2

    Re: squidGuard has stopped

    There is no problem with the program, just that there might be some mistake/configuration that I unable to figure out.
    I have seen it work fine with on other servers

    I will give 12.10 LTS A go though, see if it works.
    Last edited by lee16; March 30th, 2014 at 09:44 AM.

  4. #4
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: squidGuard has stopped

    AFAIK, 12.10 wasn't LTS, but 12.04 was.
    Forum DOs and DON'Ts
    Never assume that information you find using a search engine is up-to-date.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •