Results 1 to 4 of 4

Thread: Trying to use 2 NICs, one hardwire one wireless

  1. #1
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,437
    Distro
    Xubuntu 13.04 Raring Ringtail

    Trying to use 2 NICs, one hardwire one wireless

    I have hardwired/wireless network 10.0.0.0/24 that connects to the Internet
    I have a Wireless network on 192.168.1.0/24 that consist of 2 systems, an old XP system that has been taken offline and the other is running xubuntu 12.10 for about another week or two when 14.04 is ready or at least a release candidate
    the xubuntu box is sharing the printer/scanner so the goal is to have it on both networks
    when both networks are connected i can ping the XP box but the XP box cant ping back, sometimes it can but it is very lossy/slow, but it i disconnect from the hardwire it acts right

    I tried creating a virtual NIC eth0:1 but it keeps disappearing and will not appear even if i put it in /etc/network/interfaces so i figure i will just use the wireless for it, at least that does not vanish
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  2. #2
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    10,231
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Trying to use 2 NICs, one hardwire one wireless

    Are you trying to connect to the same subnet using both the wired and wireless adapters? That usually causes routing problems since the choice of the default gateway is randomized. Just use one connection or the other. Unless you use "bonding" to connect to the two interfaces together, you're really not gaining anything in terms of performance by using both adapters.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  3. #3
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,437
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: Trying to use 2 NICs, one hardwire one wireless

    just trying to isolate the 2 networks and have 1 system on both

    DIR-615 ver I1 running DD-WRT w/ second 2 wireless networks screenshot
    ├── Wireless Laptop in 10.0.0.0/24 network (Xubuntu 12.10)
    ├── Wireless Desktop on 192.168.1.0/24 network (Windows XP)
    └── Wired Desktop on 10.0.0.0/24 network with wireless card on 192.168.0/24 network (Xubuntu 12.10 or 13.10 i forget)
    Only the 10.0.0.0/24 network has Internet access
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  4. #4
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    10,231
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Trying to use 2 NICs, one hardwire one wireless

    Wired Desktop on 10.0.0.0/24 network with wireless card on 192.168.0/24 network (Xubuntu 12.10 or 13.10 i forget)
    What's the default gateway on this machine? Can you show us the output from "route -n"?

    If you want the machine to have Internet access, its default gateway should be in the 10 network. Then it would use the wireless connection to communicate with hosts in the 192.168 network and send any other traffic to the default gateway in 10.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •