Results 1 to 5 of 5

Thread: Can mount NAS using CIFS but not NFS

  1. #1
    Join Date
    Nov 2009
    Location
    NS, Canada
    Beans
    41
    Distro
    Ubuntu Studio 14.04 Trusty Tahr

    Question Can mount NAS using CIFS but not NFS

    Either of these fstab entries work for me until lately with a D-Link DNS-321 and two Linux boxes running 12.04 LTS
    [CODE]
    192.168.0.14:/Volume_1 /mnt nfs defaults 0 0
    or
    Code:
    192.168.0.14:/Volume_1        /mnt          cifs  guest,_netdev,noperm  0  0
    Now only mounting possibility is CIFS. The code in each fstab is basically a cut n paste so they should be identical.

    The D-Link is quite old and does not support NFSv4

    Has there been changes to the NFS structure?

    Code:
    192.168.0.14:/Volume_1        /mnt         nfs    defaults 0 0
    jpb@Maple:~$ sudo mount -av
    
    mount.nfs: timeout set for Thu Mar 27 15:19:28 2014
    mount.nfs: trying text-based options 'vers=4,addr=192.168.0.14,clientaddr=192.168.0.102'
    mount.nfs: mount(2): Protocol not supported
    mount.nfs: trying text-based options 'addr=192.168.0.14'
    mount.nfs: prog 100003, trying vers=3, prot=6
    mount.nfs: trying 192.168.0.14 prog 100003 vers 3 prot TCP port 2049
    mount.nfs: prog 100005, trying vers=3, prot=17
    mount.nfs: trying 192.168.0.14 prog 100005 vers 3 prot UDP port 32774
    mount.nfs: mount(2): Permission denied
    mount.nfs: access denied by server while mounting 192.168.0.14:/Volume_1
    Dell XPS 8300 i5, Nvidia K2000, 2xDell U2312HM, 16GB ram, Ubuntu Studio14.04 LTS

  2. #2
    Join Date
    Aug 2011
    Beans
    40

    Re: Can mount NAS using CIFS but not NFS

    Quote Originally Posted by uwe-bungto View Post
    Code:
    mount.nfs: mount(2): Permission denied
    mount.nfs: access denied by server while mounting 192.168.0.14:/Volume_1
    Last line in your output is quite clear. The server denied your mount request.

  3. #3
    Join Date
    Nov 2009
    Location
    NS, Canada
    Beans
    41
    Distro
    Ubuntu Studio 14.04 Trusty Tahr

    Re: Can mount NAS using CIFS but not NFS

    Quote Originally Posted by apohal9 View Post
    Last line in your output is quite clear. The server denied your mount request.
    That is obvious. The question is why would the server accept the request from one box and deny the request another one? The request is a simple cut and paste into each fstab.
    Last edited by uwe-bungto; April 5th, 2014 at 08:26 PM.
    Dell XPS 8300 i5, Nvidia K2000, 2xDell U2312HM, 16GB ram, Ubuntu Studio14.04 LTS

  4. #4
    Join Date
    Nov 2009
    Location
    NS, Canada
    Beans
    41
    Distro
    Ubuntu Studio 14.04 Trusty Tahr

    Re: Can mount NAS using CIFS but not NFS

    An I the only one that has a problem with a NAS??
    Dell XPS 8300 i5, Nvidia K2000, 2xDell U2312HM, 16GB ram, Ubuntu Studio14.04 LTS

  5. #5
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,851
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Can mount NAS using CIFS but not NFS

    Are you sure the NAS is configured with "no_root_squash" or what its equivalent on the D-Link may be? Connections from fstab take place as the root user.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •