Results 1 to 4 of 4

Thread: "apt-get install ruby rubygems" fails

  1. #1
    Join Date
    Apr 2006
    Beans
    77

    "apt-get install ruby rubygems" fails

    Looks like ruby is halfway through switching default from 1.8 to 1.9;
    ruby is 1.9, but rubygems is 1.8.

    This is in a freshly created lxc container.

    $ apt-cache policy ruby rubygems
    ruby:
    Installed: (none)
    Candidate: 1:1.9.3.4
    Version table:
    1:1.9.3.4 0
    500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
    rubygems:
    Installed: 1.8.24-1ubuntu2
    Candidate: 1.8.24-1ubuntu2
    Version table:
    *** 1.8.24-1ubuntu2 0
    500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    100 /var/lib/dpkg/status

    Caused me a few hiccups. Looking forward to this being resolved.
    Hoping I just forgot to do 'apt-get upgrade' in the lxc container, or something.

  2. #2
    Join Date
    Mar 2010
    Location
    Metro-ATL; PM free zone.
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: "apt-get install ruby rubygems" fails

    If you are programming ruby and/or rails - use rbenv or rvm to manage everything about the ruby environment. DO NOT TRUST the OS versions.

  3. #3
    Join Date
    Apr 2006
    Beans
    77

    Re: "apt-get install ruby rubygems" fails

    This is an OS forum, this thread is about fixing OS versions.

    So the issue is that rubygems is 1.8 only. As https://launchpad.net/ubuntu/trusty/....8.24-1ubuntu2 says,
    "In Ruby 1.9.X, Rubygems is provided with the interpreter".

    At the moment, rubygems1.8 is a transitional package that depends on the package rubygems.
    Given that Trusty is moving to 1.9 by default, that should be flipped; the real package
    should be rubygems1.8, and rubygems should become a transitional package that does nothing.

  4. #4
    Join Date
    Apr 2006
    Beans
    77

    Re: "apt-get install ruby rubygems" fails

    I think the following dependency lines would let my private app's source package build and work across the range ubuntu 10.04-14.04:

    libopenssl-ruby | dash,
    ruby (>= 1:1.9.3.4) | rubygems,
    ruby-dev,

    I'll post back here if that's not a good enough workaround.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •