Results 1 to 6 of 6

Thread: Running Wine Game with xinit problem

  1. #1
    Join Date
    Sep 2013
    Beans
    136

    Running Wine Game with xinit problem

    Hi,

    I am running an old game using playonlinux through xinit to provide a 16 bit display (which the game needs to run)
    I use this command:

    xinit /usr/share/playonlinux/playonlinux --run "Moto Racer" %F -- :1 -ac -depth 16

    The game works fine doing this BUT the display of the game only takes up the top left quarter of the screen and the rest is black.
    What's odd is i am using Kubuntu and have this problem but in a previous installation on Ubuntu it runs filling the full screen using exactly the same command.
    Is there some little option I am missing here?

    Thanks for any help

  2. #2
    Join Date
    Sep 2013
    Beans
    136

    Re: Running Wine Game with xinit problem

    Bump! Nobody?

  3. #3
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Running Wine Game with xinit problem

    .o/
    Moved to Wine, where you may get more attention.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  4. #4
    Join Date
    Sep 2013
    Beans
    136

    Re: Running Wine Game with xinit problem

    I'll mark this as solved. I have found that there is a command line option to moto.exe -fullscreen. Doh!
    Last edited by adec2; April 20th, 2014 at 06:59 PM.

  5. #5
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Running Wine Game with xinit problem

    Quote Originally Posted by adec2 View Post
    I'll mark this as solved. I have fund that there is a command line option to moto.exe -fullscreen. Doh!
    lol, thanks. Sometimes, asking a question is enough to find a solution
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  6. #6
    Join Date
    Sep 2013
    Beans
    136

    Re: Running Wine Game with xinit problem

    Yeah i didnt think that running in a window was the problem i always presumed windows games from that era defaulted to full screen. Oh Well we live and learn!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •