It's an Acer Aspire 3050 laptop which has an adapter not supported by Linux. I have 5 USB adapters (Varying brands that have worked on other Linux systems) all of which seem to half-work when I use Linux on the laptop. By half-work I mean that it will connect for a minute, load pages really slow, disconnect, and just continue to have problems. I have tried several different distributions and the only one that I have got to work steadily is PC Linux OS, but for other reasons, I don't love that one. I'm pretty sure the two adapters are conflicting with each other.
I would like either Ubuntu, Mint, or OpenSuse. Is there an easy way to disable the internal adapter so it won't conflict? If that's not the problem, then what is? This laptop is a gift for family member and I would like to get Linux working well before giving it to them. (I would simply leave Windows on it, but I bought it off Craigslist with a non-activated fresh install and I don't have the product key)

Thank you for any assistance you can provide.