Results 1 to 4 of 4

Thread: How can I disable my laptop's internal wireless adapter?

Hybrid View

  1. #1
    Join Date
    Mar 2014
    Beans
    1

    How can I disable my laptop's internal wireless adapter?

    It's an Acer Aspire 3050 laptop which has an adapter not supported by Linux. I have 5 USB adapters (Varying brands that have worked on other Linux systems) all of which seem to half-work when I use Linux on the laptop. By half-work I mean that it will connect for a minute, load pages really slow, disconnect, and just continue to have problems. I have tried several different distributions and the only one that I have got to work steadily is PC Linux OS, but for other reasons, I don't love that one. I'm pretty sure the two adapters are conflicting with each other.
    I would like either Ubuntu, Mint, or OpenSuse. Is there an easy way to disable the internal adapter so it won't conflict? If that's not the problem, then what is? This laptop is a gift for family member and I would like to get Linux working well before giving it to them. (I would simply leave Windows on it, but I bought it off Craigslist with a non-activated fresh install and I don't have the product key)

    Thank you for any assistance you can provide.

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,273
    Distro
    Ubuntu Development Release

    Re: How can I disable my laptop's internal wireless adapter?

    The strict answer to your question is to determine what the driver is from the terminal:
    Code:
    sudo lshw -C network
    It will report something like:
    *-network
    description: Wireless interface
    product: Centrino Advanced-N 6200
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:03:00.0
    logical name: wlan0
    version: 35
    serial: xx:94:6b:99:55:xx
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=iwlwifi driverversion=3.11.0-18-generic firmware=9.221.4.1 build 25532 ip=192.168.1.100 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
    resources: irq:42 memory:f2400000-f2401fff
    Then blacklist what you found:
    Code:
    sudo -i
    echo "blacklist iwlwifi"  >>  /etc/modprobe.d/blacklist.conf
    exit
    Of course, substitute your details here. Reboot and you'll be all set.

    The real answer is to troubleshoot the internal device and see if we can fix it. If you'd like to do so, tell us the information you found from above.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Apr 2005
    Location
    EU - UK
    Beans
    3,324
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How can I disable my laptop's internal wireless adapter?

    If your laptop has a wifi button you can use that to disable (hard block) it. Or you could try to soft block it, by doing the following:
    Code:
    rfkill list
    to find the index of the card and then
    Code:
    rfkill block index_number
    e.g.
    Code:
    rfkill block 0
    although I'm not sure if the block will stay between reboots.

    Hope that helps.

  4. #4
    Join Date
    Aug 2011
    Location
    Des Moines, Iowa, USA
    Beans
    143
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: How can I disable my laptop's internal wireless adapter?

    Have you checked the bios settings? There may be a way to disable it in there.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •