Results 1 to 5 of 5

Thread: qt application misbehavior?

  1. #1

    qt application misbehavior?

    I suddenly began having this error with every KDE based application.


    xxxx:~$ kate &
    [1] 2724
    xxxxxx:~$ QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
    Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
    uint DBusMenuExporterDBus::GetLayout(int, int, const QStringList&, DBusMenuLayoutItem&): Condition failed: menu



  2. #2
    Join Date
    Sep 2005
    Beans
    1,606
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: qt application misbehavior?

    Found this via kde.org
    https://forum.kde.org/viewtopic.php?f=66&t=102251 - saying the first error just to ignore, as for the unit DBusMenu.... see below

    Found this via Launchpad

    https://answers.launchpad.net/appmen...uestion/183966
    Quote Originally Posted by Ritesh Raj Sarraf (rrs) said on 2012-01-17: #1
    Answering myself. The appmenu plasma widget needs to be added to the panel. Thanks.
    I don't know if any of this helps, but thought I'd point it out just in case.
    Where's [slooksterpsv] been? - I had Catastrophic partition alignment failure. I lost 90%+ of my data, and just now got it back fixed and working.

  3. #3

    Re: qt application misbehavior?

    Hmm. Don't see anything called "appmenu" but I did already have the file menu widget on a panel. Didn't fix the issue unfortunately.

  4. #4
    Join Date
    Sep 2005
    Beans
    1,606
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: qt application misbehavior?

    it looks like this is a bug. Try the following:

    Open ~/.kde/share/config/nepomukserverrc and set “Start Nepomuk” to false.

    [Basic Settings]
    Start Nepomuk=false
    Open ~/.kde/share/config/kdedrc and set “autoload” to false for nepomuksearchmodule:

    [Module-nepomuksearchmodule]
    autoload=false

    Restart, try again. Taken from:
    http://ubuntuku.org/16/how-to-disable-nepomuk-akonadi/

    EDIT: https://bugs.launchpad.net/ubuntu/+s...bs/+bug/959151 - is the bug report location
    Where's [slooksterpsv] been? - I had Catastrophic partition alignment failure. I lost 90%+ of my data, and just now got it back fixed and working.

  5. #5

    Re: qt application misbehavior?

    Weird. I think all my values were already false

    [$Version]
    update_info=nepomukstrigiservice-migrate.upd:nepomukstrigiservice-migrate

    [Service-nepomukfileindexer]
    autostart=false

    [Service-nepomukstrigiservice]
    autostart[$d]

    [main Settings]
    GraphMigrationRequired=false
    Port=1113
    Storage Dir[$e]=$HOME/.kde/share/apps/nepomuk/repository/main/
    Used Soprano Backend=virtuosobackend

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •