Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Keyboard

  1. #1
    Join Date
    Mar 2014
    Location
    Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Keyboard

    Hi,

    I'm using Ubuntu but got a small problem with my keyboard.

    When I enter a ' and then a t, the ' is not appearing. But when I use ' and then the m I get this: ḿ. How must I setup my keyboard settings?

    Thank you.

  2. #2
    Join Date
    Oct 2011
    Location
    Galiza
    Beans
    3,347
    Distro
    Ubuntu Development Release

    Re: Keyboard

    You probably selected a keyboard variant with "dead keys", a variant used for enabling the accentuated characters needed for many languages (English only needs a few for some borrowed words like the French "fiancé").
    With such layout variant you need to type ' or " + space.
    You can change the keyboard layout for the normal one if you feel you don't need special characters. How to do it graphically depends on the version and falvor of Ubuntu you're running. Please provide such info next time.
    Galiza Nação!

  3. #3
    Join Date
    Mar 2014
    Location
    Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Keyboard

    Quote Originally Posted by Vladlenin5000 View Post
    You probably selected a keyboard variant with "dead keys", a variant used for enabling the accentuated characters needed for many languages (English only needs a few for some borrowed words like the French "fiancé").
    With such layout variant you need to type ' or " + space.
    You can change the keyboard layout for the normal one if you feel you don't need special characters. How to do it graphically depends on the version and falvor of Ubuntu you're running. Please provide such info next time.
    Using Ubuntu 13.10. I use the special characters like ´ most of the time.

  4. #4
    Join Date
    Oct 2011
    Location
    Galiza
    Beans
    3,347
    Distro
    Ubuntu Development Release

    Re: Keyboard

    That isn't a "special character". Examples of special characters: ç á à â é È ü ...
    In standard Ubuntu you can go to system setting > Keyboard. There you'll find a button that takes you to the keyboard layouts. You can add or remove layouts. As a rule you should only have the ones pertaining to the keyboards you use with that computer therefore, if you only use "US International" keyboards and you don't want that behavior, make sure that only US international is listed.


    PS - Please reply to your other thread or otherwise mark it as solved if you no longer need help.
    Galiza Nação!

  5. #5
    Join Date
    Mar 2014
    Location
    Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Keyboard

    But then ' show automatic... :s

  6. #6
    Join Date
    Oct 2011
    Location
    Galiza
    Beans
    3,347
    Distro
    Ubuntu Development Release

    Re: Keyboard

    Quote Originally Posted by Korkel View Post
    But then ' show automatic... :s
    Sure... Isn't that what you want? And no, you can't have it both way. Either normal or with "dead keys".
    Galiza Nação!

  7. #7
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 15.10 Wily Werewolf

    Re: Keyboard

    Where do you get these ? In an application ? Terminal ? Please have a look at your keyboard layout or at the accessibility menus where you may have checked something by accident. What keyboard and language are you using ?
    Edit : what is the output to locale. Here is mine for ref :
    Code:
     locale
    LANG=en_US.UTF-8
    LANGUAGE=en_US:en
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC=fr_FR.UTF-8
    LC_TIME=fr_FR.UTF-8
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY=fr_FR.UTF-8
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER=fr_FR.UTF-8
    LC_NAME=fr_FR.UTF-8
    LC_ADDRESS=fr_FR.UTF-8
    LC_TELEPHONE=fr_FR.UTF-8
    LC_MEASUREMENT=fr_FR.UTF-8
    LC_IDENTIFICATION=fr_FR.UTF-8
    LC_ALL=
    Last edited by bapoumba; March 16th, 2014 at 07:48 PM.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  8. #8
    Join Date
    Mar 2014
    Location
    Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Keyboard

    Quote Originally Posted by bapoumba View Post
    Where do you get these ? In an application ? Terminal ? Please have a look at your keyboard layout or at the accessibility menus where you may have checked something by accident. What keyboard and language are you using ?
    English, US with dead keys...

  9. #9
    Join Date
    Oct 2011
    Location
    Galiza
    Beans
    3,347
    Distro
    Ubuntu Development Release

    Re: Keyboard

    Quote Originally Posted by Korkel View Post
    English, US with dead keys...
    As I said before, it's working as designed. That's exactly the expected behavior with the "dead keys" option. If you don't want it just change back to normal. You won't be able to write accentuated characters though but - again - you can't have it both ways.
    Galiza Nação!

  10. #10
    Join Date
    Mar 2014
    Location
    Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Keyboard

    Hmm, I will deal with it. :'(

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •