Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: skype not working

  1. #1
    Join Date
    Aug 2011
    Beans
    42

    skype not working

    hello
    i have just installed kubuntu 12.04 and i tried to download skype http://www.skype.com/en/download-skype/skype-for-linux/
    (i chose ubuntu 12.04 distribution, it did not have an option for kubuntu)
    and when i open the deb file i get Error: wrong architecture 'i386'

  2. #2
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,828
    Distro
    Ubuntu Development Release

    Re: skype not working

    what is your system bit type ? 32 bit(x84) or 64 bit( AMD) ?
    Raja

    రాజ శేఖర్ రెడ్డి

  3. #3
    Join Date
    Feb 2014
    Beans
    23

    Re: skype not working

    you should download it from ubuntu software center you should already got that program installed.

    It's an icon with a bag on the sidebar.

  4. #4
    Join Date
    Aug 2011
    Beans
    42

    Re: skype not working

    there is no skype in the software center
    when i had ubuntu 12.04 i opened the deb file and then skype appeared in the software center and i could then download it
    my system is 64 bit

  5. #5
    Join Date
    Sep 2006
    Beans
    7,632
    Distro
    Lubuntu Development Release

    Enabling multiarch

    You have to hop through some hoops to get it but the instructions are available:

    https://help.ubuntu.com/community/Skype

    However, once you have done that, I would very much encourage you to install an SIP client along side Skype. That won't interfere with Skype and will give you more options. Unlike Skype's protocol, SIP is an open standard and that prevents lock-in to any one product or company, but the discussion of open standards is a whole separate topic. SIP clients to look at include Ekiga, Linphone, Blink and Jitsi. I find the sound quality better with some of them than with Skype.

  6. #6
    Join Date
    Aug 2011
    Beans
    42

    Re: skype not working

    i try sudo dpkg --add-architecture i386
    and i get


    dpkg: error: unknown option --add-architecture


    Type dpkg --help for help about installing and deinstalling packages [*];
    Use `dselect' or `aptitude' for user-friendly package management;
    Type dpkg -Dhelp for a list of dpkg debug flag values;
    Type dpkg --force-help for a list of forcing options;
    Type dpkg-deb --help for help about manipulating *.deb files;


    Options marked [*] produce a lot of output - pipe it through `less' or `more' !

  7. #7
    Join Date
    Sep 2006
    Beans
    7,632
    Distro
    Lubuntu Development Release

    Re: skype not working

    Add/remove arch works for me on x86_64.

    What architecture do you have just now?

    Code:
    uname -a

  8. #8
    Join Date
    Aug 2011
    Beans
    42

    Re: skype not working

    3.2.0-60-generic #91-Ubuntu SMP Wed Feb 19 03:54:44 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

  9. #9
    Join Date
    Sep 2006
    Beans
    7,632
    Distro
    Lubuntu Development Release

    dpkg

    Ok. It looks like the guide is not written for 12.04 and that there have been changes to dpkg since then. Try --foreign-architecture instead.

    Code:
    sudo dpkg --foreign-architecture i386

  10. #10
    Join Date
    Aug 2011
    Beans
    42

    Re: skype not working

    i skipped the first command that didn't work and tried the next 2 and they worked ( https://help.ubuntu.com/community/Skype )
    skype seems to be ok now
    do u think there will be a problem?
    i needed the architecture command because i have a 64bit system?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •