HI, I've just upgraded from 11.10 to 12.04 and I've found that the Asus Xonar U3 card which worked well under 11.10 doesn't work with 12.04. This is a real disadvantage as I use my laptop, Samsung RV511, to record speech for teaching English. The internal sound chip is pretty poor by comparison with the Xonar.
It looks like the Xonar is not being recognized by the OS.
~$ lsmod | grep snd
snd_hda_codec_hdmi 40881 1
snd_hda_codec_realtek 50931 1
snd_hda_intel 43326 3
snd_hda_codec 169608 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel
snd_hwdep 13276 1 snd_hda_codec
snd_pcm 94597 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq_midi 13132 0
snd_rawmidi 25157 1 snd_seq_midi
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 55716 2 snd_seq_midi,snd_seq_midi_event
snd_timer 28930 2 snd_pcm,snd_seq
snd_seq_device 14137 3 snd_seq_midi,snd_rawmidi,snd_seq
snd 61270 17 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq_midi, snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 12600 1 snd
snd_page_alloc 18398 2 snd_hda_intel,snd_pcm
roy@medea:~$ lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
Subsystem: Samsung Electronics Co Ltd Device c581
Flags: bus master, fast devsel, latency 0, IRQ 44
Memory at fc800000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd-hda-intel
~$ ^C
roy@medea:~$ lsmod | grep snd
snd_hda_codec_hdmi 40881 1
snd_hda_codec_realtek 50931 1
snd_hda_intel 43326 3
snd_hda_codec 169608 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel
snd_hwdep 13276 1 snd_hda_codec
snd_pcm 94597 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq_midi 13132 0
snd_rawmidi 25157 1 snd_seq_midi
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 55716 2 snd_seq_midi,snd_seq_midi_event
snd_timer 28930 2 snd_pcm,snd_seq
snd_seq_device 14137 3 snd_seq_midi,snd_rawmidi,snd_seq
snd 61270 17 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq_midi, snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 12600 1 snd
snd_page_alloc 18398 2 snd_hda_intel,snd_pcm
I've had a look at the ALSA Project page http://www.alsa-project.org/main/ind...dule-usb-audio but I'm not sure if this is the way to go.

Any help would be much appreciated TIA