Results 1 to 3 of 3

Thread: Ubuntu Emulator not working

  1. #1
    Join Date
    Sep 2013
    Beans
    5

    Ubuntu Emulator not working

    I recently installed the latest daily build (PC (Intel x86) desktop image) of Trusty from here: http://cdimage.ubuntu.com/daily-live/current/



    Ubuntu works perfectly! I decided to try out ubuntu touch using the ubuntu-emulator to see if I like it. Eventually I will use this to make and test ubuntu apps.


    I ran these commands to install, create and run ubuntu-emulator:


    sudo apt-get install ubuntu-emulator
    sudo ubuntu-emulator create myinstance
    ubuntu-emulator run myinstance


    The first two worked fine and when I ran the third, a virtual phone appeared however the virtual screen was blank. I waited and waited, but nothing happened, the screen remained blank/black (on the virtual phone). Then I notice I have to log in terminal. I entered phablet then phablet and logged in fine.


    Now I have the terminal logged in and a virtual kernel of the phone but the screen is blank. How can I start the graphics?


    Also, once I've got the screen working, can I reduce the window size (it doesn't all fit on one desktop)?
    Thanks! -Zach

  2. #2
    Join Date
    Apr 2005
    Location
    EU - UK
    Beans
    3,308
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu Emulator not working

    Quote Originally Posted by zacharyi123 View Post
    The first two worked fine and when I ran the third, a virtual phone appeared however the virtual screen was blank. I waited and waited, but nothing happened, the screen remained blank/black (on the virtual phone). Then I notice I have to log in terminal. I entered phablet then phablet and logged in fine.


    Now I have the terminal logged in and a virtual kernel of the phone but the screen is blank. How can I start the graphics?
    Same here, ran it a couple of times, got a blank screen. I logged in and ran unity8 again, it restarted and then I got graphics but unity was messy and buggy; that didn't work the second time though. So, I can't give you a definite solution for that.
    Quote Originally Posted by zacharyi123 View Post
    Also, once I've got the screen working, can I reduce the window size (it doesn't all fit on one desktop)?
    Thanks! -Zach
    Yes, to scale it down for example to 80% of its size you would do:
    Code:
    ubuntu-emulator run --scale 0.8 myinstance
    Anyways, even if you manage to make it work, it will be slow. The good news is that the x86 version of the emulator is coming out soon and it's obviously, much faster than this.

  3. #3
    Join Date
    Apr 2005
    Location
    EU - UK
    Beans
    3,308
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu Emulator not working

    Actually, a public preview of the x86 emulator is already available (just read the post on webupd8). Instructions are here (and also on webupd8).

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •