I have serious problems with installing Ubuntu on my Asus Rampage IV Extreme/i7, in fact any linux at all.

1. Direct boot Kubuntu 13.10 from DVD - Sometimes installer starts, sometimes not (freeze on Kubuntu logo) - when it starts it installs just fine, after that login screen shows after login freeze while being on "hard drive" icon, however once it started don't know why

2. Direct boot Ubuntu 13.10 - freeze and stop reading from CD at install screen (this one with passing dots)

3. 12.04 - same thing in both cases

4. Wubi 12.4 from Windows installed just to do it - install on Windows completes fine, after restart: "To show other install options press ESC now" then "0" shows and freeze

5. Recommended by manufacturer 11.4 same thing

6. OLE/openSUSE/other RedHat based - "waiting for hardware to initialize" or "starting udev..." before installation, then freeze

Tried with different combinations of BIOS settings/install options like nomodprobe but nothing worked.

Is that system incapable of handling any linux?