Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Very slow while opening up new applications

  1. #1
    Join Date
    Feb 2014
    Beans
    8

    Very slow while opening up new applications

    I am new to the Linux platform and have been experimenting with KUBUNTU and LUBUNTU on a fairly old HP laptop (Intel 1.73 Ghz dual core processor, 1 GB RAM, 160 GB hard disc, GeForce 7400 nvidia graphics card). I recently revived it from a crash and don't want to use windows anymore

    I installed KUBUNTU first and soon realized that LUBUNTU would suit me best. I purged the KDE components and installed the LUBUNTU desktop as described in various forums. I have also installed standard programs like VLC. libreoffice, gimp, cheese etc.

    There's a dramatic change in the speed and the system runs very smoothly. But the only problem I have is that the system takes a while to load applications. I need to wait c.5 seconds before an application (like Chromium, firefox, folders, vlc....) would load. After loading the system runs very fast, smooth and without any issues.

    Please suggest if I could make any changes to decrease the loading time for applications. Thanks
    Last edited by Vaneet_Goyal; February 28th, 2014 at 09:51 PM.

  2. #2
    Join Date
    Feb 2014
    Beans
    8

    Re: Very slow while opening up new applications

    Other information I forgot to mention:

    UBUNTU:
    Release 12.04 (precise) 32-bit
    Kernel Linux 3.2.0-59-generic-pae
    GNOME 3.4.2

    System Status:
    Available disk space: 1.9 GB (Although I have more than 60 gigs to spare in another module. The module on which LUBUNTU is mounted is only 10 GB)

  3. #3
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    9,661
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Very slow while opening up new applications

    Hi, welcome to the fora.

    Please post (in CODE tags) the output from df -m.
    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

  4. #4
    Join Date
    Feb 2014
    Beans
    8

    Re: Very slow while opening up new applications

    Code:
    Filesystem     1M-blocks  Used Available Use% Mounted on
    /dev/sda1           9387  7133      1778  81% /
    udev                 491     1       491   1% /dev
    tmpfs                200     1       200   1% /run
    none                   5     0         5   0% /run/lock
    none                 500     9       492   2% /run/shm

  5. #5
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    9,661
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Very slow while opening up new applications

    As you mentioned yourself you have very little space left on the disk, which is unhealthy. Normally fragmentation is no problem on Linux but it becomes a problem when the system is choking.

    Your installation is a K/L/Ubuntu mixture and an old one, too (12.04). The Lubuntu parts are unsupported.

    I suggest moving everything of value out of sda1 and doing a fresh install of Lubuntu 13.10. Maybe more adjustments are necessary but this is a good first step.
    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

  6. #6
    Join Date
    Feb 2014
    Beans
    8

    Re: Very slow while opening up new applications

    Thanks mrgs. Will do a fresh installation of 13.10. Is it possible to increase disk space for the time being (maybe use some of the 60gigs from another module which is just sitting idle)?

  7. #7
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    9,661
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Very slow while opening up new applications

    What exactly do you mean by module? Hard disk / partition / ... ?
    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

  8. #8
    Join Date
    Oct 2009
    Location
    apt-get
    Beans
    4,245
    Distro
    Ubuntu Gnome Development Release

    Re: Very slow while opening up new applications

    Hi,

    I highly appreciate you do a full backup for your data, use GParted to create new partition table, prepare your partitions:

    Root Partition (10GB - 20GB)
    Swap Partition (1GB - 2GB)
    Home Partition (the rest)

    And then install either:
    Lubuntu 13.10
    or
    Xubuntu 12.04.4 LTS

    Note: in 17th of April, 14.04 LTS will be released and no matter what direction you choose, you can upgrade to 14.04 once released.

    How to backup?
    Either you copy-paste your 'Home' Folder
    Or, see this:
    https://help.ubuntu.com/community/BackupYourSystem

    More about partitioning?
    https://help.ubuntu.com/lts/installa...titioning.html

    And the internet is full of HOWTOs and Guides

    Support for different cycles?
    https://wiki.ubuntu.com/Releases

    If you do need any help, please ask

  9. #9
    Join Date
    Feb 2014
    Beans
    8

    Re: Very slow while opening up new applications

    Thanks mrgs and amjjawad. Like you guys suggested, I have done a full installation of Lubuntu 13.10 and increased the root partition. I still have the same problem and chromium still takes a lot of time to load. Again, the system runs smoothly once any application like chromium, firefox, xpad, libreoffice, vlc etc. loads. Its only the initial load time of every application that's a problem for me. Please find below the output for df -m

    Code:
    Filesystem     1M-blocks  Used Available Use% Mounted on
    /dev/sda7          57990  4047     50975   8% /
    none                   1     0         1   0% /sys/fs/cgroup
    udev                 492     1       492   1% /dev
    tmpfs                101     2       100   2% /run
    none                   5     0         5   0% /run/lock
    none                 501     1       501   1% /run/shm
    none                 100     1       100   1% /run/user
    Would appreciate any further suggestions. Thanks

  10. #10
    Join Date
    Feb 2014
    Beans
    8

    Re: Very slow while opening up new applications

    Also, please note that I have reduced the swapiness to 10 as suggested in some of the forums.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •