Results 1 to 8 of 8

Thread: my dell monitor goes to sleep

  1. #1
    Join Date
    Jan 2014
    Beans
    5

    Question my dell monitor goes to sleep

    I am on 12.04 a dell 24" flat screen monitor.
    I unplugged the screen by kicking the plug.
    Now it goes to sleep even though power management is set to never.
    I was given this script to keep it from going to sleep:
    xset -dpms;xset s off
    when I put that in terminal or run it as a .sh as follows:
    #!/bin/bash
    xset -dpms;xset s off
    It works...I can watch movies with out my monitor going to sleep.
    I have the .sh in my home folder and checked allow executing file as program.
    then added it to my startup applications.
    but is does not work.
    How can i get this .sh to run at boot or at login?

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,894
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: my dell monitor goes to sleep

    Hi darinb6-w.

    Are you sure it is suspending? May be it's just the monitor turning off.

    There's another setting that turn off the monitor (no suspend). It is in 'Brightness and Lock'.

    Hope it helps. Let us know if that helped.
    Regards.

  3. #3
    Join Date
    Jan 2014
    Beans
    5

    Re: my dell monitor goes to sleep

    brightness and lock?

    is that on the dell monitor. menu on the monitor or in the operating system power management part or screensaver part?

  4. #4
    Join Date
    Jan 2014
    Location
    Sojournor
    Beans
    41
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: my dell monitor goes to sleep

    Ok, I am a new user of Ubunto 12.04 Precise Pangolin but I may be able to clarify where brightness and lock is. I found it in system settings, and then the "personal" section at the top of the screen. The button is at the top right corner of the main desk top screen.

  5. #5
    Join Date
    Apr 2005
    Location
    EU - UK
    Beans
    3,344
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: my dell monitor goes to sleep

    Quote Originally Posted by darinb6-w View Post
    brightness and lock?

    is that on the dell monitor. menu on the monitor or in the operating system power management part or screensaver part?
    Monitors have their own power management settings. Press the menu button of your monitor to bring up the OSD and then go from there.

    You could also unplug your vga cable from both ends and plug it back making sure that it is attached firmly to the ports (turn off both your monitor and computer before attempting that, especially if it is a desktop pc).

    Hope that helps.
    Last edited by kostkon; February 25th, 2014 at 03:55 AM.

  6. #6
    Join Date
    Jan 2014
    Beans
    5

    Re: my dell monitor goes to sleep

    ok it is not turning off the monitor since moving the mouse turns it back on.
    I did the unplug and reseat the hdmi plug this morning.
    I have not been away from the pc yet or watched a movie to see if it goes to sleep. i do not see anything in the monitor menu itself that stops it from going to sleep. i did once see writing in the middle of the screen that said it is going to sleep. I don't remember what it said exactly because it was brief and i was not expecting it. it only happens while watching a movie where the mouse is not used for a long period. or i walk away from the pc for some time. this is very anoying this never happened before I kicked out the power plug. I am hoping moving to 14.04lts will solve it. if we can't fix it first. Also the command in a .sh file i put in above works...I just can't get it to load on boot up or log in.

  7. #7
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,894
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: my dell monitor goes to sleep

    Open 'System Settings', then click on 'Brightness and Lock', and select 'Never' for the field 'Turn screen off when inactive'.

    Let us know if that helped.
    Regards.

  8. #8
    Join Date
    Jan 2014
    Beans
    5

    Re: my dell monitor goes to sleep

    none of the above suggestions worked. The .sh file I listed above works but only if I run it. any way to get this .sh to run at log in? i have it in my home folder and made it allow executing file as program... and then added it to my startup app list, but it doesn't seem to work.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •