Page 1 of 7 123 ... LastLast
Results 1 to 10 of 61

Thread: can not upgrade, error can not calculate upgrade

  1. #1
    Join Date
    Dec 2006
    Beans
    Hidden!

    can not upgrade, error can not calculate upgrade

    unresolvable
    How to fix?

    found this in the log

    2014-02-22 09:59:01,065 ERROR Dist-upgrade failed: 'E:Unable to correct problems, you have held broken packages.'

    So how to tell what's broken?
    Attached Images Attached Images
    Last edited by sdowney717; February 22nd, 2014 at 04:06 PM.

  2. #2
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: can not upgrade, error can not calculate upgrade

    synaptic shows no broken packages
    Attached Images Attached Images

  3. #3
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: can not upgrade, error can not calculate upgrade

    could it be these 2 here?
    They have been there for months.

    some ppa list?
    Attached Images Attached Images

  4. #4
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,830
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: can not upgrade, error can not calculate upgrade

    Code:
    sudo apt-get install -f
    in CLI...

  5. #5
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    5,423
    Distro
    Ubuntu Development Release

    Re: can not upgrade, error can not calculate upgrade

    What method are you using to upgrade ?

    edit: Just upgraded here using CLI .. no problems but then I don't have any ppas on THIS install.
    This is Rolling Release
    Warnings for New Beta Testers& Helpful Terminal Commands:
    Running Trusty /devel/@ 5.120GHz32bit/ Please put [ prefix] on New Threads!

  6. #6
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: can not upgrade, error can not calculate upgrade

    Quote Originally Posted by zika View Post
    Code:
    sudo apt-get install -f
    in CLI...
    tried it nothing


    scott@scott-P5QC:~$ sudo apt-get install -f
    [sudo] password for scott:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
    scott@scott-P5QC:~$

  7. #7
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: can not upgrade, error can not calculate upgrade

    Quote Originally Posted by ventrical View Post
    What method are you using to upgrade ?

    edit: Just upgraded here using CLI .. no problems but then I don't have any ppas on THIS install.
    terminal type in

    sudo update-manager -d

  8. #8
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: can not upgrade, error can not calculate upgrade

    significant or no?
    Code:
    scott@scott-P5QC:~$ sudo apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages have been kept back:
      xserver-xorg-video-openchrome xserver-xorg-video-qxl
    0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

  9. #9
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: can not upgrade, error can not calculate upgrade

    upgrade log file
    look for error

    Code:
    2014-02-22 10:20:00,558 INFO Using config files '['./DistUpgrade.cfg.precise']'
    2014-02-22 10:20:00,558 INFO uname information: 'Linux scott-P5QC 3.12.0-031200-generic #201311031935 SMP Mon Nov 4 00:36:54 UTC 2013 x86_64'
    2014-02-22 10:20:00,558 INFO apt version: '0.8.16~exp12ubuntu10.16'
    2014-02-22 10:20:00,558 INFO release-upgrader version '0.210' started
    2014-02-22 10:20:01,005 DEBUG Using 'DistUpgradeViewGtk3' view
    2014-02-22 10:20:01,054 DEBUG aufsOptionsAndEnvironmentSetup()
    2014-02-22 10:20:01,055 DEBUG using '/tmp/upgrade-rw-1S2QYY' as aufs_rw_dir
    2014-02-22 10:20:01,055 DEBUG using '/tmp/upgrade-chroot-6KsWnd' as aufs chroot dir
    2014-02-22 10:20:01,055 DEBUG enable dpkg --force-overwrite
    2014-02-22 10:20:01,073 DEBUG creating statefile: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
    2014-02-22 10:20:04,592 DEBUG lsb-release: 'precise'
    2014-02-22 10:20:04,593 DEBUG _pythonSymlinkCheck run
    2014-02-22 10:20:04,593 DEBUG openCache()
    2014-02-22 10:20:04,593 DEBUG No such plugin directory: ./plugins
    2014-02-22 10:20:04,594 DEBUG plugins for condition 'PreCacheOpen' are '[]'
    2014-02-22 10:20:04,594 DEBUG plugins for condition 'trustyPreCacheOpen' are '[]'
    2014-02-22 10:20:04,594 DEBUG plugins for condition 'from_precisePreCacheOpen' are '[]'
    2014-02-22 10:20:04,594 DEBUG quirks: running PreCacheOpen
    2014-02-22 10:20:04,594 DEBUG running Quirks.PreCacheOpen
    2014-02-22 10:20:05,386 DEBUG /openCache(), new cache size 62434
    2014-02-22 10:20:05,386 DEBUG need_server_mode(): run in 'desktop' mode, (because of key deps for 'ubuntu-desktop')
    2014-02-22 10:20:05,386 DEBUG checkViewDepends()
    2014-02-22 10:20:05,386 DEBUG running doUpdate() (showErrors=False)
    2014-02-22 10:20:06,346 DEBUG openCache()
    2014-02-22 10:20:07,190 DEBUG /openCache(), new cache size 62434
    2014-02-22 10:20:07,190 DEBUG doPostInitialUpdate
    2014-02-22 10:20:07,190 DEBUG plugins for condition 'PostInitialUpdate' are '[]'
    2014-02-22 10:20:07,190 DEBUG plugins for condition 'trustyPostInitialUpdate' are '[]'
    2014-02-22 10:20:07,190 DEBUG plugins for condition 'from_precisePostInitialUpdate' are '[]'
    2014-02-22 10:20:07,190 DEBUG quirks: running from_precisePostInitialUpdate
    2014-02-22 10:20:07,208 DEBUG _test_and_warn_for_unity_3d_support: no unity running
    2014-02-22 10:20:14,034 DEBUG Foreign: 
    2014-02-22 10:20:14,034 DEBUG Obsolete: emblemize udisks2 gstreamer1.0-plugins-good gstreamer1.0-plugins-base indicator-notifications skype:i386 nvidia-screenlet gambas3-gb-qt4-ext libgstreamer-plugins-base1.0-0 gstreamer1.0-x linux-image-extra-3.6.9-030609-generic nautilus-advanced-menu librhythmbox-core6 linux-image-3.12.0-031200-generic libudisks2-0 gambas3-gb-image seafile indicator-ubuntuone webmin wuala libgegl-0.2-0 libbabl-0.1-0 gnome-shell-extensions-common libquicktimecine-cv gnome-shell-extensions-weather handbrake-gtk netflix-desktop gambas3-runtime cinelerra-cv linux-headers-3.6.9-030609 libboost-program-options1.49.0 cinnamon-translations opencpn nautilus-open-terminal-here faenza-icon-theme simplescreenrecorder linux-image-extra-3.5.0-18-generic virtualbox-4.2 gambas3-gb-sdl-sound acpibattery-screenlet teamviewer ubuntu-tweak nvidia-opencl-icd-304 linux-image-3.7.0-030700-generic libmusicbrainz5-0 gnome-shell-extensions libavcodec-extra gir1.2-gcr-3 gambas3-gb-desktop google-talkplugin libmlt5 simplescreenrecorder-lib libswresample0 linux-headers-3.7.0-030700-generic gambas3-gb-web oracle-java7-installer linux-image-3.6.9-030609-generic libgstreamer-plugins-good1.0-0 gambas3-gb-form-stock libcjs0c nautilus-open-as-root cinelerra-doc unsettings linux-headers-3.7.0-030700 libboost-filesystem1.49.0 libopus0 gnome-shell-extensions-user-theme linux-headers-3.6.9-030609-generic wine-browser-installer syncdrive nautilus-refresh libmpeg3cine-cv folderview-screenlet libboost-system1.49.0 wine-silverlight5.1-installer linux-image-extra-3.7.0-030700-generic gambas3-gb-qt4 gcr gir1.2-gck-1 cjs libguicast1-cv fuzzyclock-screenlet libvlccore7 wine-compholio:i386 google-chrome-stable gambas3-gb-form nautilus-gedit linux-headers-3.12.0-031200-generic linux-headers-3.12.0-031200 libgstreamer1.0-0
    2014-02-22 10:20:14,035 DEBUG updateSourcesList()
    2014-02-22 10:20:14,208 DEBUG rewriteSourcesList()
    2014-02-22 10:20:14,211 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted'
    2014-02-22 10:20:14,211 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ trusty main restricted' updated to new dist
    2014-02-22 10:20:14,212 DEBUG examining: 'deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted'
    2014-02-22 10:20:14,212 DEBUG entry 'deb-src http://us.archive.ubuntu.com/ubuntu/ trusty main restricted' updated to new dist
    2014-02-22 10:20:14,212 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted'
    2014-02-22 10:20:14,212 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted' updated to new dist
    2014-02-22 10:20:14,212 DEBUG examining: 'deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted'
    2014-02-22 10:20:14,212 DEBUG entry 'deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted' updated to new dist
    2014-02-22 10:20:14,212 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ precise universe'
    2014-02-22 10:20:14,212 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ trusty universe' updated to new dist
    2014-02-22 10:20:14,212 DEBUG examining: 'deb-src http://us.archive.ubuntu.com/ubuntu/ precise universe'
    2014-02-22 10:20:14,213 DEBUG entry 'deb-src http://us.archive.ubuntu.com/ubuntu/ trusty universe' updated to new dist
    2014-02-22 10:20:14,213 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ precise-updates universe'
    2014-02-22 10:20:14,213 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe' updated to new dist
    2014-02-22 10:20:14,213 DEBUG examining: 'deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates universe'
    2014-02-22 10:20:14,213 DEBUG entry 'deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe' updated to new dist
    2014-02-22 10:20:14,213 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ precise multiverse'
    2014-02-22 10:20:14,213 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ trusty multiverse' updated to new dist
    2014-02-22 10:20:14,213 DEBUG examining: 'deb-src http://us.archive.ubuntu.com/ubuntu/ precise multiverse'
    2014-02-22 10:20:14,214 DEBUG entry 'deb-src http://us.archive.ubuntu.com/ubuntu/ trusty multiverse' updated to new dist
    2014-02-22 10:20:14,214 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ precise-updates multiverse'
    2014-02-22 10:20:14,214 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse' updated to new dist
    2014-02-22 10:20:14,214 DEBUG examining: 'deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates multiverse'
    2014-02-22 10:20:14,214 DEBUG entry 'deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse' updated to new dist
    2014-02-22 10:20:14,214 DEBUG examining: 'deb http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse'
    2014-02-22 10:20:14,214 DEBUG entry 'deb http://us.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse' updated to new dist
    2014-02-22 10:20:14,214 DEBUG examining: 'deb-src http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse'
    2014-02-22 10:20:14,215 DEBUG entry 'deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse' updated to new dist
    2014-02-22 10:20:14,215 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu precise-security main restricted'
    2014-02-22 10:20:14,215 DEBUG entry 'deb http://security.ubuntu.com/ubuntu trusty-security main restricted' updated to new dist
    2014-02-22 10:20:14,215 DEBUG examining: 'deb-src http://security.ubuntu.com/ubuntu precise-security main restricted'
    2014-02-22 10:20:14,215 DEBUG entry 'deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted' updated to new dist
    2014-02-22 10:20:14,215 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu precise-security universe'
    2014-02-22 10:20:14,215 DEBUG entry 'deb http://security.ubuntu.com/ubuntu trusty-security universe' updated to new dist
    2014-02-22 10:20:14,215 DEBUG examining: 'deb-src http://security.ubuntu.com/ubuntu precise-security universe'
    2014-02-22 10:20:14,216 DEBUG entry 'deb-src http://security.ubuntu.com/ubuntu trusty-security universe' updated to new dist
    2014-02-22 10:20:14,216 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu precise-security multiverse'
    2014-02-22 10:20:14,216 DEBUG entry 'deb http://security.ubuntu.com/ubuntu trusty-security multiverse' updated to new dist
    2014-02-22 10:20:14,216 DEBUG examining: 'deb-src http://security.ubuntu.com/ubuntu precise-security multiverse'
    2014-02-22 10:20:14,216 DEBUG entry 'deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse' updated to new dist
    2014-02-22 10:20:14,259 DEBUG running doUpdate() (showErrors=True)
    2014-02-22 10:20:28,334 DEBUG openCache()
    2014-02-22 10:20:28,335 DEBUG failed to SystemUnLock() (E:Not locked) 
    2014-02-22 10:20:33,892 DEBUG /openCache(), new cache size 70749
    2014-02-22 10:20:33,893 DEBUG need_server_mode(): run in 'desktop' mode, (because of key deps for 'ubuntu-desktop')
    2014-02-22 10:20:37,764 DEBUG Installing 'xserver-xorg-video-all' (Distro KeepInstalledPkgs rule)
    2014-02-22 10:21:03,009 ERROR Dist-upgrade failed: 'E:Unable to correct problems, you have held broken packages.'
    2014-02-22 10:21:03,009 DEBUG abort called
    2014-02-22 10:21:03,019 DEBUG openCache()
    2014-02-22 10:21:08,458 DEBUG /openCache(), new cache size 62434
    2014-02-22 10:21:08,458 DEBUG enabling apt cron job

  10. #10
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    5,423
    Distro
    Ubuntu Development Release

    Re: can not upgrade, error can not calculate upgrade

    I see the error . Can't figure it out.

    Just for the sake of it , try:

    Code:
    sudo apt-get update
    sudo apt-get dist-upgrade

    and/or reload from synaptic, then mark/apply. This worked for me once. I had the same error.
    This is Rolling Release
    Warnings for New Beta Testers& Helpful Terminal Commands:
    Running Trusty /devel/@ 5.120GHz32bit/ Please put [ prefix] on New Threads!

Page 1 of 7 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •