Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Problems with mounting external (SATA/USB) drive

  1. #11
    Join Date
    Dec 2005
    Beans
    812
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Problems with mounting external (SATA/USB) drive

    GParted didn't take long. I thought it would reformat the whole drive, it just changed it to EXT4 and wiped all the data (which is okay)
    The line in /etc/fstab for the mount of the external is .

    # / external hard drive - 500Gb
    UUID=43eb-0004 /media/externaldisk ext4 errors=remount-ro 0 1
    and it is mounted but I'm having permission errors. What do I change to give access to "guest" and no password please ?

    43eb-0004 is used for privacy purposes only.
    Last edited by oygle; February 22nd, 2014 at 06:06 AM.

  2. #12
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Problems with mounting external (SATA/USB) drive

    If the partition is mounted on /media/externaldisk and you can see it and manage it with sudo (superuser do alias root permissions), you are now able to give any directory the access you want.

    For example:

    You can make a shared subdirectory and give user/group/others read/write/execute permissions (or set permissions for the whole partition)
    Code:
    sudo mkdir /media/externaldisk/shared
    sudo chmod ugo+rwx /media/externaldisk/shared
    The files that are created in this directory should be available for all logged in users except guest. But if you copy files to the directory and preserve their permissions, you may have to change them afterwards to let the other users access them.

    As guest I can see that a file exists in the directory /home/shared, but I am not allowed to open it. I can also see the /tmp directory and create files there, but not open files created by other users. I tried it in Lubuntu version 13.10.

    I guess the system is made like this for security reasons and I don't know how to increase the permissions for the guest user.

    If it is not OK for you to create normal user (for example 'friends') and set log in without password for 'friends', you have to wait for help from someone else.

  3. #13
    Join Date
    Dec 2005
    Beans
    812
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Problems with mounting external (SATA/USB) drive

    Thanks for explaining that. Have done the cmod and all files under that now are okay for accessing, viewing, writing. I'm not concerned with other users, as I'm the only one who uses this computer. The only reason I mentioned guest was because another mount had this in /etc/fstab

    //192.168.1.100/Win95B /media/windowsshare cifs guest,uid=1000,iocharset=utf8 0 0
    so I thought I had to modify this line ..

    # / external hard drive - 500Gb
    UUID=43eb-0004 /media/externaldisk ext4 errors=remount-ro 0 1
    in the same manner, to enable access to everyone else (other than sudo). It's all working fine now, so I will mark the thread as solved. Thanks for your help.
    Last edited by oygle; February 22nd, 2014 at 08:38 AM.

  4. #14
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Problems with mounting external (SATA/USB) drive

    I'm glad it works

    Please click on Thread Tools at the top of the page and mark this thread as SOLVED

  5. #15
    Join Date
    Dec 2005
    Beans
    812
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Problems with mounting external (SATA/USB) drive

    I don't think I'm mounting this correctly, after having read https://help.ubuntu.com/community/Mount/ , and the problems I had with File system root has only 0 bytes disk space remaing

    I only want the mount to be physical on the external drive, and logical on /dev/sda1. Seems it was physical on /dev/sda1 as well as physical on the external drive.

    I'm sure a "mount point" can be logical, acting like a symbolic link. Like in ~/.gvs path

    Can someone explain please.

  6. #16
    Join Date
    Dec 2005
    Beans
    812
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Problems with mounting external (SATA/USB) drive

    Now when I boot and the external drive is NOT powered on, Ubuntu hangs, no message. There used to be a message about "press S to skip".

    Anyway, I press "S" even though there is no message, and Ubuntu boots up okay.

    Also, Ubuntu at boot, tries 3 times to access a shared mount on another computer, when that computer is powered off.

    It's not a clean boot, possibly the lines in /etc/fstab need modifying slightly.

    ~$ cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc nodev,noexec,nosuid 0 0
    # / was on /dev/sda1 during installation
    UUID=4ce2075s-8f01 / ext3 errors=remount-ro 0 1
    # /home was on /dev/sda3 during installation
    UUID=4ce2075s-8f02 /home ext3 defaults 0 2
    # swap was on /dev/sda5 during installation
    UUID=4ce2075s-8f03 none swap sw 0 0
    # / external hard drive - 500Gb
    UUID=4ce2075s-8f04 /media/externaldisk ext4 errors=remount-ro 0 1
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
    //192.168.1.100/Win95B /media/windowsshare cifs guest,uid=1000,iocharset=utf8 0 0
    4ce2075s-8f0n are not the real UUID's

  7. #17
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Problems with mounting external (SATA/USB) drive

    If you use the option 'noauto' for the drives that are not always connected, the computer will not complain, but it will not automatically mount them either.

    Modify /etc/fstab like this

    Code:
    # external hard drive - 500Gb                                                                                                                                                       
    UUID=4ce2075s-8f04 /media/externaldisk                ext4    noauto,errors=remount-ro 0       1
    -o-

    So you should mount them manually when it is time to do it. If you use a label it will be easy.

    For example the label 'data': Use the full and correct UUID to specify the external disk (instead of 4ce2075s-8f04)

    Code:
    sudo tune2fs -L data UUID=4ce2075s-8f04...
    and then you can mount with

    Code:
    sudo mount -L data

  8. #18
    Join Date
    Dec 2005
    Beans
    812
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Problems with mounting external (SATA/USB) drive

    Quote Originally Posted by sudodus View Post
    If you use the option 'noauto' for the drives that are not always connected, the computer will not complain, but it will not automatically mount them either.
    Thanks for explaining that. I will modify /etc/fstab as you have instructed and give the external drive a label. I must say that 13.10 has less problems with mounting, than 12.04

    Oygle

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •