Results 1 to 8 of 8

Thread: Steam not working after Nvidia driver install/activation

  1. #1
    Join Date
    Feb 2014
    Beans
    12

    Steam not working after Nvidia driver install/activation

    Ok. So steam was working ok until I activated a driver for my video card because I thought that would make things better (is that a bad assumption? sorry I am such a noob to all of this.)

    I restarted my compy and then I tried opening steam and it said the OpenGL GLX was not supported on this display.

    Any assistance would be amazing. Thank you.

  2. #2
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,282
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Steam not working after Nvidia driver install/activation

    can you tell us what gfx card you have and what drivers you installed?
    this will tell us that information
    Code:
    sudo lshw -C display
    paste the output of running that command within a terminal

  3. #3
    Join Date
    Feb 2014
    Beans
    12

    Re: Steam not working after Nvidia driver install/activation

    Here it is.

    *-display
    description: VGA compatible controller
    product: Haswell-ULT Integrated Graphics Controller
    vendor: Intel Corporation
    physical id: 2
    bus info: pci@0000:00:02.0
    version: 09
    width: 64 bits
    clock: 33MHz
    capabilities: msi pm vga_controller bus_master cap_list rom
    configuration: driver=i915 latency=0
    resources: irq:64 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)
    *-display UNCLAIMED
    description: 3D controller
    product: GK107M [GeForce GT 745M]
    vendor: NVIDIA Corporation
    physical id: 0
    bus info: pci@0000:04:00.0
    version: a1
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list
    configuration: latency=0
    resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:d000(size=128) memory:f7000000-f707ffff

  4. #4
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,282
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Steam not working after Nvidia driver install/activation

    looks like you have a system with both a built in igpu within your intel cpu AND an nvidia gpu. I am not familiar with that but i've heard others mention bumblebee. Sorry i can't help

  5. #5
    Join Date
    Aug 2005
    Beans
    6,028

    Re: Steam not working after Nvidia driver install/activation


  6. #6
    Join Date
    Jul 2012
    Beans
    449
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Steam not working after Nvidia driver install/activation

    I also have a GTX770 with a Intel integrated graphics. On 12.04 I only use Nvidia but will both work out of the box after a fresh install of upcoming 14.04?

  7. #7
    Join Date
    Feb 2014
    Beans
    12

    Re: Steam not working after Nvidia driver install/activation

    Thank you, That did the trick.

  8. #8
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,282
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Steam not working after Nvidia driver install/activation

    is it a laptop OR a desktop? I have an i5-4670k and an Nvidia GTX 760, i installed the latest 331.38 Nvidia driver form the website within 13.10 and all works great. I think the issue is on laptops when theres a mix of gpus.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •