Results 1 to 6 of 6

Thread: How to get login sound back

  1. #1
    Join Date
    Nov 2013
    Beans
    26

    How to get login sound back

    I have two Ubuntu 13.10 installed to two laptops of the same brand.

    One plays login sound and one doesn't (although there is sound of drums at the login prompt)

    I don't know why there is such a difference. Just to make sure a correct installation, I'd like to get the login sound back.

    Adding a record in start up list does not working, it says file not found. I wonder if there is a re-install of some pkg can fix it, say, using Synaptic pkg manager?

  2. #2
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    4,330
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to get login sound back

    Open the program "Startup Applications" and add this command
    Code:
    canberra-gtk-play  --file <file/name/here>
    then save or close and it should have whatever sound you picked at startup.
    You can test that the command works by running it in a terminal.

    The old Ubuntu sound should be set in a different place
    /usr/share/gnome/autostart/libcanberra-login-sound.desktop
    in this file change the line
    X-GNOME-Autostart-enabled=false
    to
    X-GNOME-Autostart-enabled=true

    See if that works.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  3. #3
    Join Date
    Nov 2011
    Beans
    1,350
    Distro
    Ubuntu Development Release

    Re: How to get login sound back

    Exact same speakers? I had a machine with speakers that "slept" to save energy. I wouldn't hear login sounds because they took too long to wake up.

  4. #4
    Join Date
    Feb 2010
    Location
    WI USA
    Beans
    10,001
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How to get login sound back

    The old method of adding the sound to start up applications didn't work for me in 13.10 . The sound has been disabled by default since 12.04 but the sound is still in the usr/share/sounds folder. I think it's named desktop-login.ogg . I had enablded the sound in 12.04 with the dconf editor, but this method doesn't work on my 12.04.4 installation. There was a instruction for creating a very simple script to be added to start-up applications , but I haven't been able to locate it yet .


    Edit: Success with 12.04.4 and 13.10 . Open dconf editor and proceed to org > gnome > desktop > sound and make sure sound is set to default , then add the start-up command at the link and restart.

    http://www.ubuntugeek.com/how-to-ena...4-precise.html
    Last edited by Frogs Hair; February 14th, 2014 at 09:25 PM.
    Infinite diversity in infinite combination.

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Manual

  5. #5
    Join Date
    Jan 2013
    Location
    East Yorkshire
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How to get login sound back

    Code:
    gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop 
    Then change autostart enabled to true, & save the file.
    Log out & back in again, & you should have login sound back.
    Last edited by Frogs Hair; February 15th, 2014 at 03:34 PM. Reason: Font

  6. #6
    Join Date
    Nov 2013
    Beans
    26

    Re: How to get login sound back

    Quote Originally Posted by speartip View Post
    Code:
    gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop 
    Then change autostart enabled to true, & save the file.
    Log out & back in again, & you should have login sound back.
    Thanks speartip! Great solution!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •