Results 1 to 2 of 2

Thread: VSFTPD Configuration Issues

  1. #1
    Join Date
    Feb 2014
    Beans
    3

    Question VSFTPD Configuration Issues

    I am trying to use VSFTPD on one of my web servers but I am having issues with virtual users. When I try to login with my test user I get the following error:

    530 Login incorrect.
    Login failed.
    Here is my pam.d vsftpd file:

    Code:
    auth required pam_mysql.so user=[user] passwd=[password] host=localhost db=vsftpd table=accounts usercolumn=username passwdcolumn=pass crypt=0
    account required pam_mysql.so user=[user] passwd=[password] host=localhost db=vsftpd table=accounts usercolumn=username passwdcolumn=pass crypt=0
    Here is my vsftpd.conf file:

    Code:
    listen=YES
    anonymous_enable=NO
    local_enable=YES
    write_enable=YES
    local_umask=022
    dirmessage_enable=YES
    xferlog_enable=YES
    connect_from_port_20=YES
    nopriv_user=sites
    chroot_local_user=YES
    secure_chroot_dir=/var/run/vsftpd
    pam_service_name=vsftpd
    guest_enable=YES
    guest_username=sites
    local_root=/home/sites/$USER
    user_sub_token=$USER
    virtual_use_local_privs=YES
    user_config_dir=/etc/vsftpd_user_conf
    Does anyone know why I would get a login failure with these configurations?
    Last edited by matt59; February 11th, 2014 at 08:44 PM.

  2. #2
    Join Date
    Feb 2014
    Beans
    3

    Re: VSFTPD Configuration Issues

    I started using pure-ftpd instead of vsftpd and it is working now.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •