Results 1 to 6 of 6

Thread: cant telnet external mx dns

  1. #1
    Join Date
    Aug 2013
    Beans
    144

    cant telnet external mx dns

    ok , im running ubuntu 13.10
    then i have postfix and dovecot setup correctly


    i check my mail server if already running using telnet , telnet mail.mydomain.com 25

    and i was connected to my mail server successfully .. , and i can now receive emails local and external message ,

    but the problem is i cant send emails outside my server .

    so id tried to ping mx host of gmail and hotmail


    $ ping aspmx.l.google.com
    and it pings successful
    so id thought that port 80 doesnt have problem

    and maybe the problem is port 25
    i check it using telnet

    $ telnet aspmx.l.google.com 25
    trying 173.blah.blah./blah

    it stucks there .. and doesnt connect

    so i exit the terminal for another session

    and this time i try to telnet port 80

    $ telnet aspmx.l.google.com 80
    same results stucks on trying 173.blah.blah.blah

    i try different ports but (25,110,143,465,587) same results happened ..

    i already disabled my firewall and already forwarded SMTP and IMAP port on my router setting ..


    any ideas ?
    Last edited by jhay2; February 5th, 2014 at 11:00 AM.

  2. #2
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    9,588
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: cant telnet external mx dns

    Your ISP blocks outbound traffic on port 25 as a defense against spambots on its network. Talk to the ISP about your alternatives. Many residential ISP contracts bar the use of servers entirely, so you may not get much help.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  3. #3
    Join Date
    Aug 2013
    Beans
    144

    Re: cant telnet external mx dns

    thanks for reply

    ,i see, if port 25 was blocked by ISP ? how can i force postfix to use outgoing port 587 or other port ? i'd searched google . and they just uncommented submission inet - - - - - smtp on master.cf , but when i uncommented mine , no change . my postfix outgoing port still 25 .. i already try to add 587 inet n - n - - - smtpd but still no luck .. still send on port 25 .. how can i achieve it ?


    heres my config


    main.cf
    myhostname = mail.mydomain.com
    myorigin = /etc/mailname
    mydestination = mail.mydomain.com,mydomain.com, localhost, localhost.localdomain
    relayhost =
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
    mailbox_size_limit = 0
    recipient_delimiter = +
    #inet_interfaces = all
    inet_protocols=ipv4
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    smtpd_tls_cert_file = /opt/lampp/etc/ssl.crt/mailserver.crt
    smtpd_tls_key_file = /opt/lampp/etc/ssl.key/mailserver.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    smtpd_tls_security_level=may
    smtpd_tls_protocols = !SSLv2, !SSLv3


    local_recipient_maps = proxy:unixasswd.byname $alias_maps

    master.cf

    #
    # Postfix master process configuration file. For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # Do not forget to execute "postfix reload" after editing this file.
    #
    # ================================================== ========================
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # ================================================== ========================
    #smtp inet n - - - - smtpd
    587 inet n - n - - smtpd
    #smtp inet n - - - 1 postscreen
    #smtpd pass - - - - - smtpd
    #dnsblog unix - - - - 0 dnsblog
    #tlsproxy unix - - - - 0 tlsproxy
    submission inet n - n - - smtpd
    -o syslog_name=postfix/submission
    -o smtpd_tls_wrappermode=yes
    -o smtpd_tls_security_level=encrypt
    -o smtpd_sasl_auth_enable=yes
    -o smtpd_recipient_restrictions=permit_mynetworks,per mit_sasl_authenticated,reject
    -o milter_macro_daemon_name=ORIGINATING
    -o smtpd_sasl_type=dovecot
    -o smtpd_sasl_path=private/auth
    #submission inet n - - - - smtpd
    # -o syslog_name=postfix/submission
    # -o smtpd_tls_security_level=encrypt
    # -o smtpd_sasl_auth_enable=yes
    # -o smtpd_reject_unlisted_recipient=no
    # -o smtpd_client_restrictions=$mua_client_restrictions
    # -o smtpd_helo_restrictions=$mua_helo_restrictions
    # -o smtpd_sender_restrictions=$mua_sender_restrictions
    # -o smtpd_recipient_restrictions=permit_sasl_authentic ated,reject
    # -o milter_macro_daemon_name=ORIGINATING
    #smtps inet n - - - - smtpd
    # -o syslog_name=postfix/smtps
    # -o smtpd_tls_wrappermode=yes
    # -o smtpd_sasl_auth_enable=yes
    # -o smtpd_reject_unlisted_recipient=no
    # -o smtpd_client_restrictions=$mua_client_restrictions
    # -o smtpd_helo_restrictions=$mua_helo_restrictions
    # -o smtpd_sender_restrictions=$mua_sender_restrictions
    # -o smtpd_recipient_restrictions=permit_sasl_authentic ated,reject
    # -o milter_macro_daemon_name=ORIGINATING
    #628 inet n - - - - qmqpd
    pickup unix n - - 60 1 pickup
    cleanup unix n - - - 0 cleanup
    qmgr unix n - n 300 1 qmgr
    #qmgr unix n - n 300 1 oqmgr
    tlsmgr unix - - - 1000? 1 tlsmgr
    rewrite unix - - - - - trivial-rewrite
    bounce unix - - - - 0 bounce
    defer unix - - - - 0 bounce
    trace unix - - - - 0 bounce
    verify unix - - - - 1 verify
    flush unix n - - 1000? 0 flush
    proxymap unix - - n - - proxymap
    proxywrite unix - - n - 1 proxymap
    smtp unix - - - - - smtp
    relay unix - - - - - smtp
    # -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq unix n - - - - showq
    error unix - - - - - error
    retry unix - - - - - error
    discard unix - - - - - discard
    local unix - n n - - local
    virtual unix - n n - - virtual
    lmtp unix - - - - - lmtp
    anvil unix - - - - 1 anvil
    scache unix - - - - 1 scache
    #
    # ================================================== ==================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent. See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ================================================== ==================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop unix - n n - - pipe
    flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
    #
    # ================================================== ==================
    #
    # Recent Cyrus versions can use the existing "lmtp" master.cf entry.
    #
    # Specify in cyrus.conf:
    # lmtp cmd="lmtpd -a" listen="localhost:lmtp" proto=tcp4
    #
    # Specify in main.cf one or more of the following:
    # mailbox_transport = lmtp:inet:localhost
    # virtual_transport = lmtp:inet:localhost
    #
    # ================================================== ==================
    #
    # Cyrus 2.1.5 (Amos Gouaux)
    # Also specify in main.cf: cyrus_destination_recipient_limit=1
    #
    #cyrus unix - n n - - pipe
    # user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
    #
    # ================================================== ==================
    # Old example of delivery via Cyrus.
    #
    #old-cyrus unix - n n - - pipe
    # flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
    #
    # ================================================== ==================
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp unix - n n - - pipe
    flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail unix - n n - - pipe
    flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp unix - n n - - pipe
    flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix - n n - 2 pipe
    flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman unix - n n - - pipe
    flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
    ${nexthop} ${user}
    any ideas sir ?

  4. #4
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    9,588
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: cant telnet external mx dns

    I'm not a Postfix user, but if you want to relay mail through port 587 at Google don't you need
    Code:
    relayhost=aspmx.l.google.com:587
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  5. #5
    Join Date
    Aug 2013
    Beans
    144

    Re: cant telnet external mx dns

    hi my isp doesnt block port 25 ,

    when i try these
    $ telnet smtp.meridian.ph 25
    its connected so i think port 25 is an open port ,

  6. #6
    Join Date
    Aug 2013
    Beans
    144

    Re: cant telnet external mx dns

    ??

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •