Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Problem with b43 during installation

  1. #1
    Join Date
    Oct 2012
    Beans
    12

    Problem with b43 during installation

    Got an old computer from a friend and a trying to install Lubuntu on it with little success.

    It's an aspire 3003LMi. Mobile Sempron Processor 3000+. 80 Gb. 512MB Ram. It's Lubuntu 13.10 for 32-bits systems I'm trying to install.

    I get to the screen where I can chose to Try it out, Install it, Control for errors, Memory check (rough translation from swedish).

    When I chose Try it out or Installing it starts to load, but a few seconds in something like this pops up;

    b43-phy0 ERROR: firmware file “b43/ucode5.fw” not found
    b43-phy0 ERROR: firmware file “b43-open/ucode5.fw” not found
    b43-phy0 ERROR: You must go to http://wireless.kernel.org and read all the instructions on this website.
    and quickly vanishes again and then the system halts, jumping between a completly black screen and a black screen with a cursor I'm able to move. Note that I have copied the text from another site as the text vanishes to quickly for me to write it down. I know the last line is a bit different in wording, although not in essence.

    I have tried to go F6, Esc and entering
    b43.blacklist=yes
    and Enter, but it doesn't help in any way.

    Here is two links to what seem to be the same problem as I'm having. THey are suggesting the b43.blacklist=yes approach, but as said, that doesn't work for me.

    Any ideas?

  2. #2
    Join Date
    Sep 2013
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Problem with b43 during installation

    If you can, I would try and connect with ethernet to get the OS installed, then we can worry about getting the Broadcom driver installed. If thats not an option, then we will get the driver installed!
    "Ignorance is short-lived, and knowledge is forever."


  3. #3
    Join Date
    Oct 2012
    Beans
    12

    Re: Problem with b43 during installation

    Thanks! Tried with a cable but it didn't help.

    So how do we get the driver installed? I can run the stick on another computer with internet connection without any problem.

  4. #4
    Join Date
    Apr 2009
    Location
    UK Lake District
    Beans
    2,865
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Problem with b43 during installation

    Quote Originally Posted by DoktornTheFirst View Post
    Thanks! Tried with a cable but it didn't help.

    So how do we get the driver installed? I can run the stick on another computer with internet connection without any problem.
    Another computer with the identical hardware? Uh?

    If you have the actual firmware you can copy the folder b43 to /lib/firmware in the live session
    Then modprobe it like this

    Code:
    sudo modprobe -rv b43
    Code:
    sudo modprobe -v b43
    I have a copy of the firmware folder
    https://dl.dropboxusercontent.com/u/...20_09_2013.zip
    Ubuntu Member Always something different. Promoting Ubuntu and System 76 at TUXPC

  5. #5
    Join Date
    Oct 2012
    Beans
    12

    Re: Problem with b43 during installation

    No, very different hardware.

    Ok. I downloaded and installed the firmware in your folder carl4926. I ran the commands on the other, working, computer. Switched to the computer I want to install Lubuntu to an ran it. Same problem. Restarted and by using Ctrl+Alt+F2 right after I chose "Try Ubuntu before installing" I got a command line and entered the commands. Restarted again and still the same problem.

    Did I do something wrong or do you have any more suggestions?

  6. #6
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,578
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Problem with b43 during installation

    It's much more troubling that you cannot seem to connect with a network cable. Can you try that again please? It's been a very long time since I've encountered a machine that could not use wired Ethernet out-of-the-box. If both wired and wifi connections don't work, there is something more fundamentally wrong than just the b43 firmware. I installed Kubuntu on a older machine with a Broadcom wifi adapter and could not connect with it, but I could still connect using the Ethernet adapter.

    Some Broadcom problems can be quickly solved by installing the "linux-firmware-nonfree" package and rebooting. That worked for me.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  7. #7
    Join Date
    Oct 2012
    Beans
    12

    Re: Problem with b43 during installation

    I'm pretty sure it does connect to internet through the wired cable. (It does on Windows XP that is installed.)

    My problem is I don't get far enough for a connection to internet to be an issue at all. I can't get into the Live session and I can't reach the installation guide. I get to where I can chose to try Lubuntu out, install it, check the disc for errors, etc. But when I chose to try it out or install it it starts to load and then crashes with the message I quoted in the OP.

  8. #8
    Join Date
    Apr 2009
    Location
    UK Lake District
    Beans
    2,865
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Problem with b43 during installation

    Ubuntu Member Always something different. Promoting Ubuntu and System 76 at TUXPC

  9. #9
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,578
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Problem with b43 during installation

    6. You should now have a cursor from which you can enter commands below the boot options: Type
    b43.blacklist=yes
    making sure there is a space before and after the text you enter.
    Perhaps you left out a space?
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  10. #10
    Join Date
    Oct 2012
    Beans
    12

    Re: Problem with b43 during installation

    @carl4926
    Yes. My device is supported. BCM4318 to exact.

    @SeijiSensei
    Space before and after was included. (Without also. And with space before, but after and vice versa.)

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •