Results 1 to 5 of 5

Thread: Installing a downloaded package

  1. #1
    Join Date
    Jan 2014
    Beans
    6

    Installing a downloaded package

    I've downloaded a package called pyme_0.8.1+clean.orig.tar.gz for Ubuntu Server (Lucid). I don't have the foggiest idea how to install this package. Being the Server edition, I only have the command line.

    Thanks.

  2. #2
    Join Date
    Mar 2009
    Beans
    29

    Re: Installing a downloaded package

    The package your trying to install is presumably called python-pyme in ubuntu. You can install this using the package manager:
    sudo apt-get install python-pyme

    or

    You can manually install the downloaded file by first opening the archive:
    tar -zxvf pyme_0.8.1+clean.orig.tar.gz
    Then look inside the folder created for the makefile, readme, install, setup files etc.

    The usual way to install programs manuall if it's a source file is to first build and install (specific instructions are usually contained in the readme file):
    make && sudo make install
    If it's a pre-build binary then you might not need to do anything else, or you might have to configure the program with setup or install or some other file... It really depends on the program your installing.

  3. #3
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Installing a downloaded package

    Welcome. Be advised that support ended for 10.04 LTS (Lucid Lynx) in April last year so moving to the latest LTS and an upgrade to the next (14.04 LTS) this April (if you want to) might be your best course of action. The LTS (long-term support) releases now have five years support.

    The easiest way to install, as suggested, is from the repositories with this:

    sudo apt-get install python-pyme

    ... but you might have no luck as support has ended. As well as regular updates, this also means you will not get security updates so being online with this machine is not great.

    Are you new to Ubuntu?
    Last edited by Bucky Ball; January 27th, 2014 at 06:46 PM.

  4. #4
    Join Date
    May 2005
    Location
    US
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Installing a downloaded package

    Quote Originally Posted by Bucky Ball View Post
    Welcome. Be advised that support ended for 10.04 LTS (Lucid Lynx) in April last year so moving to the latest LTS and an upgrade to the next (14.04 LTS) this April (if you want to) might be your best course of action. The LTS (long-term support) releases now have five years support.
    The OP is using the server edition, which is still supported for another year, even though the desktop edition lost support last year:
    http://fridge.ubuntu.com/2013/05/10/...on-may-9-2013/

    Still, your advice is good. There is already a solid LTS release to upgrade to right now--12.04.3.

  5. #5
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Installing a downloaded package

    Quote Originally Posted by aysiu View Post
    The OP is using the server edition, which is still supported for another year, even though the desktop edition lost support last year ...
    My mistake, of course! Apologies. Getting late here, I should go to bed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •