Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: SSH: Permission denied (publickey)

  1. #1
    Join Date
    Jan 2007
    Beans
    16
    Distro
    Ubuntu

    Exclamation SSH: Permission denied (publickey)

    Thank you for your help in advance. I have been working on this for weeks, and pretty frustrated. This is my current status, but have done a lot of research, and tried a lot of tweaks.

    Issue: Permission denied (publickey) ,
    • Client Ubuntu 13.10 | Server Ubuntu 12.04
    • Used following for reference: https://help.ubuntu.com/community/SSH/OpenSSH/Keys
    • Was working with old keys, but did a client reload and hasn't worked since. Could not connect using old keys
    • Generated new keys and manually added them to the authorized_keys on the server, connected once, but on Client reboot could not connect again with new keys.
    • Last kicker was that a reboot removed the authorized_keys file on the client. I recreated it, and added the private key


    .ssh
    Code:
    -rw------- 1 xxxUName xxxUName 1766 Jan 25 16:36 authorized_keys
    -rw-r--r-- 1 xxxUName xxxUName  619 Jan 24 16:37 known_hosts
    -rw------- 1 xxxUName xxxUName 1766 Jan 24 15:42 ServerName_id3
    -rw-r--r-- 1 xxxUName xxxUName  399 Jan 24 15:42 ServerName_id3.pub
    Current Issue:
    Code:
    xxxUName@clientName:~/.ssh$ ssh -vvv xxxUName@192.xx.xx.xx
    OpenSSH_6.2p2 Ubuntu-6ubuntu0.1, OpenSSL 1.0.1e 11 Feb 2013
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: /etc/ssh/ssh_config line 19: Applying options for *
    debug2: ssh_connect: needpriv 0
    debug1: Connecting to 192.xx.xx.xx [192.xx.xx.xx] port 22.
    debug1: Connection established.
    debug1: identity file /home/xxxUName/.ssh/id_rsa type -1
    debug1: identity file /home/xxxUName/.ssh/id_rsa-cert type -1
    debug1: identity file /home/xxxUName/.ssh/id_dsa type -1
    debug1: identity file /home/xxxUName/.ssh/id_dsa-cert type -1
    debug1: identity file /home/xxxUName/.ssh/id_ecdsa type -1
    debug1: identity file /home/xxxUName/.ssh/id_ecdsa-cert type -1
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_6.2p2 Ubuntu-6ubuntu0.1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.9p1 Debian-5ubuntu1.1
    debug1: match: OpenSSH_5.9p1 Debian-5ubuntu1.1 pat OpenSSH_5*
    debug2: fd 3 setting O_NONBLOCK
    debug3: load_hostkeys: loading entries for host "192.xx.xx.xx" from file "/home/xxxUName/.ssh/known_hosts"
    debug3: load_hostkeys: found key type ECDSA in file /home/xxxUName/.ssh/known_hosts:1
    debug3: load_hostkeys: found key type RSA in file /home/xxxUName/.ssh/known_hosts:2
    debug3: load_hostkeys: loaded 2 keys
    debug3: order_hostkeyalgs: prefer hostkeyalgs: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-rsa
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug2: kex_parse_kexinit: ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
    debug2: kex_parse_kexinit: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-rsa,ssh-dss-cert-v01@openssh.com,ssh-dss-cert-v00@openssh.com,ssh-dss
    debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
    debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
    debug2: kex_parse_kexinit: hmac-md5-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-sha1,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: hmac-md5-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-sha1,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
    debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: first_kex_follows 0 
    debug2: kex_parse_kexinit: reserved 0 
    debug2: kex_parse_kexinit: ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
    debug2: kex_parse_kexinit: ssh-rsa,ssh-dss,ecdsa-sha2-nistp256
    debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
    debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: none,zlib@openssh.com
    debug2: kex_parse_kexinit: none,zlib@openssh.com
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: first_kex_follows 0 
    debug2: kex_parse_kexinit: reserved 0 
    debug2: mac_setup: found hmac-md5
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug2: mac_setup: found hmac-md5
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: sending SSH2_MSG_KEX_ECDH_INIT
    debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
    debug1: Server host key: ECDSA ea:bf:60:43:09:b4:49:a5:a3:fd:b3:f4:06:eb:67:f4
    debug3: load_hostkeys: loading entries for host "192.xx.xx.xx" from file "/home/xxxUName/.ssh/known_hosts"
    debug3: load_hostkeys: found key type ECDSA in file /home/xxxUName/.ssh/known_hosts:1
    debug3: load_hostkeys: found key type RSA in file /home/xxxUName/.ssh/known_hosts:2
    debug3: load_hostkeys: loaded 2 keys
    debug1: Host '192.xx.xx.xx' is known and matches the ECDSA host key.
    debug1: Found key in /home/xxxUName/.ssh/known_hosts:1
    debug1: ssh_ecdsa_verify: signature correct
    debug2: kex_derive_keys
    debug2: set_newkeys: mode 1
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug2: set_newkeys: mode 0
    debug1: SSH2_MSG_NEWKEYS received
    debug1: Roaming not allowed by server
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug2: service_accept: ssh-userauth
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug2: key: ServerName_id3 (0x7f9027eb72f0),
    debug2: key: xxxUName@clientName (0x7f9027eb7440),
    debug2: key: /home/xxxUName/.ssh/id_rsa ((nil)),
    debug2: key: /home/xxxUName/.ssh/id_dsa ((nil)),
    debug2: key: /home/xxxUName/.ssh/id_ecdsa ((nil)),
    debug1: Authentications that can continue: publickey
    debug3: start over, passed a different list publickey
    debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
    debug3: authmethod_lookup publickey
    debug3: remaining preferred: keyboard-interactive,password
    debug3: authmethod_is_enabled publickey
    debug1: Next authentication method: publickey
    debug1: Offering RSA public key: ServerName_id3
    debug3: send_pubkey_test
    debug2: we sent a publickey packet, wait for reply
    debug1: Authentications that can continue: publickey
    debug1: Offering RSA public key: xxxUName@clientName
    debug3: send_pubkey_test
    debug2: we sent a publickey packet, wait for reply
    debug1: Authentications that can continue: publickey
    debug1: Trying private key: /home/xxxUName/.ssh/id_rsa
    debug3: no such identity: /home/xxxUName/.ssh/id_rsa: No such file or directory
    debug1: Trying private key: /home/xxxUName/.ssh/id_dsa
    debug3: no such identity: /home/xxxUName/.ssh/id_dsa: No such file or directory
    debug1: Trying private key: /home/xxxUName/.ssh/id_ecdsa
    debug3: no such identity: /home/xxxUName/.ssh/id_ecdsa: No such file or directory
    debug2: we did not send a packet, disable method
    debug1: No more authentication methods to try.
    Permission denied (publickey).

  2. #2
    Join Date
    Jan 2009
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Padawan seeking SSH Jedi Master -- HELP!! Permission denied (publickey)

    debug3: no such identity: /home/xxxUName/.ssh/id_rsa: No such file or directory
    Make sure that you have your private key in .ssh.

  3. #3
    Join Date
    Jan 2007
    Beans
    16
    Distro
    Ubuntu

    Re: Padawan seeking SSH Jedi Master -- HELP!! Permission denied (publickey)

    Quote Originally Posted by ubudog View Post
    Make sure that you have your private key in .ssh.
    Thanks ubudog,

    I have both my Pub and Private key in the ~/.ssh directory as shown below. My authorized_keys file is a duplicate of my Private key "ServerName_id3"

    Code:
    -rw------- 1 xxxUName xxxUName 1766 Jan 25 16:36 authorized_keys
    -rw-r--r-- 1 xxxUName xxxUName  619 Jan 24 16:37 known_hosts
    -rw------- 1 xxxUName xxxUName 1766 Jan 24 15:42 ServerName_id3
    -rw-r--r-- 1 xxxUName xxxUName  399 Jan 24 15:42 ServerName_id3.pub

  4. #4
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Padawan seeking SSH Jedi Master -- HELP!! Permission denied (publickey)

    You should be putting the public key into authorized_keys, not the private key.

    If you have a server with the correct keys, you can use ssh-copy-id to add the proper keys to authorized_keys automagically.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  5. #5
    Join Date
    Mar 2009
    Beans
    1,331

    Re: Padawan seeking SSH Jedi Master -- HELP!! Permission denied (publickey)

    I also don't think ssh keys are portable. When you reloaded your system the system generated new server keys. I can't say for sure though, and don't feel like looking it up. I'm lazy today.

    Anyway, make sure your $HOME is chmod 700, and are you using a DSA key or an RSA key? DSA goes to authorized_keys2. I use DSA.

    You need to delete your whole .ssh directory and start over. The private key needs to never leave the system it was generated on or it is considered compromised. The public key crosses the net, the private one is protected.

    This isn't strictly required but IMO your .ssh directory should be chmod 700 too. Nobody else has any business poking around in there.
    Help stamp out MBR partition tables. Use GPT instead!

  6. #6
    Join Date
    Mar 2009
    Beans
    1,331

    Re: Padawan seeking SSH Jedi Master -- HELP!! Permission denied (publickey)

    So here's what I'd do:
    Code:
    rm -rf .ssh
    ssh-keygen -t dsa
    scp .ssh/id_dsa.pub you@<remote-host-name-or-ip>:
    ssh you@<remote-host-name-or-ip>
    mkdir .ssh
    mv id_dsa.pub .ssh/authorized_keys2
    # You also want to delete your existing key for this host
    exit
    #now from your local machine again:
    ssh you@<remote-host-name-or-ip>
    # and you should be in without a password if you have a stock setup there.
    Help stamp out MBR partition tables. Use GPT instead!

  7. #7
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Padawan seeking SSH Jedi Master -- HELP!! Permission denied (publickey)

    Quote Originally Posted by 1clue View Post
    I also don't think ssh keys are portable. When you reloaded your system the system generated new server keys. I can't say for sure though, and don't feel like looking it up. I'm lazy today.
    They are portable, but you need to be using the correct key.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  8. #8
    Join Date
    Mar 2009
    Beans
    1,331

    Re: Padawan seeking SSH Jedi Master -- HELP!! Permission denied (publickey)

    OK cool, I've never tried to move one because I thought they were somehow tied to the host key.
    Help stamp out MBR partition tables. Use GPT instead!

  9. #9
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Padawan seeking SSH Jedi Master -- HELP!! Permission denied (publickey)

    Running a development version, I do re-installs fairly often, I do weekly backups of my home directory, when I do a new installation, I just restore the relevant directories back to /home/cariboo, in my case.

  10. #10
    Join Date
    Jan 2007
    Beans
    16
    Distro
    Ubuntu

    Re: Padawan seeking SSH Jedi Master -- HELP!! Permission denied (publickey)

    Quote Originally Posted by CharlesA View Post
    You should be putting the public key into authorized_keys, not the private key.

    If you have a server with the correct keys, you can use ssh-copy-id to add the proper keys to authorized_keys automagically.
    Thank you CharlesA,

    I replaced the Authorized_key with the Public key but still have the issue

    Code:
    xxxUName@clientName:~/.ssh$ ssh -vvv xxxUName@192.
    OpenSSH_6.2p2 Ubuntu-6ubuntu0.1, OpenSSL 1.0.1e 11 Feb 2013
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: /etc/ssh/ssh_config line 19: Applying options for *
    debug2: ssh_connect: needpriv 0
    ssh: Could not resolve hostname 192.: Name or service not known
    xxxUName@clientName:~/.ssh$ ssh -vvv xxxUName@192.168.123.106
    OpenSSH_6.2p2 Ubuntu-6ubuntu0.1, OpenSSL 1.0.1e 11 Feb 2013
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: /etc/ssh/ssh_config line 19: Applying options for *
    debug2: ssh_connect: needpriv 0
    debug1: Connecting to 192.168.123.106 [192.168.123.106] port 22.
    debug1: Connection established.
    debug1: identity file /home/xxxUName/.ssh/id_rsa type -1
    debug1: identity file /home/xxxUName/.ssh/id_rsa-cert type -1
    debug1: identity file /home/xxxUName/.ssh/id_dsa type -1
    debug1: identity file /home/xxxUName/.ssh/id_dsa-cert type -1
    debug1: identity file /home/xxxUName/.ssh/id_ecdsa type -1
    debug1: identity file /home/xxxUName/.ssh/id_ecdsa-cert type -1
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_6.2p2 Ubuntu-6ubuntu0.1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.9p1 Debian-5ubuntu1.1
    debug1: match: OpenSSH_5.9p1 Debian-5ubuntu1.1 pat OpenSSH_5*
    debug2: fd 3 setting O_NONBLOCK
    debug3: load_hostkeys: loading entries for host "192.168.123.106" from file "/home/xxxUName/.ssh/known_hosts"
    debug3: load_hostkeys: found key type ECDSA in file /home/xxxUName/.ssh/known_hosts:1
    debug3: load_hostkeys: found key type RSA in file /home/xxxUName/.ssh/known_hosts:2
    debug3: load_hostkeys: loaded 2 keys
    debug3: order_hostkeyalgs: prefer hostkeyalgs: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-rsa
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug2: kex_parse_kexinit: ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
    debug2: kex_parse_kexinit: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-rsa,ssh-dss-cert-v01@openssh.com,ssh-dss-cert-v00@openssh.com,ssh-dss
    debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
    debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
    debug2: kex_parse_kexinit: hmac-md5-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-sha1,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: hmac-md5-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-sha1,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
    debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: first_kex_follows 0 
    debug2: kex_parse_kexinit: reserved 0 
    debug2: kex_parse_kexinit: ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
    debug2: kex_parse_kexinit: ssh-rsa,ssh-dss,ecdsa-sha2-nistp256
    debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
    debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: none,zlib@openssh.com
    debug2: kex_parse_kexinit: none,zlib@openssh.com
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: first_kex_follows 0 
    debug2: kex_parse_kexinit: reserved 0 
    debug2: mac_setup: found hmac-md5
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug2: mac_setup: found hmac-md5
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: sending SSH2_MSG_KEX_ECDH_INIT
    debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
    debug1: Server host key: ECDSA ea:bf:60:43:09:b4:49:a5:a3:fd:b3:f4:06:eb:67:f4
    debug3: load_hostkeys: loading entries for host "192.168.123.106" from file "/home/xxxUName/.ssh/known_hosts"
    debug3: load_hostkeys: found key type ECDSA in file /home/xxxUName/.ssh/known_hosts:1
    debug3: load_hostkeys: found key type RSA in file /home/xxxUName/.ssh/known_hosts:2
    debug3: load_hostkeys: loaded 2 keys
    debug1: Host '192.168.123.106' is known and matches the ECDSA host key.
    debug1: Found key in /home/xxxUName/.ssh/known_hosts:1
    debug1: ssh_ecdsa_verify: signature correct
    debug2: kex_derive_keys
    debug2: set_newkeys: mode 1
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug2: set_newkeys: mode 0
    debug1: SSH2_MSG_NEWKEYS received
    debug1: Roaming not allowed by server
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug2: service_accept: ssh-userauth
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug2: key: ServerName_id3 (0x7ff16a5012f0),
    debug2: key: xxxUName@clientName (0x7ff16a501440),
    debug2: key: /home/xxxUName/.ssh/id_rsa ((nil)),
    debug2: key: /home/xxxUName/.ssh/id_dsa ((nil)),
    debug2: key: /home/xxxUName/.ssh/id_ecdsa ((nil)),
    debug1: Authentications that can continue: publickey
    debug3: start over, passed a different list publickey
    debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
    debug3: authmethod_lookup publickey
    debug3: remaining preferred: keyboard-interactive,password
    debug3: authmethod_is_enabled publickey
    debug1: Next authentication method: publickey
    debug1: Offering RSA public key: ServerName_id3
    debug3: send_pubkey_test
    debug2: we sent a publickey packet, wait for reply
    debug1: Authentications that can continue: publickey
    debug1: Offering RSA public key: xxxUName@clientName
    debug3: send_pubkey_test
    debug2: we sent a publickey packet, wait for reply
    debug1: Authentications that can continue: publickey
    debug1: Trying private key: /home/xxxUName/.ssh/id_rsa
    debug3: no such identity: /home/xxxUName/.ssh/id_rsa: No such file or directory
    debug1: Trying private key: /home/xxxUName/.ssh/id_dsa
    debug3: no such identity: /home/xxxUName/.ssh/id_dsa: No such file or directory
    debug1: Trying private key: /home/xxxUName/.ssh/id_ecdsa
    debug3: no such identity: /home/xxxUName/.ssh/id_ecdsa: No such file or directory
    debug2: we did not send a packet, disable method
    debug1: No more authentication methods to try.
    Permission denied (publickey).

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •