Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: 12.04 LTS 80 improperly installed packages?

  1. #1
    Join Date
    Jan 2014
    Beans
    4

    12.04 LTS 80 improperly installed packages?

    Hey -
    So I tried to update flashplayer with the "sudo apt-get install flashplugin-installer" command, and it brought up a EULA agreement for some MS fonts thing. I had no idea how to accept it, so I just exited the terminal. Apparently that was a very bad idea, and screwed a lot of things up.

    Now every time I try to use dpkg or apt for anything, I get this (example used is sudo apt-get autoremove):
    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages will be REMOVED:
      ttf-mscorefonts-installer
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    80 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
    dpkg: warning: there's no installed package matching ttf-mscorefonts-installer:amd64
    Setting up man-db (2.6.1-2ubuntu1) ...
    debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
    dpkg: error processing man-db (--configure):
     subprocess installed post-installation script returned error exit status 1
    Setting up libc6:i386 (2.15-0ubuntu10.5) ...
    debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
    dpkg: error processing libc6:i386 (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of libsqlite3-0:i386:
     libsqlite3-0:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libsqlite3-0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libstdc++6:i386:
     libstdc++6:i386 depends on libc6 (>= 2.11); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libstdc++6:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libcomerr2:i386:
     libcomerr2:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libcomerr2:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libdbus-1-3:i386:
     libdbus-1-3:i386 depends on libc6 (>= 2.10); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libdbus-1-3:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libffi6:i386:
     libffi6:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libffi6:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libpcre3:i386:
     libpcre3:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libpcre3:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libselinux1:i386:
     libselinux1:i386 depends on libc6 (>= 2.8); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libselinux1:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of zlib1g:i386:
     zlib1g:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing zlib1g:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libglib2.0-0:i386:
     libglib2.0-0:i386 depends on libc6 (>= 2.15); however:
      Package libc6:i386 is not configured yet.
     libglib2.0-0:i386 depends on libffi6 (>= 3.0.4); however:
      Package libffi6:i386 is not configured yet.
     libglib2.0-0:i386 depends on libpcre3 (>= 8.10); however:
      Package libpcre3:i386 is not configured yet.
     libglib2.0-0:i386 depends on libselinux1 (>= 1.32); however:
      Package libselinux1:i386 is not configured yet.
     libglib2.0-0:i386 depends on zlib1g (>= 1:1.2.2); however:
      Package zlib1g:i386 is not configured yet.
    dpkg: error processing libglib2.0-0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libpng12-0:i386:
     libpng12-0:i386 depends on libc6 (>= 2.11); however:
      Package libc6:i386 is not configured yet.
     libpng12-0:i386 depends on zlib1g (>= 1:1.1.4); however:
      Package zlib1g:i386 is not configured yet.
    dpkg: error processing libpng12-0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libssl1.0.0:i386:
     libssl1.0.0:i386 depends on libc6 (>= 2.7); however:
      Package libc6:i386 is not configured yet.
     libssl1.0.0:i386 depends on zlib1g (>= 1:1.1.4); however:
      Package zlib1g:i386 is not configured yet.
    dpkg: error processing libssl1.0.0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libuuid1:i386:
     libuuid1:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libuuid1:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgpg-error0:i386:
     libgpg-error0:i386 depends on libc6 (>= 2.1.3); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libgpg-error0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgcrypt11:i386:
     libgcrypt11:i386 depends on libc6 (>= 2.15); however:
      Package libc6:i386 is not configured yet.
     libgcrypt11:i386 depends on libgpg-error0 (>= 1.10); however:
      Package libgpg-error0:i386 is not configured yet.
    dpkg: error processing libgcrypt11:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libp11-kit0:i386:
     libp11-kit0:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libp11-kit0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libtasn1-3:i386:
     libtasn1-3:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libtasn1-3:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgnutls26:i386:
     libgnutls26:i386 depends on libc6 (>= 2.8); however:
      Package libc6:i386 is not configured yet.
     libgnutls26:i386 depends on libgcrypt11 (>= 1.4.5); however:
      Package libgcrypt11:i386 is not configured yet.
     libgnutls26:i386 depends on libp11-kit0 (>= 0.11); however:
      Package libp11-kit0:i386 is not configured yet.
     libgnutls26:i386 depends on libtasn1-3 (>= 1.6-0); however:
      Package libtasn1-3:i386 is not configured yet.
     libgnutls26:i386 depends on zlib1g (>= 1:1.1.4); however:
      Package zlib1g:i386 is not configured yet.
    dpkg: error processing libgnutls26:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkrb5support0:i386:
     libkrb5support0:i386 depends on libc6 (>= 2.3.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libkrb5support0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libk5crypto3:i386:
     libk5crypto3:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
     libk5crypto3:i386 depends on libkrb5support0 (>= 1.7dfsg~beta2); however:
      Package libkrb5support0:i386 is not configured yet.
    dpkg: error processing libk5crypto3:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkeyutils1:i386:
     libkeyutils1:i386 depends on libc6 (>= 2.7); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libkeyutils1:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkrb5-3:i386:
     libkrb5-3:i386 depends on libc6 (>= 2.9); however:
      Package libc6:i386 is not configured yet.
     libkrb5-3:i386 depends on libcomerr2 (>= 1.34); however:
      Package libcomerr2:i386 is not configured yet.
     libkrb5-3:i386 depends on libk5crypto3 (>= 1.9+dfsg~beta1); however:
      Package libk5crypto3:i386 is not configured yet.
     libkrb5-3:i386 depends on libkeyutils1; however:
      Package libkeyutils1:i386 is not configured yet.
     libkrb5-3:i386 depends on libkrb5support0 (= 1.10+dfsg~beta1-2ubuntu0.3); however:
      Package libkrb5support0:i386 is not configured yet.
    dpkg: error processing libkrb5-3:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgssapi-krb5-2:i386:
     libgssapi-krb5-2:i386 depends on libc6 (>= 2.7); however:
      Package libc6:i386 is not configured yet.
     libgssapi-krb5-2:i386 depends on libcomerr2 (>= 1.34); however:
      Package libcomerr2:i386 is not configured yet.
     libgssapi-krb5-2:i386 depends on libk5crypto3 (>= 1.8+dfsg); however:
      Package libk5crypto3:i386 is not configured yet.
     libgssapi-krb5-2:i386 depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.3); however:
      Package libkrb5-3:i386 is not configured yet.
     libgssapi-krb5-2:i386 depends on libkrb5support0 (>= 1.7dfsg~beta2); however:
      Package libkrb5support0:i386 is not configured yet.
    dpkg: error processing libgssapi-krb5-2:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libxau6:i386:
     libxau6:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libxau6:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libxdmcp6:i386:
     libxdmcp6:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libxdmcp6:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libxcb1:i386:
     libxcb1:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
     libxcb1:i386 depends on libxau6; however:
      Package libxau6:i386 is not configured yet.
     libxcb1:i386 depends on libxdmcp6; however:
      Package libxdmcp6:i386 is not configured yet.
    dpkg: error processing libxcb1:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libx11-6:i386:
     libx11-6:i386 depends on libc6 (>= 2.15); however:
      Package libc6:i386 is not configured yet.
     libx11-6:i386 depends on libxcb1 (>= 1.2); however:
      Package libxcb1:i386 is not configured yet.
    dpkg: error processing libx11-6:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libxext6:i386:
     libxext6:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
     libxext6:i386 depends on libx11-6 (>= 2:1.4.99.1); however:
      Package libx11-6:i386 is not configured yet.
    dpkg: error processing libxext6:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libxml2:i386:
     libxml2:i386 depends on libc6 (>= 2.15); however:
      Package libc6:i386 is not configured yet.
     libxml2:i386 depends on zlib1g (>= 1:1.2.3.3.dfsg); however:
      Package zlib1g:i386 is not configured yet.
    dpkg: error processing libxml2:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libasound2:i386:
     libasound2:i386 depends on libc6 (>= 2.7); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libasound2:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libasyncns0:i386:
     libasyncns0:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libasyncns0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libice6:i386:
     libice6:i386 depends on libc6 (>= 2.11); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libice6:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libsm6:i386:
     libsm6:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
     libsm6:i386 depends on libice6 (>= 1:1.0.0); however:
      Package libice6:i386 is not configured yet.
     libsm6:i386 depends on libuuid1 (>= 2.16); however:
      Package libuuid1:i386 is not configured yet.
    dpkg: error processing libsm6:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libxt6:i386:
     libxt6:i386 depends on libc6 (>= 2.7); however:
      Package libc6:i386 is not configured yet.
     libxt6:i386 depends on libice6 (>= 1:1.0.0); however:
      Package libice6:i386 is not configured yet.
     libxt6:i386 depends on libsm6; however:
      Package libsm6:i386 is not configured yet.
     libxt6:i386 depends on libx11-6; however:
      Package libx11-6:i386 is not configured yet.
    dpkg: error processing libxt6:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libaudio2:i386:
     libaudio2:i386 depends on libc6 (>= 2.15); however:
      Package libc6:i386 is not configured yet.
     libaudio2:i386 depends on libxau6; however:
      Package libxau6:i386 is not configured yet.
     libaudio2:i386 depends on libxt6; however:
      Package libxt6:i386 is not configured yet.
    dpkg: error processing libaudio2:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libavahi-common3:i386:
     libavahi-common3:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libavahi-common3:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libavahi-client3:i386:
     libavahi-client3:i386 depends on libavahi-common3 (>= 0.6.22); however:
      Package libavahi-common3:i386 is not configured yet.
     libavahi-client3:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
     libavahi-client3:i386 depends on libdbus-1-3 (>= 1.1.1); however:
      Package libdbus-1-3:i386 is not configured yet.
    dpkg: error processing libavahi-client3:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libcups2:i386:
     libcups2:i386 depends on libavahi-client3 (>= 0.6.16); however:
      Package libavahi-client3:i386 is not configured yet.
     libcups2:i386 depends on libavahi-common3 (>= 0.6.16); however:
      Package libavahi-common3:i386 is not configured yet.
     libcups2:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
     libcups2:i386 depends on libgnutls26 (>= 2.12.6.1-0); however:
      Package libgnutls26:i386 is not configured yet.
     libcups2:i386 depends on libgssapi-krb5-2 (>= 1.10+dfsg~); however:
      Package libgssapi-krb5-2:i386 is not configured yet.
     libcups2:i386 depends on zlib1g (>= 1:1.1.4); however:
      Package zlib1g:i386 is not configured yet.
    dpkg: error processing libcups2:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libexpat1:i386:
     libexpat1:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libexpat1:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libogg0:i386:
     libogg0:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libogg0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libflac8:i386:
     libflac8:i386 depends on libc6 (>= 2.7); however:
      Package libc6:i386 is not configured yet.
     libflac8:i386 depends on libogg0 (>= 1.0rc3); however:
      Package libogg0:i386 is not configured yet.
    dpkg: error processing libflac8:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libfreetype6:i386:
     libfreetype6:i386 depends on libc6 (>= 2.11); however:
      Package libc6:i386 is not configured yet.
     libfreetype6:i386 depends on zlib1g (>= 1:1.1.4); however:
      Package zlib1g:i386 is not configured yet.
    dpkg: error processing libfreetype6:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libfontconfig1:i386:
     libfontconfig1:i386 depends on libc6 (>= 2.7); however:
      Package libc6:i386 is not configured yet.
     libfontconfig1:i386 depends on libexpat1 (>= 1.95.8); however:
      Package libexpat1:i386 is not configured yet.
     libfontconfig1:i386 depends on libfreetype6 (>= 2.2.1); however:
      Package libfreetype6:i386 is not configured yet.
    dpkg: error processing libfontconfig1:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgstreamer0.10-0:i386:
     libgstreamer0.10-0:i386 depends on libc6 (>= 2.15); however:
      Package libc6:i386 is not configured yet.
     libgstreamer0.10-0:i386 depends on libglib2.0-0 (>= 2.31.8); however:
      Package libglib2.0-0:i386 is not configured yet.
     libgstreamer0.10-0:i386 depends on libxml2 (>= 2.7.4); however:
      Package libxml2:i386 is not configured yet.
    dpkg: error processing libgstreamer0.10-0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of liborc-0.4-0:i386:
     liborc-0.4-0:i386 depends on libc6 (>= 2.4); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing liborc-0.4-0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgstreamer-plugins-base0.10-0:i386:
     libgstreamer-plugins-base0.10-0:i386 depends on libc6 (>= 2.7); however:
      Package libc6:i386 is not configured yet.
     libgstreamer-plugins-base0.10-0:i386 depends on libglib2.0-0 (>= 2.31.8); however:
      Package libglib2.0-0:i386 is not configured yet.
     libgstreamer-plugins-base0.10-0:i386 depends on libgstreamer0.10-0 (>= 0.10.36); however:
      Package libgstreamer0.10-0:i386 is not configured yet.
     libgstreamer-plugins-base0.10-0:i386 depends on liborc-0.4-0 (>= 1:0.4.16); however:
      Package liborc-0.4-0:i386 is not configured yet.
     libgstreamer-plugins-base0.10-0:i386 depends on zlib1g (>= 1:1.1.4); however:
      Package zlib1g:i386 is not configured yet.
    dpkg: error processing libgstreamer-plugins-base0.10-0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libsamplerate0:i386:
     libsamplerate0:i386 depends on libc6 (>= 2.1.3); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libsamplerate0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libjack-jackd2-0:i386:
     libjack-jackd2-0:i386 depends on libc6 (>= 2.7); however:
      Package libc6:i386 is not configured yet.
     libjack-jackd2-0:i386 depends on libsamplerate0 (>= 0.1.7); however:
      Package libsamplerate0:i386 is not configured yet.
     libjack-jackd2-0:i386 depends on libstdc++6 (>= 4.6); however:
      Package libstdc++6:i386 is not configured yet.
    dpkg: error processing libjack-jackd2-0:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libjpeg-turbo8:i386:
     libjpeg-turbo8:i386 depends on libc6 (>= 2.7); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing libjpeg-turbo8:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of liblcms1:i386:
     liblcms1:i386 depends on libc6 (>= 2.7); however:
      Package libc6:i386 is not configured yet.
    dpkg: error processing liblcms1:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: too many errors, stopping
    Errors were encountered while processing:
     man-db
     libc6:i386
     libsqlite3-0:i386
     libstdc++6:i386
     libcomerr2:i386
     libdbus-1-3:i386
     libffi6:i386
     libpcre3:i386
     libselinux1:i386
     zlib1g:i386
     libglib2.0-0:i386
     libpng12-0:i386
     libssl1.0.0:i386
     libuuid1:i386
     libgpg-error0:i386
     libgcrypt11:i386
     libp11-kit0:i386
     libtasn1-3:i386
     libgnutls26:i386
     libkrb5support0:i386
     libk5crypto3:i386
     libkeyutils1:i386
     libkrb5-3:i386
     libgssapi-krb5-2:i386
     libxau6:i386
     libxdmcp6:i386
     libxcb1:i386
     libx11-6:i386
     libxext6:i386
     libxml2:i386
     libasound2:i386
     libasyncns0:i386
     libice6:i386
     libsm6:i386
     libxt6:i386
     libaudio2:i386
     libavahi-common3:i386
     libavahi-client3:i386
     libcups2:i386
     libexpat1:i386
     libogg0:i386
     libflac8:i386
     libfreetype6:i386
     libfontconfig1:i386
     libgstreamer0.10-0:i386
     liborc-0.4-0:i386
     libgstreamer-plugins-base0.10-0:i386
     libsamplerate0:i386
     libjack-jackd2-0:i386
     libjpeg-turbo8:i386
     liblcms1:i386
    Processing was halted because theE: Sub-process /usr/bin/dpkg returned an error code (1)
    For someone brand new to Linux....this is terrifying. I have no idea what's going on, or how to fix this. Any help?

    Thanks.

  2. #2
    Join Date
    Sep 2013
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: 12.04 LTS 80 improperly installed packages?

    I would shutdown, then turn on, hook up to your router with ethernet, open a terminal and type:
    Code:
    sudo apt-get update
    Good luck,
    Chris
    "Ignorance is short-lived, and knowledge is forever."


  3. #3
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    5,276
    Distro
    Ubuntu

    Re: 12.04 LTS 80 improperly installed packages?

    If Ubuntu is something new for you, it is best to use the given gui/graphical applications to install and remove packages.
    In this case, use the software center.

    That said, try
    Code:
    sudo apt-get -f install
    if see if does anything.
    Maybe try
    Code:
    sudo dpkg --configure -a
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  4. #4
    Join Date
    Aug 2012
    Beans
    Hidden!

    Re: 12.04 LTS 80 improperly installed packages?

    As well as the above posts, note that you can't have 2 package management programs like Synaptic, Ubuntu software centre, apt-get in terminal, or the update manager program, running at the same time. The dpkg process puts a lock on to prevent serious problems. Note in your output,
    debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
    Usually means you had a second package management app running.

  5. #5
    Join Date
    Jan 2014
    Beans
    4

    Re: 12.04 LTS 80 improperly installed packages?

    coldcritter64:
    How would I go about closing any other package management apps? Restarting the computer doesn't seem to be working.

  6. #6
    Join Date
    Aug 2012
    Beans
    Hidden!

    Re: 12.04 LTS 80 improperly installed packages?

    Quote Originally Posted by jacob18 View Post
    coldcritter64:
    How would I go about closing any other package management apps? Restarting the computer doesn't seem to be working.
    Usually just closing the second program (a few of the usual culprits are in my last post) does it. A restart should have fixed it..

    Edit : Have you tried deadflowr's post ? That seems like a good start.

  7. #7
    Join Date
    Jan 2014
    Beans
    4

    Re: 12.04 LTS 80 improperly installed packages?

    Yes, I tried deadflowr's post, and both commands just gave essentially the same output as in the OP. I also tried tfru's advice, to no avail as well. I'm hesitant to try Ubi_one_2014's advice because Ubuntu is warning me that it could cause a lot of problems. Should I give it a try?

  8. #8
    Join Date
    Aug 2012
    Beans
    Hidden!

    Re: 12.04 LTS 80 improperly installed packages?

    No, imo. I agree with your assessment on that command.

    Edit:
    so I just exited the terminal. Apparently that was a very bad idea, and screwed a lot of things up.
    A stale lock file maybe. You may have a corrupted config even. You may need to wait for more experienced helpers than me on this, IF that is the case.
    Last edited by coldcritter64; January 25th, 2014 at 09:41 AM.

  9. #9
    Join Date
    Jan 2014
    Beans
    4

    Re: 12.04 LTS 80 improperly installed packages?

    Okay, thanks for your effort. I am at a loss for what to do next.

  10. #10
    Join Date
    May 2007
    Location
    The New Forest
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: 12.04 LTS 80 improperly installed packages?

    I'm hesitant to try Ubi_one_2014's advice because Ubuntu is warning me that it could cause a lot of problems. Should I give it a try?
    No - you shouldn't.

    Reboot - at the grub menu - pick advanced - then from the new menu pick the second item - that will lead you to a new menu.

    You should see a dpkg option - try that, it will ask if you want to mount - answer yes.

    Once that's done it's job, enter (I think to return to the menu) then choose root from the list.

    Then try

    Code:
    apt-get -f install
    dpkg --configure -a
    Make sure to get spaces in the right place when you copy those commands down.
    Last edited by Elfy; January 25th, 2014 at 10:28 AM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •