Results 1 to 7 of 7

Thread: conky running but not displaying

  1. #1
    Join Date
    Sep 2006
    Beans
    8,365
    Distro
    Ubuntu 14.04 Trusty Tahr

    conky running but not displaying

    Conky runs for a while and then, seemingly randomly, will stop displaying. Sending it a SIGHUP reloads the configuration file and causes it to resume displaying. Sometimes it will display for a long time other times a short time but it seems it will always eventually stop displaying. Has anyone seen this problem and know of a solution?

  2. #2
    Join Date
    Sep 2006
    Beans
    8,365
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: conky running but not displaying

    Still no closer to identifying the problem. Even in debugging mode (-D) it provides no special output when it stops displaying.

  3. #3
    Join Date
    Sep 2006
    Beans
    8,365
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: conky running but not displaying

    For reference, it seems to be this bug:

    https://bugs.launchpad.net/ubuntu/+s...y/+bug/1226277

  4. #4
    Join Date
    Mar 2014
    Beans
    Hidden!

    Re: conky running but not displaying

    In your conky config this setting usually causes this in unity.
    Code:
    own_window_type desktop
    Try
    Code:
    own_window yes
    own_window_transparent yes
    own_window_type override
    own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
    #own_window_argb_visual yes
    own_window_argb_value 0
    own_window_type override does not work well with argb transparency so comment that line out.
    override windows are not under the control of the window manager. own_window_hints are ignored.

    or

    Code:
    own_window yes
    own_window_transparent no
    own_window_type normal
    own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
    own_window_argb_visual yes
    own_window_argb_value 100  #use 0-255 ... 0=0% opacity
    own_window_type normal windows use own_window_hints and are under control of the window manager.
    If own_window_transparent is set to no you can set a degree of transparency with own_window_argb_visual yes
    and an own_window_argb_value between 0 and 255.
    0=0% opacity
    255=100% opacity
    If own_window_transparent is set to yes and own_window_argb_visual yes is used
    the own_window_argb_value is ignored and the window is always fully transparent.

    When using own_window_type normal, compiz by default will minimize conky
    with other windows when you show the desktop.
    Use ccsm to untick Hide Skip Taskbar Windows
    Logout or restart unity and conky to take effect.
    Attached Images Attached Images
    Last edited by grumblebum2; May 5th, 2014 at 10:38 AM.

  5. #5
    Join Date
    Sep 2006
    Beans
    8,365
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: conky running but not displaying

    The only one that had an effect was "own_window_type normal" and that put the output in a standard window available only on a single virtual desktop. It's a step.

  6. #6
    Join Date
    Mar 2014
    Beans
    Hidden!

    Re: conky running but not displaying

    own_window_type normal
    needs to be used with
    own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

  7. #7
    Join Date
    Sep 2006
    Beans
    8,365
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: conky running but not displaying

    Thanks. The two lines together fixed it.

    Code:
    own_window_type normal
    own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •