Results 1 to 9 of 9

Thread: Computer no longer shows grub2 on startup(Can't boot to Windows anymore)

  1. #1
    Join Date
    Jan 2014
    Beans
    4

    Computer no longer shows grub2 on startup(Can't boot to Windows anymore)

    I have an older computer that dualboots Xubuntu and Windows XP. Everything was fine, with no problems at all, until recently after the computer was unplugged and unused for about a month, but now it no longer shows grub2 at startup, and thus it boots into Xubuntu directly every time.
    I have run a program I found on here called Boot Repair but it did nothing.

    Any help is greatly appreciated!

  2. #2
    Join Date
    Jun 2009
    Location
    New Mexico
    Beans
    260
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Computer no longer shows grub2 on startup(Can't boot to Windows anymore)

    Does Gparted still show your Windows partition? If so, you might try

    Code:
    sudo grub-install /dev/sdX
    
    sudo update-grub
    where X is the drive where both systems live.

    This is one way to re-order the entries in the grub menu.
    Last edited by egeezer; January 18th, 2014 at 05:44 AM.

  3. #3
    Join Date
    Jan 2014
    Beans
    4

    Re: Computer no longer shows grub2 on startup(Can't boot to Windows anymore)

    Gparted shows the partition, and I even have access to all the files through Xubuntu(There's an icon to directly access the "157GB Filesystem" which goes directly to that partition).

    I ran those commands in the terminal and rebooted but it still boots directly to Xubuntu.

    One thing that I forgot to mention. When booting the monitor displays an error for about 5 seconds that says "The frequency is out of range", and I don't remember it ever used to doing that. I've been testing it with CRT monitors.

  4. #4
    Join Date
    May 2008
    Beans
    213
    Distro
    Lubuntu

    Re: Computer no longer shows grub2 on startup(Can't boot to Windows anymore)

    I can't remember what key you had to press and hold while booting to show grub boot option... Try the shift key. If not, you can do some research on it.

  5. #5
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Computer no longer shows grub2 on startup(Can't boot to Windows anymore)

    Post link to BootInfo report.
    Post the link to the Create BootInfo report. Is part of Boot-Repair:
    https://help.ubuntu.com/community/Boot-Info

    The video issue is not directly related to XP issue. It could be grub has wrong video or install has wrong video. Did you set or have system set it with one monitor and now using one with less capability? If you still have that post separate thread with that issue in title and details on monitor & video card.
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  6. #6
    Join Date
    Jan 2014
    Beans
    4

    Re: Computer no longer shows grub2 on startup(Can't boot to Windows anymore)

    Here the the URL from the report: http://paste.ubuntu.com/6778166


    I also tried booting with a sidescreen LCD monitor. During boot it goes through a phase for about 5 seconds where it says "Input not supported" then continues to work fine.

  7. #7
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Computer no longer shows grub2 on startup(Can't boot to Windows anymore)

    Perhaps the monitor issue is causing it to somehow skip grub menu as menu looks normal and shows both Ubuntu & XP as boot choices. With both choices menu should show by default.

    Grub does try to use system video, so if not correct may be an issue.

    You could try this.
    Boot-Repair --> Advanced options --> GRUB options tab --> tick the "Uncomment GFXMODE" option --> Apply

    I think it changes this setting in /etc/default/grub, so you can reset to size monitor supports.

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  8. #8
    Join Date
    Jan 2014
    Beans
    4

    Re: Computer no longer shows grub2 on startup(Can't boot to Windows anymore)

    Oldfred, I took out the graphics card and booted using the VGA port on the motherboard, same issue. It kept having that weird monitor issue with both CRT monitors and the widescreen LED.
    But, after ticking that option in Boot Repair it now works like a champ. Grub shows up correctly.

    Thank you so much!

  9. #9
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Computer no longer shows grub2 on startup(Can't boot to Windows anymore)

    Glad you got it working.

    If video mode of 640x480 gives too large grub menu, you can change to whatever your monitor(s) support.
    You can at grub menu go to grub terminal and use the vbeinfo to see what your system supports.
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •