Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 34

Thread: Can't install AMD Radeon R7 260X Graphics Driver on 13.10

  1. #21
    squakie is offline I Ubuntu, Therefore, I Am
    Join Date
    Oct 2012
    Beans
    2,238
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't install AMD Radeon R7 260X Graphics Driver on 13.10

    Does this happen when you (1) purge as I suggested (2) install fglrx via apt-get?

    If so, what happens when you (1) purge fglrx as I suggest and (2) install fglrx-updates via apt-get?

    Both os these will attempt to install the driver and also install Catalyst. It would be nice to know if the problem is related only to fglrx, or if it also applies to fglrx-updates.

    Please, let us know if you have tried these and then what any error messages were.

  2. #22
    Join Date
    Feb 2008
    Location
    In my skin.
    Beans
    Hidden!
    Distro
    Xubuntu

  3. #23
    squakie is offline I Ubuntu, Therefore, I Am
    Join Date
    Oct 2012
    Beans
    2,238
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't install AMD Radeon R7 260X Graphics Driver on 13.10

    Also, someone here can probably tell you how (I don't know) to download a slightly older version - I running 2:13.101-0ubuntu3 of fglrx-updates and was able to remove and reinstall it just now just fine.

  4. #24
    Join Date
    Sep 2005
    Beans
    1,606
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Can't install AMD Radeon R7 260X Graphics Driver on 13.10

    Where's [slooksterpsv] been? - I had Catastrophic partition alignment failure. I lost 90%+ of my data, and just now got it back fixed and working.

  5. #25
    Join Date
    Jun 2013
    Location
    Paris, France
    Beans
    31
    Distro
    Ubuntu

    Re: Can't install AMD Radeon R7 260X Graphics Driver on 13.10

    I have tried pretty much everything that has been suggested. I purged all the fglrx and then after downloading and unpacking the zip files from the AMD site I tried

    sudo apt-get install fglrx*

    The result was...here is copy-and-paste of the messages from apt-get

    john@samba:~$ sudo apt-get install fglrx*
    [sudo] password for john:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Note, selecting 'fglrx-driver-dev' for regex 'fglrx*'
    Note, selecting 'fglrx-pxpress' for regex 'fglrx*'
    Note, selecting 'fglrx-updates' for regex 'fglrx*'
    Note, selecting 'fglrx-dev' for regex 'fglrx*'
    Note, selecting 'fglrx-control' for regex 'fglrx*'
    Note, selecting 'fglrx-amdcccle-updates' for regex 'fglrx*'
    Note, selecting 'xfree86-driver-fglrx-dev' for regex 'fglrx*'
    Note, selecting 'xorg-driver-fglrx-dev' for regex 'fglrx*'
    Note, selecting 'fglrx-glx' for regex 'fglrx*'
    Note, selecting 'fglrx-control-qt2' for regex 'fglrx*'
    Note, selecting 'fglrx-amdcccle' for regex 'fglrx*'
    Note, selecting 'fglrx-driver' for regex 'fglrx*'
    Note, selecting 'fglrx-updates-dev' for regex 'fglrx*'
    Note, selecting 'fglrx' for regex 'fglrx*'
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:


    The following packages have unmet dependencies:
    fglrx : Conflicts: fglrx-driver
    Conflicts: xorg-driver-binary
    fglrx-amdcccle : Conflicts: fglrx-control
    fglrx-amdcccle-updates : Conflicts: fglrx-control
    fglrx-dev : Conflicts: fglrx-driver-dev
    fglrx-updates : Conflicts: fglrx-driver
    Conflicts: xorg-driver-binary
    fglrx-updates-dev : Conflicts: fglrx-driver-dev
    E: Unable to correct problems, you have held broken packages.

    So now I don't know what to do and would really appreciate some more help.

  6. #26
    Join Date
    Sep 2005
    Beans
    1,606
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Can't install AMD Radeon R7 260X Graphics Driver on 13.10

    After you extract the zip file are you running:

    Code:
    sudo ./extracted_AMD_file.run
    Where extracted_AMD_file.run is the file it extracted?
    Where's [slooksterpsv] been? - I had Catastrophic partition alignment failure. I lost 90%+ of my data, and just now got it back fixed and working.

  7. #27
    Join Date
    Jun 2013
    Location
    Paris, France
    Beans
    31
    Distro
    Ubuntu

    Re: Can't install AMD Radeon R7 260X Graphics Driver on 13.10

    Yes I did, but I forgot to "sudo" and so the script hung. I will be back after I do it correctly.

  8. #28
    Join Date
    Jun 2013
    Location
    Paris, France
    Beans
    31
    Distro
    Ubuntu

    Re: Can't install AMD Radeon R7 260X Graphics Driver on 13.10

    Running the installer with "sudo" results in a message saying that there is another fglrx installed. The log file says

    Supported adapter detected.


    [Error]A previous installation of fglrx driver detected to be installed in dkms.
    User must uninstall existing fglrx driver
    or run install with force option.
    Forcing the installation is not recommended.
    Output of 'dkms status -m fglrx'
    fglrx, 13.101, 3.11.0-15-generic, x86_64: installed

  9. #29
    Join Date
    Sep 2005
    Beans
    1,606
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Can't install AMD Radeon R7 260X Graphics Driver on 13.10

    There's a directory some where, it may be /usr/lib/fglrx that has a command to remove fgrlx, I'd have to research it, but it'll go through and manually rip everything out.
    Where's [slooksterpsv] been? - I had Catastrophic partition alignment failure. I lost 90%+ of my data, and just now got it back fixed and working.

  10. #30
    Join Date
    Jun 2013
    Location
    Paris, France
    Beans
    31
    Distro
    Ubuntu

    Re: Can't install AMD Radeon R7 260X Graphics Driver on 13.10

    I was able to get rid of the earlier fglrx files with sudo apt-get purge fglrx. The proprietary installation proceeded but failed. Here is the output from the install log

    Supported adapter detected.
    Check if system has the tools required for installation.
    Uninstalling any previously installed drivers.


    Creating symlink /var/lib/dkms/fglrx/13.251/source ->
    /usr/src/fglrx-13.251


    DKMS: add completed.


    Kernel preparation unnecessary for this kernel. Skipping...


    Building module:
    cleaning build area....
    cd /var/lib/dkms/fglrx/13.251/build; sh make.sh --nohints --uname_r=3.11.0-15-generic --norootcheck....(bad exit status: 1)
    [Error] Kernel Module : Failed to build fglrx-13.251 with DKM


    Deleting module version: 13.251
    completely from the DKMS tree.

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •