Results 1 to 6 of 6

Thread: limits.conf

  1. #1
    Join Date
    Jul 2011
    Beans
    16

    limits.conf

    Hi All,
    I need to augment the max number of file opened per process.
    If I send the command ulimit -a on root user, I receive 1024 and if I send the command on apache user, I receive 4096.
    I've read many documents on the net, so I've followed common tips, but none was the right one.
    - I've set on limits.conf:
    * soft nofile 65000
    - On /etc/pam.d/sshd /etc/pam.d/login /etc/pam.d/common-session I've check or added the line "session required pam_limits.so"
    I've added fs.file-max = 65000 on /etc/sysctl.conf file
    - I've rebooted the system
    What I need to do? In the next future, could I change the nofile value without reboot the system?
    Thanks for the help.

  2. #2
    Join Date
    Jul 2011
    Beans
    16

    Re: limits.conf

    Please, give me an help

  3. #3
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    1,422
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: limits.conf

    The only thing I can suggest is that you give us a little more information about your specific application and what error messages you are getting.
    The only difference I observe between our two limits.conf file is that my setting isn't soft:
    Code:
    #        - memlock - max locked-in-memory address space (KB)
    #        - nofile - max number of open files (smythies.com - so Samba will not complain)
    * - nofile 16384
    #        - rss - max resident set size (KB)
    #        - stack - max stack size (KB)
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  4. #4
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

  5. #5
    Join Date
    Feb 2007
    Location
    West Hills CA
    Beans
    8,050
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: limits.conf

    What problem are you trying to solve? Perhaps there are other ways to solve it?

    When you changed your sysctl.conf settings did the behavior of your system change? What is the behavior?
    -------------------------------------
    Oooh Shiny: PopularPages

    Unumquodque potest reparantur. Patientia sit virtus.

  6. #6
    Join Date
    Jul 2011
    Beans
    16

    Re: limits.conf

    Please, can you change the category of this post in General Help?
    I tried hard limit also in limits.conf.
    I need to augment the number of concurrent connection possible. It is not an hardware limit, because during the stress tests (8K and 16K concurrent get requests), the cpu was busy for 40%, ram was 90% free, but active connections had never been more than 4K.
    The time of the answer to get requests exploded. Can you suggest a way to augment the number of concurrent connection possible?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •