Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Mbox2 Mini doesn't work with Audacity

  1. #1
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Mbox2 Mini doesn't work with Audacity

    * This is now resolved. See page 3, post #22.

    Hi all,

    Using 14.04 minimal install with xfce4, Audacity 2.0.5 and this kernel:

    3.13.0-2-generic

    I plug in the Mbox and dmesg gives me the read out:
    Code:
    [ 6732.317601] usb 2-1.1: Product: Mbox 2 
    [ 6732.317604] usb 2-1.1: Manufacturer: Digidesign
    [ 6732.317607] usb 2-1.1: SerialNumber: Digidesign
    [ 6732.391436] usb-audio: Sending Digidesign Mbox 2 boot sequence...
    [ 6732.895463] usb-audio: device not ready, resending boot sequence...
    [ 6733.399245] usb-audio: device not ready, resending boot sequence...
    [ 6733.903046] usb-audio: device not ready, resending boot sequence...
    [ 6734.406828] usb-audio: device not ready, resending boot sequence...
    [ 6734.910609] usb-audio: device not ready, resending boot sequence...
    [ 6735.414430] usb-audio: device not ready, resending boot sequence...
    [ 6740.918758] usb-audio: Digidesign Mbox 2: 24bit 48kHz
    [ 6740.921732] usbcore: registered new interface driver snd-usb-audio
    That may or may not be good, unsure. When I choose the Mbox in Audacity and attempt to record I get the attached screenshot error.

    There are other issues with Audacity in 14.04, but I'll start here. The Mbox is sitting there with its green light on and looking quite happy. Doesn't crash the computer (as it did in earlier releases), but is just not operational with Audacity. Haven't tried with anything else. The odd thing is that I installed the 13.04 kernel in 12.04 sometime ago (the drivers for the MBox are in that kernel but not 12.04) and it worked perfectly. Tried a few months later and nothing, same error as this.
    Attached Images Attached Images
    Last edited by Bucky Ball; January 20th, 2014 at 07:41 PM.

  2. #2
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Mbox2 Mini doesn't work with Audacity

    PS: The MBox2 also doesn't show in Pulseaudio Volume Cortrol. It does in my other (12.04) installs but I get the same error (from memory or something similar) with Audacity.

    ... and the sample rate is fine.

    * Update: When I set it to 'default' I can record, but there is a bunch of noise occurring. Oddly, I can't hear that through the headphones, only see it on the levels.

    See attached screenshot for noise.

    PS: I take that back. I think the MBox2 is showing up in PAVolume control, but as 'Integrated Rate Matching Hub Analogue Stereo'. ?
    Attached Images Attached Images
    Last edited by Bucky Ball; January 12th, 2014 at 10:57 AM.

  3. #3
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Mbox2 Mini doesn't work with Audacity

    Still battling away with this. But wait, there's more. From 'aplay -L':

    Code:
    sysdefault:CARD=M2
        Mbox 2, USB Audio
        Default Audio Device
    front:CARD=M2,DEV=0
        Mbox 2, USB Audio
        Front speakers
    surround40:CARD=M2,DEV=0
        Mbox 2, USB Audio
        4.0 Surround output to Front and Rear speakers
    surround41:CARD=M2,DEV=0
        Mbox 2, USB Audio
        4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=M2,DEV=0
        Mbox 2, USB Audio
        5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=M2,DEV=0
        Mbox 2, USB Audio
        5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=M2,DEV=0
        Mbox 2, USB Audio
        7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=M2,DEV=0
        Mbox 2, USB Audio
        IEC958 (S/PDIF) Digital Audio Output
    dmix:CARD=M2,DEV=0
        Mbox 2, USB Audio
        Direct sample mixing device
    dsnoop:CARD=M2,DEV=0
        Mbox 2, USB Audio
        Direct sample snooping device
    hw:CARD=M2,DEV=0
        Mbox 2, USB Audio
        Direct hardware device without any conversions
    plughw:CARD=M2,DEV=0
        Mbox 2, USB Audio
        Hardware device with all software conversions
    This is just the section concerning the MBox2. There's a lot more besides about the other devices.

    See attached alsamixer pic: 'This sound device does not have any controls' for the MBox2, although it does show controls under Pulseaudio V Control under the heading 'Integrated Rate Matching Hub Analogue Stereo'. I get no action on the level meters except for a heap of noise showing on the input tab which I can't hear either through the computer or the MBox2. (Pic #2) Truly baffled.

    Still digging. Any required info just ask.

    PS: If I launch Audacity from a terminal and set the input and output device to the MBox2 and hit record, this is the error message:

    Code:
    Expression 'hostFormat = PaUtil_SelectClosestAvailableFormat( availableFormats, parameters->sampleFormat )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 1720
    Expression 'hostFormat = PaUtil_SelectClosestAvailableFormat( availableFormats, parameters->sampleFormat )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 1720
    I have looked for 'src/hostapi/alsa/pa_linux_alsa.c' but can't find the file/directory.

    PPS: And a little more grist for the mill; the output of alsa-base.conf:

    Code:
    # autoloader aliases
    install sound-slot-0 /sbin/modprobe snd-card-0
    install sound-slot-1 /sbin/modprobe snd-card-1
    install sound-slot-2 /sbin/modprobe snd-card-2
    install sound-slot-3 /sbin/modprobe snd-card-3
    install sound-slot-4 /sbin/modprobe snd-card-4
    install sound-slot-5 /sbin/modprobe snd-card-5
    install sound-slot-6 /sbin/modprobe snd-card-6
    install sound-slot-7 /sbin/modprobe snd-card-7
    
    # Cause optional modules to be loaded above generic modules
    install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
    #
    # Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
    install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
    install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
    install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
    #
    install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
    # Cause optional modules to be loaded above sound card driver modules
    install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
    install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }
    
    # Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
    install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
    # Prevent abnormal drivers from grabbing index 0
    options bt87x index=-2
    options cx88_alsa index=-2
    options saa7134-alsa index=-2
    options snd-atiixp-modem index=-2
    options snd-intel8x0m index=-2
    options snd-via82xx-modem index=-2
    options snd-usb-audio index=-2
    options snd-usb-caiaq index=-2
    options snd-usb-ua101 index=-2
    options snd-usb-us122l index=-2
    options snd-usb-usx2y index=-2
    # Ubuntu #62691, enable MPU for snd-cmipci
    options snd-cmipci mpu_port=0x330 fm_port=0x388
    # Keep snd-pcsp from being loaded as first soundcard
    options snd-pcsp index=-2
    # Keep snd-usb-audio from beeing loaded as first soundcard
    options snd-usb-audio index=-2
    'index=-2' which I have marked in bold on the last line of the output I tried changing to '-1'. No diff.
    Attached Images Attached Images
    Last edited by Bucky Ball; January 14th, 2014 at 05:00 AM.

  4. #4
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Mbox2 Mini doesn't work with Audacity

    ... and another clue:

    Code:
    cat /proc/asound/cards 
     0 [MID            ]: HDA-Intel - HDA Intel MID
                          HDA Intel MID at 0xd6100000 irq 44
     1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                          HDA ATI HDMI at 0xd6010000 irq 46
     2 [M2             ]: USB-Audio - Mbox 2
                          Digidesign Mbox 2 at usb-0000:00:1d.0-1.1, full speed
    The section in bold in the last line tells me something. Shouldn't it be showing usb number? So, to the output of 'lsusb':

    Code:
    Bus 002 Device 004: ID 046d:c52e Logitech, Inc. 
    Bus 002 Device 003: ID 0dba:3000  
    Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 004: ID 04f2:b128 Chicony Electronics Co., Ltd 
    Bus 001 Device 003: ID 0930:0508 Toshiba Corp. Integrated Bluetooth HCI
    Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    'Bus 002 Device 3' is where it should be showing up I think, so I have the identifier number-wise for the device. So the MBox2 is kinda half recognised. At this point:

    alsa recognises it, names it as the MBox2, but won't show controls;
    PAVControl shows it under a different name;
    lsusb doesn't show it but has a the numbers ...

    No doubt this will get ironed out in a future update, but I may as well keep a record of my progress with it on 14.04 LTS here as I go. Might provide some tips for future travellers.
    Last edited by Bucky Ball; January 14th, 2014 at 06:52 AM.

  5. #5
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Mbox2 Mini doesn't work with Audacity

    After some more research, I edited /etc/modprobe.d/alsa-base.conf, commented out anything with

    Code:
    options snd-usb-audio index=-2
    as that can apparently prevent the USB device from getting not just 2 but any slot, then I added the last six lines at the end of the file underneath '# My options for the default setup' (which are commented out because they didn't work; they made the MBox2 vanish, didn't check other audio) .

    Code:
    # autoloader aliases
    install sound-slot-0 /sbin/modprobe snd-card-0
    install sound-slot-1 /sbin/modprobe snd-card-1
    install sound-slot-2 /sbin/modprobe snd-card-2
    install sound-slot-3 /sbin/modprobe snd-card-3
    install sound-slot-4 /sbin/modprobe snd-card-4
    install sound-slot-5 /sbin/modprobe snd-card-5
    install sound-slot-6 /sbin/modprobe snd-card-6
    install sound-slot-7 /sbin/modprobe snd-card-7
    
    # Cause optional modules to be loaded above generic modules
    install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
    #
    # Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
    install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
    install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
    install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
    #
    install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
    # Cause optional modules to be loaded above sound card driver modules
    install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
    install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }
    
    # Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
    install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
    # Prevent abnormal drivers from grabbing index 0
    options bt87x index=-2
    options cx88_alsa index=-2
    options saa7134-alsa index=-2
    options snd-atiixp-modem index=-2
    options snd-intel8x0m index=-2
    options snd-via82xx-modem index=-2
    # options snd-usb-audio index=-2
    options snd-usb-caiaq index=-2
    options snd-usb-ua101 index=-2
    options snd-usb-us122l index=-2
    options snd-usb-usx2y index=-2
    # Ubuntu #62691, enable MPU for snd-cmipci
    options snd-cmipci mpu_port=0x330 fm_port=0x388
    # Keep snd-pcsp from being loaded as first soundcard
    options snd-pcsp index=-2
    # Keep snd-usb-audio from beeing loaded as first soundcard
    # options snd-usb-audio index=-2
    # options snd-usb-audio index=2 vid=0dba \ pid=3000
    # My options for the default setup
    # alias snd-card-0 snd-hda-intel
    # alias snd-card-1 snd-hda-ati
    # alias snd-card-2 snd-usb-audio
    # options snd-hda-intel index=0
    # options snd-hda-ati index=1
    # options snd-usb-audio index=2 vid=0dba pid=3000
    The stuff at the bottom of the file in bold is what I've tried at various times. All ideas gratefully accepted.

    PS: Just to mention something else I noticed: being a minimal install I have neither libav-tools or ffmpeg installed. Perhaps that is preventing the MBox from being correctly recognised?
    Last edited by Bucky Ball; January 14th, 2014 at 11:30 AM.

  6. #6
    Join Date
    Jun 2005
    Location
    Where?
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Mbox2 Mini doesn't work with Audacity

    Try this It worked for me.
    Just above the line <# Prevent abnormal drivers from grabbing index 0>
    I had to add This
    Code:
    options snd_hda_intel index=1
    Then I rebooted.
    From here http://ubuntu4me.blogspot.com/2012/0...rd-select.html
    Just read this from your last post
    Code:
    I have neither libav-tools or ffmpeg installed. Perhaps that is preventing the MBox from being correctly recognised?
    I do have those installed!
    Last edited by runrickus; January 14th, 2014 at 02:56 PM.
    “Those who desire to give up freedom in order to gain security will not have, nor do they deserve, either one" Benjamin Franklin

  7. #7
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Mbox2 Mini doesn't work with Audacity

    @runrickus: Thanks. Would be handy if I was having trouble getting my default card picked up, but I'm not. Your suggestions and link have given me a few ideas though so I'm going to investigate some more.

    This:
    Quote Originally Posted by runrickus

    Just above the line <# Prevent abnormal drivers from grabbing index 0>
    ... makes me think I should try my option lines where you suggest, above that line.

    * Update: And I did. My latest escapade ...

    Code:
    # My New experiment ...
    # alias snd-card-0 snd-hda-intel
    # alias snd-card-1 snd-hda-intel
    # alias snd-card-2 snd-usb-audio
    # alias snd-card-3 snd-usb-audio
    # options snd-hda-intel index=0
    # options snd-hda-intel index=1
    # options snd-usb-audio index=2 vid=0dba pid=3000
    # options snd-usb-audio index=3 vid=0dba pid=3000
    Didn't work (which is why they're commented out). Leaves the MBox switched off, although regular audio working fine.

    * Further update: I tried the low latency kernel

    3.11.0-11-lowlatency

    ... as I thought it might overcome the 'Error while opening sound device. Please check the input device settings and the project sample rate' issue. It didn't.
    Last edited by Bucky Ball; January 14th, 2014 at 05:53 PM.

  8. #8
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Mbox2 Mini doesn't work with Audacity

    Just spotted something:
    Code:
    aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: MID [HDA Intel MID], device 0: ALC272 Analog [ALC272 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 2: M2 [Mbox 2], device 0: USB Audio [USB Audio]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Card 0 and card 2 are both device 0. I'm thinking this is wrong.

  9. #9
    Join Date
    Jun 2005
    Location
    Where?
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Mbox2 Mini doesn't work with Audacity

    BuckyBall Maybe just maybe this will shed some info
    http://www.zamaudio.com/?p=97
    Hope you get this working I am interested in the Mbox
    “Those who desire to give up freedom in order to gain security will not have, nor do they deserve, either one" Benjamin Franklin

  10. #10
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Mbox2 Mini doesn't work with Audacity

    Thanks for that but was my first port of call about a year ago. The driver (great work from the developer) has been accepted into alsa and is built in to the kernel now so these instructions aren't necessary for the more recent kernels. I have a feeling this is something to do with 14.04 being a bit undercooked for now and hoping it will come together as the release gets closer.

    The driver has been in the kernel since the 3.9 kernel from memory. I installed that kernel in a 12.04 install about a year ago, the MBox2 worked faultlessly with Audacity, I forgot about it and when I tried to use it again with that kernel about six months later, nothing. Couldn't get it to work.

    I'll keep plugging away as being able to record things 'on the fly' using Ubuntu and via the MBox is a vital missing piece of the puzzle for me and Ubuntu. I'm a musician and musicologist so I'm not just doing this for the heck of it. I need to boot into Windows for anything audio and I'd rather not. I use Ubuntu for everything else.

    PS: The MBox2 is a great little piece of technology, vastly improved by the fact that it can (apparently) be used with Linux now and one is no longer locked into the Mac/Windows/ProTools loop with the device. It is old, but perfect for my needs (I also have an eight channel audio interface running on the desktop but not exactly portable and booting the desktop and Ardour to record one compositional idea on an acoustic guitar is overkil ... besides, by the time all that's up and running there's a good chance I would have forgotten what I wanted to record ... an occupational hazard!).
    Last edited by Bucky Ball; January 15th, 2014 at 03:37 AM.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •