Results 1 to 3 of 3

Thread: screen blanking screensaver and other stuff xfce4-power-manager

  1. #1
    Join Date
    Jul 2011
    Location
    Lubuntu One Stop Group
    Beans
    Hidden!
    Distro
    Lubuntu

    screen blanking screensaver and other stuff xfce4-power-manager

    Using Lubuntu 13.10 is a pleasure, but the screensaver (or power saving) settings have been a little wierd.

    this post
    suggests doing it in the "default applications for lxsession"

    What i've found is that you need to create a new file:

    ~/.config/lxsession/Lubuntu/autostart
    you will need to add a few things. begin each line with @
    Code:
    #start the power manager because 13.10 doesnt enable it by default
    @xfce4-power-manager
    Code:
    #turn x.org default screensaver off because we are using the xfce4 power manager
    @xset s off
    finally logging out doesn't seem to work 100%. I really don't understand why I have to reboot... but, reboot and you should be able to configure your screen blanking with the xfce4 power manager (in the start menu) instead of having x.org blank your screen. Also i like the xfce4 power manager battery management.

    verify xfce4 is running with: (pgrep returns a pid)
    Code:
    $pgrep xfce4-power- -lf
    verify xorg screensaver is off with (last line should be "timeout: 0" )
    Code:
    $xset q|grep Screen -C2
    FYI 13.10 doesn't have an animated screensaver. If you want that you will have to install a screensaver, but I do not provide instructions here.

    Chers!

  2. #2
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: screen blanking screensaver and other stuff xfce4-power-manager

    I would like to add a link to a bug report about locking and screensaving in Lubuntu 13.10.

    https://bugs.launchpad.net/ubuntu/+s...m/+bug/1205384

    See the posts by Jarno Suni

  3. #3
    Join Date
    Jan 2014
    Beans
    1

    Re: screen blanking screensaver and other stuff xfce4-power-manager

    I love you! Man, I've been trying to fix this problem for weeks - yours is the only solution that actually works! I was on the verge of uninstalling Lubuntu - thank-you thank-you thank-you!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •