Page 48 of 65 FirstFirst ... 38464748495058 ... LastLast
Results 471 to 480 of 650

Thread: HOWTO: Configuring Logitech mice in Ubuntu 6.06: New Guide

  1. #471
    Join Date
    May 2007
    Beans
    7

    Re: HOWTO: Configuring Logitech mice in Ubuntu 6.06: New Guide

    I got it working - almost... My Mouse i Mx500
    What i want to do is not to map the keys to back and forward..
    I want to map them as aditional mousebuttons.
    Either as i did in windows by mapping the keys to F8 F9 F10 F11 and F12.
    I need the keys for World of Warcraft.

    Do any of you have any idea on how to map them to either mousebuttons or keyboard keys ?
    Im using cedega and kde.

  2. #472
    Join Date
    Oct 2005
    Location
    California
    Beans
    572
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: HOWTO: Configuring Logitech mice in Ubuntu 6.06: New Guide

    If you don't use xbindkeys, they are already just mouse buttons. If you want to map them to existing mouse buttons (such as have two left clicks or two right clicks), you can use "click" in xbindkeys which is part of the tutorial. And to map it to keys, just change the:
    Code:
    "/usr/bin/xvkbd -xsendevent -text "\[Alt_L]\[Right]""
    to something like:
    Code:
    "/usr/bin/xvkbd -xsendevent -text "\[F8]""
    aka anime4christ (I'm a guy, btw.)
    My personal boring website ^_^
    Jesus has changed your life. Save changes? (Y/N)

  3. #473
    Join Date
    Jun 2007
    Beans
    16
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: Configuring Logitech mice in Ubuntu 6.06: New Guide

    Quote Originally Posted by jhr79 View Post
    Hi!

    By following several guides I have got my Logitech Mediaplay to work somehow. I'm now able to use scroll wheel to scroll both vertically and horizontally. But I can't get the media keys to work whatever I have tried.

    All buttons work when testing with xev, but I'm not able to set the keyboard shortcuts in Gnome. When I select ie. "Volume down" and try to assign new shortcut it just reverts to the original when I press the corresponding mouse button.

    Any tips?

    ----
    My current configuration is

    xorg.conf
    Code:
    Section "InputDevice"
            Identifier  "Configured Mouse"
            Driver      "evdev"
            Option      "CorePointer"
            Option      "Device" "/dev/input/event9"
            Option      "ZAxisMapping" "6 7 4 5"
            Option      "Buttons" "7"
    EndSection
    .Xmodmap
    Code:
    pointer = 1 2 3 4 5 7 6

    Funny, because I have the media keys working, but can't get the horizontal scroll to work. Did you ever get the media keys working? If not, here's what I did:

    1. Install xbindkeys and put this is in your .xbindkeysrc config:

    Code:
    # Volume
    
    "xvkbd -text "\[XF86AudioRaiseVolume]""
      m:0x0 + b:13
    
    "xvkbd -text "\[XF86AudioLowerVolume]""
      m:0x0 + b:14
    
    # Media Control
    
    "rhythmbox-client"
      m:0x10 + b:10
    
    "xvkbd -text "\[XF86AudioPlay]""
      m:0x10 + b:17
    
    "xvkbd -text "\[XF86AudioNext]""
      m:0x10 + b:15
    
    "xvkbd -text "\[XF86AudioPrev]""
      m:0x10 + b:16
    2. I'm not sure that this is really needed, but you *might* need to add the XF86 keysyms above to your .Xmodmap file. Here's mine:

    Code:
    keycode 122 = XF86Search
    keycode 129 = XF86AudioMedia
    keycode 130 = XF86WWW
    keycode 162 = XF86AudioPlay XF86AudioPause
    keycode 164 = XF86AudioStop
    keycode 174 = XF86AudioLowerVolume
    keycode 176 = XF86AudioRaiseVolume
    keycode 230 = XF86Favorites
    keycode 231 = XF86Refresh
    keycode 233 = XF86Forward
    keycode 234 = XF86Back
    This not only lowers and raises the volume, but also shows the indicator on the screen (something that all of the other instructions I've seen don't do, btw.)

    Does the horizontal scroll wheel work for you in firefox? I tried your configuration in my xorg.conf and it didn't work for me. If it does work for you, then was there anything else needed or is that it?

    UPDATE:

    I think I've figured out what you meant, after realizing that I can scroll horizontally in OpenOffice apps, and presumably Nautilus as well, though I haven't tried it yet. I was testing it in firefox, where horizontal scroll registers as back and forward. I don't like this, so I'm gonna keep working to see if I can get horizontal scrolling working in firefox.

    UPDATE 2:

    Okay, I finally got everything working as I want with horizontal scrolling working with the scrollwheel and back/forward working with the thumb buttons. All I needed to do was add the following line to my .xbindkeysrc file to get the thumb buttons to function as back/forward in firefox and nautilus:

    Code:
    # Forward and Back
    
    "xvkbd -xsendevent -text "\[Alt_L]\[Left]""
      m:0x10 + b:8
    
    "xvkbd -xsendevent -text "\[Alt_L]\[Right]""
      m:0x10 + b:9
    And then configuring firefox for horizontal scrolling with the scrollwheel, which already worked in Nautilus, by typing "about:config" in the address bar, to go to the config page, and changing the values of “mousewheel.horizscroll.withnokey.action” and “mousewheel.horizscroll.withnokey.numlines” both to 1.
    Last edited by rogun; June 3rd, 2007 at 04:07 AM. Reason: Resolution

  4. #474
    Join Date
    Feb 2007
    Beans
    28

    Re: HOWTO: Configuring Logitech mice in Ubuntu 6.06: New Guide

    I've been trying to get the following working, but return with a 404 error:

    wget http://detyabozhye.com/other/logitec....4test1.tar.gz

    Is anyone else experiencing this problem? Solutions?

    Thanks

  5. #475
    Join Date
    Oct 2005
    Location
    California
    Beans
    572
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: HOWTO: Configuring Logitech mice in Ubuntu 6.06: New Guide

    I think I removed that in favor of lomoco.
    aka anime4christ (I'm a guy, btw.)
    My personal boring website ^_^
    Jesus has changed your life. Save changes? (Y/N)

  6. #476
    Join Date
    Jun 2007
    Beans
    1

    Re: HOWTO: Configuring Logitech mice in Ubuntu 6.06: New Guide

    I've gone through this tutorial, and a couple of other older ones, and I still can't get full functionality out of my keyboard and mouse.

    I have the Logitech Elite Duo. I can't get cruise control to work, and locomo reports that it isn't a supported device so I can't use cruise that way either.

    I also can't get the extra buttons on my keyboard working, which seems to be a common problem around here, but none of the solutions have worked for me. It seems like its something to do with "evdev" because before I used this tutorial, and set "evdev" as the mouse driver, the keys on my keyboard worked fine but the extra mouse buttons didn't.

    Doesn't seem like I can use full functionality for my keyboard and mouse at the same time. Does anyone have a solution that maybe they haven't posted that I could try out? I swear I've tried EVERYTHING.

  7. #477
    Join Date
    Jun 2007
    Beans
    129

    Re: HOWTO: Configuring Logitech mice in Ubuntu 6.06: New Guide

    Hi all:

    After long last, I have finally gotten my MX518 to work properly (thanks to the excellent posts made in this thread and others at this site). However, there is one small matter: I have this script that I told Ubuntu to run at startup (I did this through System->Preferences->Session, and then added a startup thing), and what I have it do is execute the command "lomoco -m --sms", then a few other commands to set up evrouter. The thing is that the lomoco line seems to be failing, and I think it has something to do with the fact that you have to run the command as root.

    Right now, I manually run the lomoco command after startup, but I would really like it to be executed as part of the script. Does anyone know how to accomplish this? Thanks.

    Edit:

    thecorch: Could you tell me exactly what isn't working for your mouse? I just went through hell trying to get my mouse working, maybe I can help.
    Last edited by LordKelvan; June 10th, 2007 at 02:09 AM.

  8. #478
    Join Date
    Jul 2006
    Location
    on the bleeding edge
    Beans
    1,011

    Re: HOWTO: Configuring Logitech mice in Ubuntu 6.06: New Guide

    I need a little bit of clarification here... in /etc/udev/rules.d/19-local.rules, if i decide to go for, say, event9, should the line look like this:

    KERNEL=="event[9]*", SYSFS{../name}=="Logitech USB-PS/2 Optical Mouse", NAME="input/event9"

    or

    KERNEL=="event9*", SYSFS{../name}=="Logitech USB-PS/2 Optical Mouse", NAME="input/event9"

  9. #479
    Join Date
    Oct 2005
    Location
    California
    Beans
    572
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: HOWTO: Configuring Logitech mice in Ubuntu 6.06: New Guide

    Quote Originally Posted by KhaaL View Post
    I need a little bit of clarification here... in /etc/udev/rules.d/19-local.rules, if i decide to go for, say, event9, should the line look like this:

    KERNEL=="event[9]*", SYSFS{../name}=="Logitech USB-PS/2 Optical Mouse", NAME="input/event9"

    or

    KERNEL=="event9*", SYSFS{../name}=="Logitech USB-PS/2 Optical Mouse", NAME="input/event9"
    I think it's the first one, but I don't remember for sure anymore as I don't use the udev rule anymore but use the name directly in xorg.conf.

    Code:
    Section "InputDevice"
        Identifier     "Configured Mouse"
        Driver         "evdev"
        Option         "CorePointer"
        Option         "Name" "Logitech USB-PS/2 Optical Mouse"
    EndSection
    aka anime4christ (I'm a guy, btw.)
    My personal boring website ^_^
    Jesus has changed your life. Save changes? (Y/N)

  10. #480
    Join Date
    Jul 2006
    Location
    on the bleeding edge
    Beans
    1,011

    Re: HOWTO: Configuring Logitech mice in Ubuntu 6.06: New Guide

    oh, well that looks a lot easier and more practical... I'll try it as soon as i get home!

Page 48 of 65 FirstFirst ... 38464748495058 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •