Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: DosBox Resolution Problems

  1. #1
    Join Date
    Apr 2008
    Location
    USA
    Beans
    1,060
    Distro
    Ubuntu 12.04 Precise Pangolin

    Exclamation DosBox Resolution Problems

    Hi everyone,

    I'm using DBGL to play Dune (not Dune 2), and the problem is whenever I play Dune in fullscreen mode, my Ubuntu desktop screen resolution gets changed to the resolution Dune goes into. How can I fix this? I have to log out of my desktop session to get the screen resolution back to normal, which is 1440x900. Any help is appreciated, thanks!
    Question Everything

  2. #2
    Join Date
    Apr 2005
    Location
    EU - UK
    Beans
    3,259
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: DosBox Resolution Problems

    Edit the profile for the game, click on the Display tab, set the Output to openglnb and the Fullscreen Resolution to the native for your monitor, if you can find it. If not (tbh, dbgl should be changed to ask randr for the available resolutions instead of presenting you with a list of hard coded resolutions), then set it to some random value (e.g. 1024x768) and press OK. After that you will need to locate the configuration file for the game in
    Code:
    ~/.dbgl/profiles
    (whereas ~/ means your home folder; in your home folder, press CTRL+H to see hidden folders, or select View -> Show Hidden Files from the menu)
    where it should be named after its position in your game list -for example if it is listed second in dbgl, its conf file should be 2.conf- open it and change the line
    from
    Code:
    [sdl]
    fullresolution=1024x768
    to
    Code:
    [sdl]
    fullresolution=desktop
    Also you might want to enable the Aspect Correction option, as it will not stretch the game to fit the resolution of your widescreen monitor, although you might like it that way, stretched.

    Hope that helps.

  3. #3
    Join Date
    Apr 2008
    Location
    USA
    Beans
    1,060
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: DosBox Resolution Problems

    Quote Originally Posted by kostkon View Post
    Edit the profile for the game, click on the Display tab, set the Output to openglnb and the Fullscreen Resolution to the native for your monitor, if you can find it. If not (tbh, dbgl should be changed to ask randr for the available resolutions instead of presenting you with a list of hard coded resolutions), then set it to some random value (e.g. 1024x768) and press OK. After that you will need to locate the configuration file for the game in
    Code:
    ~/.dbgl/profiles
    (whereas ~/ means your home folder; in your home folder, press CTRL+H to see hidden folders, or select View -> Show Hidden Files from the menu)
    where it should be named after its position in your game list -for example if it is listed second in dbgl, its conf file should be 2.conf- open it and change the line
    from
    Code:
    [sdl]
    fullresolution=1024x768
    to
    Code:
    [sdl]
    fullresolution=desktop
    Also you might want to enable the Aspect Correction option, as it will not stretch the game to fit the resolution of your widescreen monitor, although you might like it that way, stretched.

    Hope that helps.
    Thanks for replying! For the Fullscreen Resolution drop down menu in DBGL, there's no option to select my native screen resolution of 1440x900. The highest option I have is 1280x1024. Is that okay?
    Question Everything

  4. #4
    Join Date
    Apr 2005
    Location
    EU - UK
    Beans
    3,259
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: DosBox Resolution Problems

    Quote Originally Posted by Shadius View Post
    Thanks for replying! For the Fullscreen Resolution drop down menu in DBGL, there's no option to select my native screen resolution of 1440x900. The highest option I have is 1280x1024. Is that okay?
    Obviously, not; and by that, I mean you will need to edit its conf file, as I described in my previous post.

    Also the numbering starts from 0 so the line
    where it should be named after its position in your game list -for example if it is listed second in dbgl, its conf file should be 2.conf- open it and change the line
    needs to be changed to
    where it should be named after its position in your game list -for example if it is listed second in dbgl, its conf file should be 1.conf- open it and change the line
    Hope that helps.

  5. #5
    Join Date
    Apr 2008
    Location
    USA
    Beans
    1,060
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: DosBox Resolution Problems

    Okay, got it. Thanks for the help.
    Question Everything

  6. #6
    Join Date
    Apr 2005
    Location
    EU - UK
    Beans
    3,259
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: DosBox Resolution Problems

    If you want that to apply globally to all your games, then you could create a new template (or edit one) and then change its resolution manually, like you did for your profile; templates should be in ~/.dbgl/templates.

  7. #7
    Join Date
    Apr 2008
    Location
    USA
    Beans
    1,060
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: DosBox Resolution Problems

    So that helped me make some progress, however, when I exit fullscreen mode from the game, my desktop's resolution changes to 1280x1024.
    Question Everything

  8. #8
    Join Date
    Apr 2005
    Location
    EU - UK
    Beans
    3,259
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: DosBox Resolution Problems

    Quote Originally Posted by Shadius View Post
    So that helped me make some progress, however, when I exit fullscreen mode from the game, my desktop's resolution changes to 1280x1024.
    Do you mean you exit fullscreen mode while the game is running? And how?

  9. #9
    Join Date
    Apr 2008
    Location
    USA
    Beans
    1,060
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: DosBox Resolution Problems

    Quote Originally Posted by kostkon View Post
    Do you mean you exit fullscreen mode while the game is running? And how?
    When I press ALT+Enter to exit fullscreen mode, and also when I completely exit the game.
    Question Everything

  10. #10
    Join Date
    Apr 2005
    Location
    EU - UK
    Beans
    3,259
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: DosBox Resolution Problems

    Quote Originally Posted by Shadius View Post
    When I press ALT+Enter to exit fullscreen mode, and also when I completely exit the game.
    Hmm, you could try this:
    first, make sure that you logout and log back in to revert to your default resolution, then run the game again and while you are there, check your current resolution by using your monitor controls (all monitors usually have an info option in their on-screen menu that displays your current res, refresh rate etc); is it really 1440x900 or 1280x1024?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •