Results 1 to 4 of 4

Thread: Has anyone been able to write HTML5/Phonegap apps with Ubuntu SDK?

  1. #1
    Join Date
    Jan 2014
    Beans
    8

    Has anyone been able to write HTML5/Phonegap apps with Ubuntu SDK?

    I use Ubuntu 13.10. I tried this in two different computers already with identical results.

    I installed Ubuntu SDK following the instructions on the official website
    http://developer.ubuntu.com/apps/create/get-the-sdk/

    I tried to follow this tutorial to write Cordova apps
    http://developer.ubuntu.com/apps/cor...ner-html5-app/
    but I immediately run into trouble since "Cordova Ubuntu HTML5 Touch UI" is not a type of project offered in Qt Creator/Ubuntu SDK.

    Then I go for one of the projects available there. I thought I would try "HTML5 Tabbed Touch UI".
    Some sample html5 project gets created in Qt Creator. When I try to run it I get the following error message.
    Starting ubuntu-html5-app-launcher --www=/home/luis/projects/ubuntu-tabbed-test
    Failed to start program. Path or permissions wrong?
    ubuntu-html5-app-launcher exited with code -1

    I can solve this one installing the package ubuntu-html5-container, but I thought it would be worth reporting it, since it might be useful to some people.

    After installing that package, I try to run my sample html5 project again and I get the following error message.

    Starting ubuntu-html5-app-launcher --www=/home/luis/projects/ubuntu-tabbed-test
    /usr/bin/ubuntu-html5-app-launcher: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory
    ubuntu-html5-app-launcher exited with code 127


    I don't know how to solve this one. Like I said before, the same procedure gave me identical results in two different computers. I am following the official instructions from the Ubuntu website, so I was expecting this would work without severe glitches. The QML projects on Ubuntu SDK seem to work fine.

    The package libqt5core5 is installed with version 5.0.2+dfsg1-7ubuntu11.1 and it certainly contains the file libQt5Core.so.5.

    My questions are:
    1. How do I make Cordova apps with Ubuntu SDK? Is there a tutorial that fits the current reality?
    2. How do I fix the error above?

  2. #2
    Join Date
    Nov 2012
    Beans
    8

    Re: Has anyone been able to write HTML5/Phonegap apps with Ubuntu SDK?

    I have the same problem and I have not been able to find a solution.

  3. #3
    Join Date
    Nov 2013
    Location
    Central Europe
    Beans
    13
    Distro
    Ubuntu

    Re: Has anyone been able to write HTML5/Phonegap apps with Ubuntu SDK?

    Same here. I've tried a few things, but none of them work. And I think that it's not an optimal solution to add JavaScripts into the head, which do not exist at all
    <scriptsrc="/usr/share/ubuntu-html5-ui-toolkit/0.1/ambiance/js/fast-buttons.js"></script>

    I have to install them on my own, and I just figured it out accidentally. How can I build WebApps/Html5Apps for Ubuntu? :/

  4. #4
    Join Date
    Mar 2013
    Beans
    35

    Re: Has anyone been able to write HTML5/Phonegap apps with Ubuntu SDK?

    Quote Originally Posted by stefan_03 View Post
    Same here. I've tried a few things, but none of them work. And I think that it's not an optimal solution to add JavaScripts into the head, which do not exist at all
    <scriptsrc="/usr/share/ubuntu-html5-ui-toolkit/0.1/ambiance/js/fast-buttons.js"></script>

    I have to install them on my own, and I just figured it out accidentally. How can I build WebApps/Html5Apps for Ubuntu? :/
    Open Ubuntu SDK, New Project->Ubuntu(project)->HTML5 TOUCH UI

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •