Results 1 to 3 of 3

Thread: Cinelerra - Problems with installation

  1. #1
    Join Date
    Sep 2013
    Beans
    7

    Question Cinelerra - Problems with installation

    After adding Cinelerra to my list of repositories (sudo apt-add-repository ppa:cinelerra-ppa/ppa), and running sudo apt-get update and sudo apt-get install cinelerra-cv, I got the following error messages:
    Code:
    cannot open locale definition file `de_DE': No such file or directory
    dpkg: error processing cinelerra-cv (--configure):
     subprocess installed post-installation script returned error exit status 4
    However, Cinelerra appears to have been installed and can be launched without significant problems; but now Cinelerra displays the following errors:
    Code:
    voidMWindow::init_shm():WARNING: /proc/sys/kernel/shmmax is 0x2000000, which is too low
    Before running Cinelerra do the following as root:
    echo "0x7fffffff" >/proc/sys/kernel/shmmax
    I wonder, do the above error messages constitute a problem and should they be treated with concern? I understand that this is probably some minor issue, given the fact that the program runs, but still, is it likely to cause any problems in the future?

  2. #2
    Join Date
    Jan 2014
    Beans
    3

    Re: Cinelerra - Problems with installation

    Quote Originally Posted by gianfranco2;12889322
    [I
    subprocess installed post-installation script returned error exit status 4[/I]
    For Cinelerra - no problem. But you will have problems with the installation and removal of other programs.
    Simply make a now:
    Code:
    sudo rm /var/lib/dpkg/info/cinelerra-cv.postinst
    Code:
    sudo dpkg --configure -a
    If you look at the script cinelerra-cv.postinst, you'll see it:
    ...# this add iso-8859-15 to all language suppoted by cinelerra
    for i in de_DE es_ES fr_FR it_IT pt_BR sl_SI eu_ES eu_FR
    do
    if ! localedef --list-archive | grep $i | grep iso885915
    then localedef -c -i $i -f ISO-8859-15 $i.ISO-8859-15
    .....
    This script wants to add locale de_DE.ISO-8859-15, but does not find it in your system.

    This is a frequent question. I already answered this question here http://forum.ubuntu.ru/index.php?top...;topicseen#new and make screenshots. But there it is written in Russian.
    ---------------------

    http://forums.gentoo.org/viewtopic-t...1-start-0.html
    shmmax is just the maximum sized memory segment a process can request, an increase shouldn't really be a security issue, and the increase they're asking for is only 4 times the default, which isn't that much.

    You can just add "kernel.shmmax 134217728" to /etc/sysctl.conf to have it set to 0x8000000 upon each boot.
    Alternatively you could just run the echo command as suggested, and then run `echo 33554432 > /proc/sys/kernel/shmmax` to reset it to the default when finished with cinerella, if you're really concerned about it.
    http://www.g-raffa.eu/Cinelerra/HOWTO/installation.html
    How to approach the Cinelerra error message you get at start up


    When you start Cinelerra you get an error message saying:

    The following errors occurred:
    void MWindow::init_shm0: WARNING:/proc/sys/kernel/shmmax is 0x2000000, which is too low.
    Before running Cinelerra do the following as root:
    echo "0x7ffffff">/proc/sys/kernel/shmmax

    Actually this message is not an error, but rather a reminder.
    shmmax is a configurable kernel parameter that defines the system-wide maximum allowable shared memory. Shared Memory (shm) is an efficeint means of passing data between programs. One program will create a memory portion which other processes can access. This error message asks you to increase the shared memory allocated by default on the Linux kernel.

    What to do?

    Option 1:
    Ignore this message. You won’t get in any trouble because of this.

    Option 2:
    Do what you are told. That is open a terminal and type:

    sudo echo "0x7ffffff">/proc/sys/kernel/shmmax

    This command will increase the shared memory during your work session.

    Option 3:
    Open a terminal and type:

    sudo sysctl -w kernel.shmmax=0x7fffffff

    This way you have increased the shared memory permanently.

    You can obtain the same effect by manually editing the configuration file for setting system variables.
    Open a terminal and type:

    sudo gedit /etc/sysctl.conf

    At the bottom of the file, add those lines:

    # Make Cinelerra happy

    kernel.shmmax=0x7fffffff

    Save and close.
    This is another way to increase the shared memory permanently.
    Last edited by fghj8812; January 3rd, 2014 at 04:10 PM.

  3. #3
    Join Date
    Sep 2013
    Beans
    7

    Re: Cinelerra - Problems with installation

    Thank you for replying to my question! I am reinstalling the system now (upgrading to Xubuntu 13.10) but this information, I think, will definitely prove useful in the future when reinstalling the application.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •