Results 1 to 10 of 10

Thread: Ati radeon problem - disable integrated card

  1. #1
    Join Date
    Mar 2013
    Beans
    8

    Ati radeon problem - disable integrated card

    Hi,
    I moved from Windows to Kubuntu and my system cant detect the Radeon I have.Its a hybrid system so only the Intel card is detected and not the radeon.

    Code:
    lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
    I cant disable the integrated from my BIOS and wud like have only Radeon. I have tried amd website driver, the jockey driver and also I think the open source radeon.

    Cant really say if its working or wants to work as I have always booted with the integrated card and dont know to disable it.

    All help appreciated.

  2. #2
    Join Date
    Mar 2013
    Beans
    8

    Re: Ati radeon problem - disable integrated card

    So am I stuck with the integrated card or is there a way.

  3. #3
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Ati radeon problem - disable integrated card

    Hello!

    You don't mention which version you are using, but if you are using 13.10, you may be in luck.

    Uninstall any proprietary driver you have installed and have a look here.

    Also install fglrx-amdcccle. You'll need to use the Catalyst Control Center to switch back and forth between integrated and dedicated graphics.

    Cheers.
    Last edited by QIII; December 28th, 2013 at 10:50 AM.

  4. #4
    Join Date
    Mar 2013
    Beans
    8

    Re: Ati radeon problem - disable integrated card

    Thanks for the reply.
    I tried 13.10 and got only a black screen after the kubuntu logo. So I moved to 12.04.
    I will try out the solution you have suggested.

  5. #5
    Join Date
    Mar 2013
    Beans
    8

    Re: Ati radeon problem - disable integrated card

    Right, I tried doing whats there on the link, jockey-kde shows driver installed.But I cant turn opengl or the AMDcatalyst centre.
    Might move to LinuxMint and see if it deals with things differently.

  6. #6
    Join Date
    Mar 2013
    Beans
    8

    Re: Ati radeon problem - disable integrated card

    Heres the output of lshw -C display

    *-display
    description: VGA compatible controller
    product: Haswell-ULT Integrated Graphics Controller
    vendor: Intel Corporation
    physical id: 2
    bus info: pci@0000:00:02.0
    version: 09
    width: 64 bits
    clock: 33MHz
    capabilities: vga_controller bus_master cap_list rom
    configuration: driver=i915 latency=0
    resources: irq:62 memory:c0000000-c03fffff memory:b0000000-bfffffff ioport:5000(size=64)
    *-display
    description: Display controller
    product: Sun XT [Radeon HD 8670A/8670M/8690M]
    vendor: Hynix Semiconductor (Hyundai Electronics)
    physical id: 0
    bus info: pci@0000:03:00.0
    version: 00
    width: 64 bits
    clock: 33MHz
    capabilities: bus_master cap_list rom
    configuration: driver=fglrx_pci latency=0
    resources: irq:16 memory:a0000000-afffffff memory:c0500000-c053ffff ioport:3000(size=256) memory:c0540000-c055ffff
    WARNING: output may be incomplete or inaccurate, you should run this program as super-user.


    So is there no way to disable the intel card just keep the radeon.

  7. #7
    Join Date
    May 2007
    Beans
    12,536

    Re: Ati radeon problem - disable integrated card

    Switchable graphics like these pose serious problems in Linux as the video card manufacturers don't make Linux drivers for them -- leaving us to "hack" around for solutions. Read through the linked thread to see if anything there helps: http://askubuntu.com/questions/20511.../288355#288355
    Ubuntu 14.04, Mint 17; MS Win 8.1.
    Will not respond to PM requests for support -- use the forums.

  8. #8
    Join Date
    Mar 2013
    Beans
    8

    Re: Ati radeon problem - disable integrated card

    I tried that link, very useful , but I am getting
    aticonfig: No supported adapters detected
    The open source driver doesnt support 8x cards and the above tutorial doesnt go further cuz of aticonfig error.
    This is not going to be as easy as nvidia is it.

  9. #9
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Ati radeon problem - disable integrated card

    Intel/Nvidia hybrids are no better.

  10. #10
    Join Date
    Mar 2013
    Beans
    8

    Re: Ati radeon problem - disable integrated card

    I am leaving it as it for now, did too many installs of ubuntu and nothing seems to work. Fglrx seems to be necessary for video playback so I have fglrx-updates installed for now. If I try to install anything from jockey, it says this driver is activated but not in use right now. So I dont get all the Desktop Effects, no openGL,etc. Dont know if something like Blender will take advantage of the Radeon card at all.

    So thanks for the help but it seems there is no straight way to get hybrids working right now.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •