Results 1 to 6 of 6

Thread: Problem getting applications to autostart at start up

  1. #1
    Join Date
    Apr 2009
    Location
    Spain
    Beans
    350
    Distro
    Lubuntu 14.04 Trusty Tahr

    Problem getting applications to autostart at start up

    Hi,


    I'm running Lubuntu 13.10 on a desktop computer.


    I want Wuala and Ubuntu One to launch automatically on start up. ("Connect automatically when computer starts" is checked in Ubuntu One client, but even so it does not start automatically). I have dropped their desktop files from /usr/share/applications to .config/autostart, but this doesn't help.


    What else can I do to force them to start automatically?


    Many thanks.

  2. #2
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,315
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Problem getting applications to autostart at start up

    Things have changed in Lubuntu 13.10.

    Edit ~/.config/lxsession/Lubuntu/autostart.
    Add the appropriate command on a separate line to the end of the existing file. If such a file doesn't exist, create it with Leafpad or nano.

    This is my autostart file:
    Code:
    /home/vasa1/.dropbox-dist/dropbox
    /home/vasa1/bin/cpu-usage-alert.sh
    Note that there's no need for the older way of dropping .desktop files into ~/.config/autostart. That doesn't work anymore.
    Last edited by vasa1; December 24th, 2013 at 02:04 PM.

  3. #3
    Join Date
    Apr 2009
    Location
    Spain
    Beans
    350
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Problem getting applications to autostart at start up

    Thanks, that's given me a clue. Unfortunately, I am unsure how to formulate the commands to open the applications I have mentioned. Can anyone tell me?

  4. #4
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,315
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Problem getting applications to autostart at start up

    Quote Originally Posted by rdh61 View Post
    Thanks, that's given me a clue. Unfortunately, I am unsure how to formulate the commands to open the applications I have mentioned. Can anyone tell me?
    I don't use either. Let's hope someone who does comes this way!

  5. #5
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Problem getting applications to autostart at start up

    For UbuntuOne, the command is:
    Code:
    /usr/bin/ubuntuone-launch
    I don't use Wuala, but according to the documentation, this should work:
    Code:
    /usr/bin/wuala

  6. #6
    Join Date
    Apr 2009
    Location
    Spain
    Beans
    350
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Problem getting applications to autostart at start up

    Thank you. In the meantime I found the general answer here, and copied the Exec commands from the .desktop files:

    https://help.ubuntu.com/community/Lu...g_into_Desktop

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •