Results 1 to 6 of 6

Thread: My AMD system is very laggy on Ubuntu 13.10

  1. #1
    Join Date
    Dec 2013
    Beans
    2

    My AMD system is very laggy on Ubuntu 13.10

    My sytsem is AMD FX 6300 8GB Ram and ATI 300 HD on board graphics which looks like a decent build but Ubuntu is very laggy specially the Unity, I have seen Unity operating much more smoother on very low end system but mine is pretty decent and I am using free ATI drivers, i tried non-free legacy drivers in other distros but they were horrible, can't even play a video file properly. Should I stick with free drivers or start using Non Free Legacy drivers ?

  2. #2
    Join Date
    Aug 2005
    Beans
    5,990

    Re: My AMD system is very laggy on Ubuntu 13.10

    Get a new GPU I reckon, even a lowly GT610 will be better.

  3. #3
    Join Date
    Dec 2013
    Beans
    2

    Re: My AMD system is very laggy on Ubuntu 13.10

    I understand but for time being what should i do, please reply to the post ?

  4. #4
    Join Date
    Aug 2005
    Beans
    5,990

    Re: My AMD system is very laggy on Ubuntu 13.10

    Quote Originally Posted by rahulbali View Post
    I understand but for time being what should i do, please reply to the post ?
    Sorry I have very little experience with ATI GPUs, especially one that old. Hopefully someone else has some good advice.

  5. #5
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: My AMD system is very laggy on Ubuntu 13.10

    Moved to General Help.

  6. #6
    Join Date
    Dec 2005
    Location
    Western Australia
    Beans
    11,478
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: My AMD system is very laggy on Ubuntu 13.10

    You need to remove the non-free ATI driver if you have installed it. It wontbwork with your old graphics card. Only the default, open-source one will work, albeit with low performance.

    Unity can be sped up by turning off animations and semitransparency which causes most of the speed problems you notice on that old video card. Do a Google search, it is easy to turn off the animations and transparency and it makes a real difference on old ATI cards.

    If you can't find the instructions on Google, PM me and I'll find the instructions for you from my archive.
    I try to treat the cause, not the symptom. I avoid the terminal in instructions, unless it's easier or necessary. My instructions will work within the Ubuntu system, instead of breaking or subverting it. Those are the three guarantees to the helpee.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •