Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: LXDE-Core + tightvncserver. Chromium won't work

  1. #1
    Join Date
    Dec 2013
    Beans
    33

    LXDE-Core + tightvncserver. Chromium won't work

    On a clean ubuntu VPS, I installed
    Code:
    apt-get install xorg lxde-core tightvncserver
    with the following xstartup settings:

    Code:
    #!/bin/sh
    
    xrdb $HOME/.Xresources
    xsetroot -solid grey
    #x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
    #x-window-manager &
    # Fix to make GNOME work
    export XKL_XMODMAP_DISABLE=1
    /etc/X11/Xsession
    lxterminal &
    /usr/bin/lxsession -s LXDE &
    I'm able to successfully VNC to the LXDE desktop. I then install chromium with:
    Code:
    sudo apt-get install chromium-browser
    When I try to start chromium, the program launches and immediately crashes. When I try to run from the command line, I get the following message:

    Code:
    Xlib extension “RANDR” missing on display ":1"
    For the life of me I can't figure out how to resolve this. I'm a newbie to all of this, and uncertain if this is an issue with LXDE or Tightvnc.

    Any tips on what could be causing this? Let me know if there's any other information I can share.

  2. #2
    Join Date
    Apr 2012
    Beans
    5,139

    Re: LXDE-Core + tightvncserver. Chromium won't work

    I think it means that your tightvncserver does not support the Xlib RANDR extension - however this usually isn't fatal, I get the same message starting firefox in an LXDE session over tightvnc, but it runs just fine. *If* that's what's causing chromium to crash (and I have doubts about that) then arguably it's chromium's issue for not handling it more gracefully. I *think* that the RANDR extension should only be required for stuff like dynamic display resiszing / rotation.

    If you still believe the missing RANDR support is the issue, you could try vnc4server instead of tightvncserver

  3. #3
    Join Date
    Dec 2013
    Beans
    33

    Re: LXDE-Core + tightvncserver. Chromium won't work

    Thanks for the help. Any ideas on what else it could be? I literally only installed lxde-core and tightvnc. The only other setting that was made besides what was previously mentioned was the following to force tightvnc to start at boot...

    Code:
    vi /etc/init.d/tightvncserver
    Code:
    #!/bin/sh -e### BEGIN INIT INFO
    # Provides:          vncserver
    # Required-Start:    networking
    # Default-Start:     S
    # Default-Stop:      0 6
    ### END INIT INFO
    
    
    PATH="$PATH:/usr/X11R6/bin/"
    
    
    # The Username:Group that will run VNC
    export USER="user1"
    #${RUNAS}
    
    
    # The display that VNC will use
    DISPLAY="1"
    
    
    # Color depth (between 8 and 32)
    DEPTH="16"
    
    
    # The Desktop geometry to use.
    #GEOMETRY="<WIDTH>x<HEIGHT>"
    #GEOMETRY="800x600"
    GEOMETRY="1024x768"
    #GEOMETRY="1280x1024"
    
    
    # The name that the VNC Desktop will have.
    NAME="dekstop1"
    
    
    OPTIONS="-name ${NAME} -depth ${DEPTH} -geometry ${GEOMETRY} :${DISPLAY}"
    
    
    . /lib/lsb/init-functions
    
    
    case "$1" in
    start)
    log_action_begin_msg "Starting vncserver for user '${USER}' on localhost:${DISPLAY}"
    su ${USER} -c "/usr/bin/vncserver ${OPTIONS}"
    ;;
    
    
    stop)
    log_action_begin_msg "Stoping vncserver for user '${USER}' on localhost:${DISPLAY}"
    su ${USER} -c "/usr/bin/vncserver -kill :${DISPLAY}"
    ;;
    
    
    restart)
    $0 stop
    $0 start
    ;;
    esac
    
    
    exit 0

    Code:
    sudo chmod +x /etc/init.d/tightvncserversudo update-rc.d tightvncserver defaults

  4. #4
    Join Date
    Apr 2012
    Beans
    5,139

    Re: LXDE-Core + tightvncserver. Chromium won't work

    Are there multiple users / X sessions / displays running? does it work if you only have a single active session / display?

  5. #5
    Join Date
    Dec 2013
    Beans
    33

    Re: LXDE-Core + tightvncserver. Chromium won't work

    Just the one session and display running as far as I can tell. Firefox works just fine, but unfortunately need Chromium for this project.

  6. #6
    Join Date
    Apr 2012
    Beans
    5,139

    Re: LXDE-Core + tightvncserver. Chromium won't work

    Well I just tested it on my 12.04.03 laptop and chromium works for me on an lxsession via tightvnc

    Maybe try starting chromium-browser with the --temp-profile switch in case it's a profile corruption issue? if that fails, there's a -g or --debug option

  7. #7
    Join Date
    Dec 2013
    Beans
    33

    Re: LXDE-Core + tightvncserver. Chromium won't work

    Thanks for testing that out for me! I'll give that a shot and report back...

  8. #8
    Join Date
    Dec 2013
    Beans
    33

    Re: LXDE-Core + tightvncserver. Chromium won't work

    Unfortunately that didn't work. I tried running with xrdp vnc and same issue, so must be something other than the vlc.

  9. #9
    Join Date
    Dec 2013
    Beans
    33

    Re: LXDE-Core + tightvncserver. Chromium won't work

    Installed lxde-core on a brand new vps and still having the same issue. I wonder if it has something to do with color depth or something simple I'm overlooking.

  10. #10
    Join Date
    Apr 2012
    Beans
    5,139

    Re: LXDE-Core + tightvncserver. Chromium won't work

    is there anything in ~/.xsession-errors (apart from the Xlib RANDR extension messages)?

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •