Results 1 to 6 of 6

Thread: Error in apt-get for SourceForge

  1. #1
    Join Date
    Nov 2006
    Location
    Minnesota
    Beans
    16
    Distro
    Ubuntu 12.04 Precise Pangolin

    Error in apt-get for SourceForge

    In followed the guide lines on the site but after running sudo apt-get update I get an error.

    W: Failed to fetch http://downloads.sourceforge.net/pro...ts/all/Release
    Unable to find expected entry 'main/source/Sources' in Release file (Wrong sources.list entry or malformed file)

    New at this so I don't really know what this means, as far as where I went wrong.

    The instruction page is a little different than my verson, but it seamed to go well until I verified.

    Any help would be great.

    DPMR

  2. #2
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,840
    Distro
    Ubuntu Development Release

    Re: Error in apt-get for SourceForge

    we would like to help you but its only possible with your sources list. show us your sources.list with

    cat /etc/apt/sources.list
    Google First your issue , if no solution then ask.

    రాజ శేఖర్ రెడ్డి

  3. #3
    Join Date
    Nov 2006
    Location
    Minnesota
    Beans
    16
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Error in apt-get for SourceForge

    niverse multiverse

    deb http://security.ubuntu.com/ubuntu precise-security main restricted
    deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
    deb http://security.ubuntu.com/ubuntu precise-security universe
    deb-src http://security.ubuntu.com/ubuntu precise-security universe
    deb http://security.ubuntu.com/ubuntu precise-security multiverse
    deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    deb http://archive.canonical.com/ubuntu oneiric partner
    deb-src http://archive.canonical.com/ubuntu oneiric partner

    ## This software is not part of Ubuntu, but is offered by third-party
    ## developers who want to ship their latest software.
    deb http://extras.ubuntu.com/ubuntu precise main
    deb http://downloads.sourceforge.net/pro...la/mozilla/apt all main
    deb-src http://downloads.sourceforge.net/pro...la/mozilla/apt all main
    deb-src http://extras.ubuntu.com/ubuntu precise main

  4. #4
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,070
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Error in apt-get for SourceForge

    Quote Originally Posted by DPMR View Post
    In followed the guide lines on the site but after running sudo apt-get update I get an error.

    W: Failed to fetch http://downloads.sourceforge.net/pro...ts/all/Release
    Unable to find expected entry 'main/source/Sources' in Release file (Wrong sources.list entry or malformed file)
    Could be you just got directed to a borked sourceforge mirror. Just try the 'sudo apt-get update' again a few times and see if this goes away.
    Let know how that goes.

  5. #5
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    8,463
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Error in apt-get for SourceForge

    DPMR; Hello ;

    I see two points in your sources list file that needs addressing:
    The first is :
    Should be expanded to this URL:
    Code:
    deb http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main
    deb-src http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main
    Copy paste into your sources list file (make a back up prior to editing !)
    Not real sure about that "all" ?????? _ never seen that option in the field before - maybe Mozilla accepts that format(?).

    2nd:
    oneiric has reached end of life and is no longer supported. If this fetch line is a duplicate of one for precise, then delete these lines.
    Else change "oneric" to "precicse".

    Give it a run and let us know the results.

    just try'n to help
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  6. #6
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,070
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Error in apt-get for SourceForge

    Quote Originally Posted by Bashing-om View Post
    DPMR; Hello ;
    Should be expanded to this URL:
    Code:
    deb http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main
    deb-src http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main
    Actually ubuntuzilla doesn't host sources, only mozilla-built binaries. so deb-src won't do anything even if you try to apt-get source.
    So his one line,
    Code:
    deb http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main
    should be just fine.

    Copy paste into your sources list file (make a back up prior to editing !)
    Not real sure about that "all" ?????? _ never seen that option in the field before - maybe Mozilla accepts that format(?).
    The ubuntuzilla (mozilla) binaries are not distribution-version specific, they're the same for any ubuntu/debian version. Hence they just live under 'all'.

    2nd:
    oneiric has reached end of life and is no longer supported. If this fetch line is a duplicate of one for precise, then delete these lines.
    Else change "oneric" to "precicse".
    Yes, that seems weird, that he's mixing precise and oneiric. You're right, if he's running precise, should probably edit that. That said, it should not have anything to do with the ubuntuzilla repo failing.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •