Results 1 to 5 of 5

Thread: 13.10 'gnome classic' top-menu bar not actually the 'classic' one on fresh install

  1. #1
    Join Date
    Nov 2007
    Beans
    41

    13.10 'gnome classic' top-menu bar not actually the 'classic' one on fresh install

    I've installed on an HP Elitebook 8440p.
    --> Logged in to Unity, installed 'Gnome shell', logged into that, decided I didn't like it;
    --> Logged out, back into unity, tried to 'remove' Gnome shell prior to adding 'Gnome shell classic', but nothing happened when I pushed remove,
    so I just added 'Gnome shell classic' , logged out, and logged into that.

    Almost there, except that the top of the screen now has this unfamiliar (and very 'work-in-progressy') black-on-gray Applications/Places menu, with the following problems:

    (1) The menu items are large, with even larger icons in the submenus, so I have to actually scroll submenus to reach some of them, even on a fresh install (only 11 1/2 are visible in a scrolled menu).

    (2) In the desktop I'm used to, I can drag any item from the menu to the top bar to make a launcher, so that the next time I want 'terminal', I can just click on the launcher instead of (as here) : (a) clicking on Applications (b) mousing down to 'utilities' (c) moving to the right towards the scroll bar (while noticing that the 'utilities' choice does not remain indicated in any way) (d) scrolling down so that 'terminal', the 2nd last item, becomes visible and (d) clicking it.
    In this menu I can't drag items anywhere, and in this whole bar and menu the right-click either does nothing or does the same as the left-click.

    And, the 'current' app is shown in the top bar (name prettily overlaid on the icon), in the space where I want to add my launchers, which is redundant since it's also highlighted on the bottom bar - and the bottom bar shows the app's actual window title, the top one just shows the static name. When I click on that item I get what is apparently a place-holder for what could someday be the application's main-window control menu (with minimize, move to other desktop, etc) but for now it contains only 'Close' (which is spelled "Quit" ).

    The odd thing is, I installed on a desktop a few weeks ago, and did not have this problem, I have the proper menu there; it's possible I didn't add 'Gnome shell' there but I went straight to 'Gnome Classic'.

    Could anyone help me get back the more functional version?

  2. #2
    Join Date
    Nov 2007
    Beans
    41

    Re: 13.10 'gnome classic' top-menu bar not actually the 'classic' one on fresh instal

    I've been trying to fix this with 'tweak tool'. The 'font scaling factor' I've reduced to 0.9 which is helpful on this smallish screen (1366x768), but it doesn't increase the number of items visible in the applications menu (since that is dominated by the size of the icons).

    The're a switch in there -- 'application menu' (on/off) -- which I thought might be helpful with the above but it seems to have no effect at all (nor can I find an explanation of what its effect should be).

  3. #3
    Join Date
    Apr 2008
    Beans
    10,441

    Re: 13.10 'gnome classic' top-menu bar not actually the 'classic' one on fresh instal

    Have a look here:

    http://ubuntuforums.org/showthread.php?t=2185161

    And here:

    http://ubuntuforums.org/showthread.p...5#post12857225

    The latter of the two refers back to my Precise guide:

    http://ubuntuforums.org/showthread.php?t=1966370

    Basically you need to install 'gnome-panel' and then select "GNOME Flashback" for a session running Compiz or "GNOME Flashback (no effects)" for a session running Metacity.

  4. #4
    Join Date
    Nov 2007
    Beans
    41

    Re: 13.10 'gnome classic' top-menu bar not actually the 'classic' one on fresh instal

    Fixed - thank you!

    (Also, I got back the 'suspend' option which is missing from the upper-right on the 'new' menu).

  5. #5
    Join Date
    Apr 2008
    Beans
    10,441

    Re: 13.10 'gnome classic' top-menu bar not actually the 'classic' one on fresh instal

    Quote Originally Posted by gregsmith_to View Post
    Fixed - thank you!

    (Also, I got back the 'suspend' option which is missing from the upper-right on the 'new' menu).
    Glad I was able to help, please feel free to post on that Precise thread if you have any more questions.

    I'm trying to come up with something better for Trusty

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •