Results 1 to 2 of 2

Thread: autogen.sh Problem - ./configure CFLAGS="-03 fails

  1. #1
    Join Date
    Aug 2012
    Location
    Austria
    Beans
    62
    Distro
    Lubuntu

    autogen.sh Problem - ./configure CFLAGS="-03 fails

    Hi all,

    My first compile with ./autogen.sh , and problem.


    1. I get the quarkcoin-cpuminer-2.3.2.tar.gz file from https://github.com/Neisklar/quarkcoin-cpuminer/releases
    2. Extracted to the folder quarkcoin-cpuminer-2.3.2
    3. entered this directory
    4. executed
      Code:
      ./autogen.sh

      (which gives me a Warning, but can be ignored I think, I am right?
      Code:
      Makefile.am:12: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
    5. Then I exetuded ./configure CFLAGS="-03" as advised , but get this, so no "Makefile" was created
      Code:
      hecking build system type... x86_64-unknown-linux-gnuchecking host system type... x86_64-unknown-linux-gnu
      checking target system type... x86_64-unknown-linux-gnu
      checking for a BSD-compatible install... /usr/bin/install -c
      checking whether build environment is sane... yes
      checking for a thread-safe mkdir -p... /bin/mkdir -p
      checking for gawk... gawk
      checking whether make sets $(MAKE)... yes
      checking whether make supports nested variables... yes
      checking whether to enable maintainer-specific portions of Makefiles... no
      checking for style of include used by make... GNU
      checking for gcc... gcc
      checking whether the C compiler works... no
      configure: error: in `/home/istvan/Downloads/quarkcoin-cpuminer-2.3.2':
      configure: error: C compiler cannot create executables
      See `config.log' for more details
    6. Says, whether the C compiler works... no
    7. In config.log in the middle I found this (is this enough for identify the problem?)
      Code:
      configure:3387: $? = 0configure:3376: gcc -v >&5
      Using built-in specs.
      COLLECT_GCC=gcc
      COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.8/lto-wrapper
      Target: x86_64-linux-gnu
      Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.8.1-10ubuntu9' --with-bugurl=file:///usr/share/doc/gcc-4.8/README.Bugs --enable-languages=c,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.8 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.8 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --enable-plugin --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.8-amd64 --with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
      Thread model: posix
      gcc version 4.8.1 (Ubuntu/Linaro 4.8.1-10ubuntu9) 
      configure:3387: $? = 0
      configure:3376: gcc -V >&5
      gcc: error: unrecognized command line option '-V'
      gcc: fatal error: no input files
      compilation terminated.
      configure:3387: $? = 4
      configure:3376: gcc -qversion >&5
      gcc: error: unrecognized command line option '-qversion'
      gcc: fatal error: no input files
      compilation terminated.
      configure:3387: $? = 4
      configure:3407: checking whether the C compiler works
      configure:3429: gcc -03   conftest.c  >&5
      gcc: error: unrecognized command line option '-03'
      configure:3433: $? = 1
      configure:3471: result: no
      configure: failed program was:
      | /* confdefs.h */
      | #define PACKAGE_NAME "cpuminer"
      | #define PACKAGE_TARNAME "cpuminer"
      | #define PACKAGE_VERSION "2.3.2"
      | #define PACKAGE_STRING "cpuminer 2.3.2"
      | #define PACKAGE_BUGREPORT ""
      | #define PACKAGE_URL ""
      | #define PACKAGE "cpuminer"
      | #define VERSION "2.3.2"
      | /* end confdefs.h.  */


    Does this mean that I cannot use
    Code:
    ./configure CFLAGS="-03"
    so I cannot use CFLAGS="-Zero3" ?

    The last step would be to execute "makefile", but I cannot as "Makefile" file was not generated.

    Can anybody help me?

    thx
    Last edited by Resistent; December 8th, 2013 at 03:27 AM.
    THX for your answers

  2. #2
    Join Date
    Jan 2014
    Beans
    1

    Re: autogen.sh Problem - ./configure CFLAGS="-03 fails

    That's the "Optimize" flag. It should be the letter O, not a zero.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •