That was the version I downloaded a while back. I tried to reinstall and it gives me an error but that is because it already is installed.

I have not seen that error, but if you downloaded it from sourceforge it should be ok.